Latest amdgpu-pro would not work properly on Manjaro (last known good is 19.30)

It seems as of 20.20, installing amdgpu-pro on Arch/Manjaro would cause the system to not boot properly. It appears to be a known issue on ArchWiki (that suggested workarounds to use it temporarily for things like DaVinci Resolve). I’m using Cinnamon by the way.

After installing amdgpu-pro 20.40 (using the PKGBUILD, but changing 20.30 to 20.40), X server would segfault, restart, then segfault again, in a very fast and endless loop, that I can’t even type properly from another tty (as X would automatically switch the active tty whenever it restarts). I only managed to break that loop by struggling to switch to tty2 (quickly mashing CTRL-ALT-F2), type my username, password, sudo systemctl start sshd (while the system is still on tty2) then log in to that system from another one and uninstall the amdgpu-pro packages. After the packages were uninstalled, X started successfully and I entered the desktop.

Not sure what caused amdgpu-pro to break on Arch-based Linux distros. It seems 19.30 is the last known good version on Arch/Manjaro, which booted without issues.

EDIT: Not entirely without issues for 19.30. Actually, I tried installing this on my laptop which is using XFCE and I ended up in a white screen after login (so I have to uninstall it). On Cinnamon, however, there’s a minor issue that the terminal app would lose transparency.

Is there a reason you want amdgpu-pro?

Please see this thread:


There are several reasons.

  1. Navi (5700 XT) support on open source stack is not stabilized until 5.7 kernel. I got 100%-reproducible ring sdma0 timeouts during 5.3 and 5.4 kernel at that time (virtually unusable) and only got it fixed by installing amdgpu-pro, until 5.7 (5.6 still had issues with cursors), when I uninstalled amdgpu-pro and the system stayed fine. That was about a year ago and not sure how it is on 5.4 LTS now. I’m currently on 5.8.11 as something seems to be broken on 5.9-rc6.

  2. When mining ETH, with amdgpu-pro 19.30 the DAG buffer can be built within seconds, compared to 1-2 minutes when using amdgpu and the opencl-amd part which was on version 20.30. Not sure which part was the issue (maybe I got it wrong and it was the opencl-amd part that was to blame).

  3. Chromium seems to have some graphical glitches with hardware acceleration recently. However, on the system with amdgpu-pro 19.30, the issue appears to be mitigated. However, it seems with amdgpu-pro 19.30, Cinnamon’s terminal appears to have lost its transparency.

I just tried amdgpu-pro 19.30 on my laptop which is using RX 580 and Manjaro XFCE, but got a white screen instead, after logging in (I can still move the cursor or switch to another tty). So in any case, there’s no perfect version of amdgpu-pro here.

On the other hand, not sure what does the amdgpu-experimental packages do and I’m not sure if it’s compatible with amdgpu-pro and whether the issues I’m having was caused by this package instead of amdgpu-pro itself…