Last Stable Update Broke Sniper Elite 5 EAC

As the title suggests, the last stable update completely broke Sniper Elite 5 its EAC.

I am at a loss for what is causing this, as right before the update it worked perfectly fine.

EDIT: I am referring to the last Manjaro KDE Stable update

You mean you were playing fine, then you quit the game, updated, rebooted, then it stopped working?

yep, exactly

Try to restore your system backup to see if the update actually broke EAC in your game.

I do not have a backup of said date unfortunately, in all fairness I am not the most organized when it comes to backups and such

OK then you can NOT check that. I would be tempted to say the update didn’t break your game and that it is another EAC/Proton (I assume, right?) issue. For example check the Vermintide 2 Steam forum to see people who have EAC working then just restarting the game makes it not work, so this is not unthinkable.

Best bet is to go the the Steam forum of the game or whatever community forum it has, or PRotonDB, or Github issues for Proton.

That would be feasible, if it wasn’t for the fact I tried several proton versions including older ones, rebooted the game multiple times and reinstalled EAC multiple times.

In other words, I am relatively certain nothing regarding Proton is the issue

I found that: Easy AntiCheat :: Sniper Elite 5 General Discussions

EAC is broken probably. I also assume you were not exactly

were you? what is the time frame between when you quit the game and you rebooted and started the game again?

approximately 12 hours, with updates finishing, me shutting down my PC for the night and booting it back up in the morning after

OK then it makes more sense, EAC broke in between this long time frame I guess.

//EDIT: I saw 5 hours ago on the thread, but it was for last post, not the thread. Thread is actually older.

shouldn’t the game have received an update for EAC to become an issue? because the last update was on september 13th

No, EAC has its own update system. Also Steam’s EAC Runtime (that you may or may not need, I don’t know) is independent of the game. It can also be a network issue with EAC’s servers. I’m not sure how to troubleshoot your issue.

//EDIT: something completely stupid to try, to check if the issue comes from an updated system package, is to find an outdated Manjaro mirror server, updating from it with the downgrade option, to return back to previous Stable branch state, but as said this is stupid and may break the system. You can do a Timeshift backup beforehand or whatever system backup solution you use if you want to be stoopid and try.

thanks for you effort anyways, I’ll try to see if I can figure out what is causing this. Although unlikely I will find anything, I will post it here if I do happen to

For info, resources to check when in trouble with a Proton game (not that it will help now but for future reference):

Posting or reading there can help sometimes.

for the sake of accuracy I will be trying to play a different game with EAC, apex legends, but due to RL restrictions I wont be able to actually play it and report findings until later today

Something you could try, is to delete the Proton prefix folder /home/YourName/.local/share/Steam/steamapps/compatdata/1029690/ (or rename it for safe keeping, in case there is some savegame or whatever that will not be imported back from Steam Cloud, so you still have it somewhere), select Proton Experimental or Proton 7 (no other one, they can’t work with EAC), make sure you have EAC Runtime from Steam Tools in your Library, and verify file for the EAC Runtime from Steam, then for the game. At this point start the game and see if it unbreaks.

PS: also note that EAC in a game is not the same EAC in other game, they have different implementations, different versions, so it may not be a reliable test if you want to try many other games.

see here…

wow! thank you for pointing out literally the first thing I saw and tried.

If you’re talking about the glibc issue, it is irrelevant anyway, it was fixed quickly after the 2022-08-07 update.

that yeah

now the game just doesn’t want to boot at all with EAC active… joy
also Apex was just fine, so that was inconclusive

well, that didn’t work. Followed the steps to the letter, but nada. thank you for your efforts though, I hope that this issue gets solved at some point behind the scenes, because at this point I legitimately don’t know what could possibly fix this

the game works without EAC, it just lacks all multiplayer components (including friend to friend coop games… because THAT is a good idea, lets lock friendly coop games behind an anticheat)