Large border around windows when not maximized

When the window is not maximized there is a large border around windows. No idea what causing it any help is appreciated. As it appears correctly in the screenshot that’s why this pic is added.

Thanks in advance.

Go to Settings > Appearance > Window Decorations > Window border size (at the bottom) and change it according to your preference.

@ishaanbhimwal Already done tried all options but no effect.

Which Window decoration are you using? Click on the “pencil icon” and uncheck “Active window glow” in Shadows.

Screenshot

@ishaanbhimwal There is no “Active window glow” option when clicking the pencil icon (only button size).

What are your settings for Settings → Display and Monitor → Compositor

What GPU and driver are you using?

@winnie

Screenshot_20220314_20311

What happens if you force disable and force re-enable compositing?

Press ALT + SHIFT + F12 twice (once to disable, and again to re-enable)

(Still unknown what GPU/driver you’re using.)

By using ALT + SHIFT + F12 it removes this extra border from some applications such as Firefox when pressed once and from other application such as from Dolphin when press twice.

So it’s “solved” for now? When you force disabling/re-enabling Kwin’s compositor, it resolves the issue? :slightly_smiling_face:

You still haven’t shared what GPU/driver you’re using.

@winnie Will this help?

00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Device 2233
        Flags: bus master, fast devsel, latency 0, IRQ 134
        Memory at e0000000 (64-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=512M]
        I/O ports at e000 [size=64]
        Expansion ROM at 000c0000 [virtual] [disabled] [size=128K]
        Capabilities: <access denied>
        Kernel driver in use: i915
        Kernel modules: i915

I’d remove the xf86-video-intel package, if it’s installed, and make sure you don’t have any custom configs under /etc/X11/

pamac list -i | grep xf86-video-intel

ls -l -R /etc/X11/

If it’s installed, and there are no custom configs, remove the package and reboot,

sudo pamac remove xf86-video-intel

Hopefully you’ll get better performance and fewer video/compositor glitches.

However, if it happens again, you can always use ALT + SHIFT + F12 to toggle off/on the Kwin compositor.

Mark post #9 as the solution since it resolves the issue and future readers can benefit.

(Post #13 is for extra performance and reliability.)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.