Laptop with Hybrid graphics, Intel GPU not recognized

#1

inxi -Fx

System:    Host: epc Kernel: 4.20.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: HP product: HP ZBook Studio G5 v: N/A serial: <root required> 
           Mobo: HP model: 8427 v: KBC Version 16.31.00 serial: <root required> UEFI: HP v: Q71 Ver. 01.04.05 date: 11/16/2018 
Battery:   ID-1: BAT0 charge: 92.3 Wh condition: 92.3/92.3 Wh (100%) model: Hewlett-Packard Primary status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 9216 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 53004 
           Speed: 1000 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 1000 2: 1001 3: 1000 4: 1000 5: 1000 6: 1000 7: 1000 
           8: 1000 9: 1000 10: 1001 11: 1000 12: 1001 
Graphics:  Device-1: NVIDIA GP107GLM [Quadro P1000 Mobile] vendor: Hewlett-Packard driver: nvidia v: 415.27 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.3 driver: nvidia resolution: 1920x1080~60Hz 
           OpenGL: renderer: Quadro P1000/PCIe/SSE2 v: 4.6.0 NVIDIA 415.27 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Sound Server: ALSA v: k4.20.7-1-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel bus ID: 00:14.3 
           IF: wlp0s20f3 state: up mac: 5c:5f:67:4a:e8:4f 
Drives:    Local Storage: total: 238.47 GiB used: 7.33 GiB (3.1%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-000H1 size: 238.47 GiB 
Partition: ID-1: / size: 85.43 GiB used: 7.33 GiB (8.6%) fs: ext4 dev: /dev/nvme0n1p7 
           ID-2: swap-1 size: 9.77 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 47.0 C mobo: 45.0 C gpu: nvidia temp: 40 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 257 Uptime: 10m Memory: 15.52 GiB used: 1.16 GiB (7.5%) Init: systemd Compilers: gcc: 8.2.1 Shell: bash 
           v: 5.0.0 inxi: 3.0.30 

mhwd -li


> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.08.09               false            PCI

mhwd

> 0000:01:00.0 (0300:10de:1cbb) Display controller nVidia Corporation:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
          video-nvidia            2018.08.09               false            PCI
    video-nvidia-390xx            2018.08.09               false            PCI
           video-linux            2018.05.04                true            PCI
            video-vesa            2017.03.12                true            PCI

this is the system I am using. I have hard time with the drivers, currently I am using the nvidia 415 with the latest kernel. Problem is that it randomly freezes from time to time and I have not found how to fix that and also that the intel GPU is not recognized at all.

Any ideas?

#2

mhwd seems to think you only have 1 gpu (nvidia) and didn’t install bumblebee stuff

so either try to install bumblebee (with that mhwd thingy) or configure manually (or try other distributions which don’t rely on mwhd)

#3

already attempted to install bumblebee with mhwd, but it results in a blank screen.
Tried also ubuntu where there it installs nouveau driver initially and I have no control over brightness of the screen, and then later i installn nvidia drivers which again resulted in the system crashing from time to time(similar to what i have now)

#4

brightness: “only” keys not working or in general not working?
(e.g. on my laptop keys only work if I use acpi_backlight=vendor in cmdline)

regarding of the crashing issue:
can you check if journalctl logged something which might help?
else you can try acpi_osi values,
(check output of sudo strings /sys/firmware/acpi/tables/DSDT | grep -E ‘Windows|Linux’ and try one of these) maybe it helps for your system crashing issue (probably wont).

sorry cant help with bumblebee issues (no clue about that)

#5

Does this model have some BIOS options to turn off one of the GPU’s ? If so, then that might be the “issue”

#6

@vetzki it is a problem with brightness in general, meaning I can not change it at all. (i have also attempted to install some apps that might help but they did not).

I have tried some of the flags for the acpi but could not find something working. Currently I have the following acpi_osi=! acpi_osi=\"Windows 2015\" but I dont know if it helps any, since the system crashed with and without it.

@bogdancovaciu yes there is a feature to turn off one of the GPUs but i do not want to do that, i am in dual boot with windows and I need both gpus in windows.

#7

this is from the journalctl, after a crash just now

feb 18 17:56:57 erev0s-pc kernel: NVRM: GPU at PCI:0000:01:00: GPU-d9b3baf3-e3c6-9ef5-c151-e1a3750b9de5
feb 18 17:56:57 erev0s-pc kernel: NVRM: Xid (PCI:0000:01:00): 79, GPU has fallen off the bus.
feb 18 17:56:57 erev0s-pc kernel: NVRM: GPU at 00000000:01:00.0 has fallen off the bus.
feb 18 17:56:57 erev0s-pc kernel: NVRM: A GPU crash dump has been created. If possible, please run
                                  NVRM: nvidia-bug-report.sh as root to collect this data before
                                  NVRM: the NVIDIA kernel module is unloaded.

#8

backlight, maybe try
acpi_osi=“Linux” acpi_backlight=vendor

(also check arch wiki backlight stuff https://wiki.archlinux.org/index.php/backlight)
(but again this helps on my laptop, maybe also on yours. probably not.)

(you can edit cmdline when grub menu shows up after reboot so you dont have update-grub each time you test different values)

the crash log is useful (but unfortunately I’ve no clue how you can fix this error. Maybe wait for module update/try older nvidia kernel module[390xx not recommended] or if available test beta drivers)

you can also check nvidia forums if you find help for that issue:
e.g.
https://devtalk.nvidia.com/default/topic/1016888/linux/-quot-gpu-has-fallen-off-the-bus-quot-on-gtx-1070/
https://devtalk.nvidia.com/default/topic/537302/linux/reproducible-nvrm-gpu-at-0000-01-00-0-has-fallen-off-the-bus-both-screens-black-xorg-at-100-/
https://devtalk.nvidia.com/default/topic/1039096/linux/gpu-has-fallen-off-the-bus-gpu-crashes-after-a-while-under-load-ie-playing-games-/

edit:
according to this site https://docs.nvidia.com/deploy/xid-errors/index.html
xid 79 can have lots of causes (hardware error, driver error, system memory corruption, …)

closed #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.