Laptop Webcam Not Working After Kernel Update (VivoBook_ASUSLaptop X509DA_D509DA 1.0 )

$ v4l2-ctl -l
Cannot open device /dev/video0, exiting.

none of the programs recognize the cam
Does anyone know how to solve this?

1 Like

Welcome. See /var/log/Xorg.0.log file and sudo dmesg output for investigate what exactly error is.
See also lsusb/lspci for device details if any. Regards

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)

:+1:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

output of /var/log/Xorg.0.log

[    16.047] (II) AMDGPU(0): Modeline "1920x1080"x0.0  148.52  1920 1968 2000 2230  1080 1083 1089 1110 +hsync -vsync (66.6 kHz eP)
[    21.098] (II) AMDGPU(0): EDID vendor "BOE", prod id 2307
[    21.098] (II) AMDGPU(0): Printing DDC gathered Modelines:
[    21.098] (II) AMDGPU(0): Modeline "1920x1080"x0.0  148.52  1920 1968 2000 2230  1080 1083 1089 1110 +hsync -vsync (66.6 kHz eP)
[    36.095] (II) AMDGPU(0): EDID vendor "BOE", prod id 2307
[    36.095] (II) AMDGPU(0): Printing DDC gathered Modelines:
[    36.095] (II) AMDGPU(0): Modeline "1920x1080"x0.0  148.52  1920 1968 2000 2230  1080 1083 1089 1110 +hsync -vsync (66.6 kHz eP)
[    37.750] (II) AMDGPU(0): EDID vendor "BOE", prod id 2307
[    37.750] (II) AMDGPU(0): Printing DDC gathered Modelines:
[    37.750] (II) AMDGPU(0): Modeline "1920x1080"x0.0  148.52  1920 1968 2000 2230  1080 1083 1089 1110 +hsync -vsync (66.6 kHz eP)
[    61.108] (II) AMDGPU(0): EDID vendor "BOE", prod id 2307
[    61.108] (II) AMDGPU(0): Printing DDC gathered Modelines:
[    61.108] (II) AMDGPU(0): Modeline "1920x1080"x0.0  148.52  1920 1968 2000 2230  1080 1083 1089 1110 +hsync -vsync (66.6 kHz eP)
[   256.660] (II) AMDGPU(0): EDID vendor "BOE", prod id 2307
[   256.660] (II) AMDGPU(0): Printing DDC gathered Modelines:
[   256.660] (II) AMDGPU(0): Modeline "1920x1080"x0.0  148.52  1920 1968 2000 2230  1080 1083 1089 1110 +hsync -vsync (66.6 kHz eP)

output of lspci:

            00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Root Complex
            00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 IOMMU
            00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
            00:01.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
            00:01.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 PCIe GPP Bridge [6:0]
            00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-1fh) PCIe Dummy Host Bridge
            00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus A
            00:08.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Internal PCIe GPP Bridge 0 to Bus B
            00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 61)
            00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
            00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 0
            00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 1
            00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 2
            00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 3
            00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 4
            00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 5
            00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 6
            00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Raven/Raven2 Device 24: Function 7
            01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
            02:00.0 Non-Volatile memory controller: Intel Corporation SSD 660P Series (rev 03)
            03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c2)
            03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
            03:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) Platform Security Processor
            03:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
            03:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
            03:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor
            03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
            03:00.7 Non-VGA unclassified device: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/Renoir Non-Sensor Fusion Hub KMDF driver
            04:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 61)

Does this help with finding the error? Thanks for replying.

I have read other forum entries on the arch and ubuntu forums, but none of the solutions seem to help. A couple of days ago pressing Fn+f10(disable camera key) worked, but now the kernel log says asus_wmi: Unknown key 85 pressed.

That’s why we asked for inxi information

:man_shrugging:

System:
  Kernel: 5.11.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.11-x86_64 
  root=UUID=19d45ce5-3202-43cb-af35-35eb38e236ca rw quiet udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X509DA_D509DA 
  v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X509DA v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X509DA.306 date: 10/11/2019 
Battery:
  ID-1: BAT0 charge: 3.2 Wh (11.8%) condition: 27.2/32.0 Wh (85.0%) volts: 7.6 
  min: 7.6 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A 
  status: Discharging cycles: 152 
Memory:
  RAM: total: 5.81 GiB used: 3.46 GiB (59.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen/Zen+ note: check family: 17 (23) 
  model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L2: 2 MiB 
  bogomips: 33551 
  Speed: 1293 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 1293 2: 1391 3: 1317 4: 1356 5: 2390 6: 2393 7: 1380 8: 1342 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca 
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl 
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme 
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce 
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt 
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus-ID: 03:00.0 chip-ID: 1002:15d8 class-ID: 0300 
  Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
  diag: 395mm (15.5") 
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 
  5.11.6-1-MANJARO LLVM 11.1.0) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
  v: kernel bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x bus-ID: 03:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403 
  Sound Server-1: ALSA v: k5.11.6-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: no 
Bluetooth:
  Message: No Bluetooth data was found. 
Logical:
  Message: No LVM data was found. 
RAID:
  Message: No RAID data was found. 
Drives:
  Local Storage: total: 476.94 GiB used: 295.63 GiB (62.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8 
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: 002C temp: 27.9 C scheme: GPT 
  Message: No Optical or Floppy data was found. 
Partition:
  ID-1: / raw-size: 376.43 GiB size: 370.27 GiB (98.36%) 
  used: 295.63 GiB (79.8%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: N/A uuid: 19d45ce5-3202-43cb-af35-35eb38e236ca 
  ID-2: /boot/efi raw-size: 100 MiB size: 98.4 MiB (98.45%) 
  used: 298 KiB (0.3%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A 
  uuid: E86E-7C42 
  ID-3: /run/timeshift/backup raw-size: 376.43 GiB size: <superuser required> 
  used: <superuser required> fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: N/A uuid: 19d45ce5-3202-43cb-af35-35eb38e236ca 
Swap:
  Alert: No Swap data was found. 
Unmounted:
  ID-1: /dev/nvme0n1p3 maj-min: 259:3 size: 100 MiB fs: vfat label: N/A 
  uuid: 9056-EEA0 
  ID-2: /dev/nvme0n1p4 maj-min: 259:4 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p5 maj-min: 259:5 size: 99.8 GiB fs: ntfs label: N/A 
  uuid: 56F8664FF8662E05 
  ID-4: /dev/nvme0n1p6 maj-min: 259:6 size: 499 MiB fs: ntfs label: N/A 
  uuid: 865E62D75E62C013 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 54.9 C mobo: N/A gpu: amdgpu temp: 54.0 C 
  Fan Speeds (RPM): cpu: 2400 
Info:
  Processes: 265 Uptime: 1h 17m wakeups: 2 Init: systemd v: 247 
  tool: systemctl Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: pacman: 1638 
  lib: 451 flatpak: 0 Shell: Zsh v: 5.8 running-in: xfce4-terminal 
  inxi: 3.3.03
  1. You’re running on a “stable” kernel and not on an LTS kernel:

    mhwd-kernel --install linux510
    mhwd-kernel --install linux54
    

    Then go into the grub advanced options and try them out one by one.

  2. Your video camera is not recognised at all:

    Graphics:
      Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
      bus-ID: 03:00.0 chip-ID: 1002:15d8 class-ID: 0300 
      Display: x11 server: X.Org 1.20.10 driver: loaded: amdgpu,ati 
      unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
      Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
      s-diag: 582mm (22.9") 
      Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6") 
      diag: 395mm (15.5") 
      OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0 
      5.11.6-1-MANJARO LLVM 11.1.0) 
      v: 4.6 Mesa 20.3.4 direct render: Yes 
    

    Please ensure you have not disabled it by a hardware key (I don’t have a VivoBook, but according to a quick DDG search it’s either Fn+F9 or Fn+F10 or F9 or F10)

Thank you for your help and suggestions, it seems that running an lts kernel fixed my issue.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.