Laptop suspend not working and freezes in black screen then overheating

Hi all, recently I realized my laptop wasn’t suspending as expected. One night after I close the lid and expecting it to suspend itself, after I came back from outside the laptop fan is at full throttle, and the laptop is quite hot. I opened the lid and it’s only black screen, and it doesn’t respond to any key press except force shutdown with the power button long-pressed.

I did a test by pressing the “Suspend” from the power menu during a normal session. It goes to black screen and freezes like before. Leaving it there to run will result in fan speed going up as well.

I couldn’t find closely related issue, and I hope to be more cautious on shoving any command I found online to the terminal. Could you advice me on proper steps to troubleshoot this?


  Kernel: 5.13.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=0325b5b7-65b5-48a0-b18f-5736752533a5 rw quiet splash apparmor=1 
  security=apparmor resume=UUID=2bc1cb5e-5be0-4d1a-af6e-e2a0dedc24a9 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LEVEL 51 product: NP5x_NP7xHH_HJ_HK v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: LEVEL 51 model: NP5x_NP7xHH_HJ_HK serial: <filter> UEFI: INSYDE 
  v: 1.07.01TASP3 date: 05/07/2021 
  ID-1: BAT0 charge: 43.6 Wh (100.0%) condition: 43.6/49.4 Wh (88.3%) 
  volts: 17.2 min: 15.2 model: Notebook BAT type: Li-ion serial: <filter> 
  status: Full 
  RAM: total: 15.41 GiB used: 5.45 GiB (35.4%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: 11th Gen Intel Core i5-11400H bits: 64 type: MT MCP 
  arch: Tiger Lake family: 6 model-id: 8D (141) stepping: 1 microcode: 2C 
  cache: L2: 12 MiB bogomips: 64536 
  Speed: 3945 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 3945 2: 3194 
  3: 1978 4: 926 5: 2086 6: 1571 7: 4300 8: 1237 9: 940 10: 4066 11: 3491 
  12: 2456 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2 avx512_vnni 
  avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f 
  avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2 cdp_l2 clflush 
  clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl 
  dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma 
  fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp hwp_notify 
  hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single 
  lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri msr mtrr 
  nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge 
  pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good 
  sdbg sep sha_ni smap smep split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 
  ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer 
  tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: CLEVO/KAPOK 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a68 class-ID: 0300 
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Ti Mobile] driver: nvidia 
  v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:25a0 class-ID: 0300 
  Device-3: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 3-8:2 
  chip-ID: 5986:9102 class-ID: 0e02 
  Display: wayland server: 1.20.13 compositor: gnome-shell driver: 
  loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa display-ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel Tiger Lake-H HD Audio vendor: CLEVO/KAPOK 
  driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl 
  bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.15-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.35 running: yes 
  Device-1: Intel Tiger Lake PCH CNVi WiFi driver: iwlwifi v: kernel 
  port: 5000 bus-ID: 00:14.3 chip-ID: 8086:43f0 class-ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: CLEVO/KAPOK driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 3-14:3 chip-ID: 8087:0026 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 953.87 GiB used: 163.93 GiB (17.2%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Lexar model: 1TB SSD 
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: V1.3 temp: 41.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 936.61 GiB size: 920.84 GiB (98.32%) 
  used: 163.93 GiB (17.8%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 0325b5b7-65b5-48a0-b18f-5736752533a5 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: NO_LABEL uuid: AE77-E049 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.95 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: swap 
  uuid: 2bc1cb5e-5be0-4d1a-af6e-e2a0dedc24a9 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-8:2 info: Acer BisonCam NB Pro type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:9102 
  class-ID: 0e02 
  Device-2: 3-14:3 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026 
  class-ID: e001 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 20 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 49.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 356 Uptime: 59m wakeups: 3 Init: systemd v: 249 tool: systemctl 
  Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1237 pacman: 1231 lib: 302 
  flatpak: 0 snap: 6 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.06 

1 Like

Please read this:

Please read this:

Especially the Linux has multiple kernels section, then try an LTS kernel and hopefully the problem will go away “automagically”. :grin: If not, upgrade to the 5.14 kernel and please keep in mind you’re on the Stable Development bandwagon now

Please read this too! before you start doing hibernate.

After you’ve resolved all of the above and the issue would still be there do the following as fast as possible:

  • reboot

  • log in

  • open a terminal

  • execute:

    systemctl suspend
    (OK, you’re off the clock now and can do the rest at your leisure)

  • Log in

  • Execute:

    journalctl --system --boot=-1 --priority=warning
  • Post that output here


1 Like

Thank you for the reading materials! I’ve stumbled upon interesting result.

After switching to the LTS version of kernel 5.10.63-1-MANJARO, the options for Wayland during login is no longer there. For there are only “Gnome” and “Gnome Classic”, where “Gnome” is X11.

So I proceed to suspend using the power menu, and it worked as intended.

I usually prefer Wayland, so I suspect maybe it was some conflict between my suspend and Wayland. I logged out X11 after boot and to my surprise, Wayland is among the options again.

Trying to suspend either using power menu or terminal resulted to the same black screen and overheating on Wayland session. Unfortunately I couldn’t perform a REISUB during the black screen, which is extremely odd since I’ve verified that I’ve successfully enabled sysrq button during normal session.

After hard reset again, I executed the command and have the below log file:

Log file too big, had to upload to drive.

I’m still on Xorg because Wayland is a work in progress…

Furthermore, your log is 8 hours long and why I asked:

So I’d say:

  1. Revert back to Xorg and forget Wayland for the moment, problem solved
  2. If you want to stay on Wayland and leave meaningful information for the next person to help you, go back up and start with rebooting (I think you forgot that step) and leave a much smaller log for a Gnome / Wayland expert to help you further…



I honestly did reboot. But the way for me to trigger the black screen with the LTS kernel is that I had to reboot, login X11, logout, login Wayland, and then suspend.

I couldn’t figure out which part I’m doing wrong to caused the log to be that long. I do understand Wayland is a work in progress, and I’m super impressed by the progress it made compared to last I used!

I understand the options you listed, but using Xorg would mean I couldn’t use the three finger swipe with touchpad on Gnome to switch workspace. And I silently hope that maybe these discussion could indirectly helped the development of Wayland so in future I could daily drive it.

Regardless, I’ve gone through again the steps you’ve provided for me, still not getting any shorter log yet. But I’ll keep look into it, I’ve already learned so much, so thank you :smiley:

Another might not be useful log:

try this:

  • Note the exact time up to the second

  • go to a terminal and execute:

    systemctl suspend

  • provide the output to:

    journalctl --system --priority=3 --since "YYYY-MM-DD HH:MM:SS"

where obviously "YYYY-MM-DD HH:MM:SS" is the date/time noted earlier


Hi Fabby, thank you so much for you attention, I assume I should perform the REISUB with 5.13 kernel as that’s the only way to trigger the black screen. But unfortunately it wasn’t responding to REISUB during the black screen.

Yesterday I tried using 5.14 kernel instead since I read 5.13 is EOL. To my surprise everything works as intended now. So far I’m not encountering any issue.

Anyway, thank you for your help :smiley:!

1 Like

Solution marked.

Please be aware you’re on the Stable Development bandwagon now and you should upgrade your kernels often and keep an eye out when your kernel goes EOL.


1 Like

A post was split to a new topic: Freeze on 5.13 kernel

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.