Laptop sound is either 0% or 100%

Hi, I got this working the other day but after I rebooted by logging into root and doing sudo reboot many things broke. My snap installs no longer work such as discord and spotify and the sound slider gnome either sets the audio to 0% (when at 0%) and to 100% (sound slider between 1% and 100%)

I tried doing the fix I saw on mint, it worked yesterday but no longer works today. The fix was editing few lines here: " sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-output.conf.common"
The file is actually missing now, I went there and checked. The entire pulseaudio folder is gone… There is only pulseaudio-ctl.

Forgive my noobie-ness this is my third day trying to use any distro. Any help would be greatly appreciated. Thanks.


I will never understand why going on such route.
systemctl reboot
as your user should be the only way to reboot your system from terminal.

pulseaudio package can be reinstalled by:
pamac install pulseaudio

I don’t think that is a good approach.
Have you tried to remove ~/.config/pulse and restart your system ?

Hey, thanks for the response.
I reinstalled pulseaudio and deleted the folder, nothing changed.
As for the way to restart I will know that later thanks.