Laptop shuts down suddenly when screen sharing and power is disconnected or connected

My laptop suddenly shuts down when I’m screen sharing or using certain apps/websites like discord, meet, zoom, and then I disconnect charger or connect charger. This happens if I’m screen sharing, looking at other person’s screen share and in discord’s case, it happens regardless I’m sharing screen or not.

My Laptop is a bit old, but i presume it might have something to do with the graphics driver.
Laptop specs:
cpu: intel i3 5005u
gpu: intel integrated graphics 5500
ram: 8gb
hdd: 1 tb
swap: 16gb
dual boot with windows

I have logs of last crash but it says i cant add links to my posts.

post formated output from:
inxi -Fazy
and of those crash logs - click this icon in editor: </> and put the outputs there

1 Like

Output from inxi -Fazy

  Kernel: 5.18.6-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=5a54e136-8657-4f9e-825b-d11cb13c7794 rw quiet
  Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.5 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP Notebook v: Type1ProductConfigId
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 80C1 v: 96.53 serial: <superuser required> UEFI: Insyde
    v: F.29 date: 05/24/2019
  ID-1: BAT1 charge: 27.3 Wh (77.1%) condition: 35.4/32.1 Wh (110.1%)
    volts: 15.4 min: 14.6 model: COMPAL PABAS0241231 type: Li-ion
    serial: <filter> status: discharging
  Info: model: Intel Core i3-5005U bits: 64 type: MT MCP arch: Broadwell
    gen: core 5 built: 2015-18 process: Intel 14nm family: 6 model-id: 0x3D (61)
    stepping: 4 microcode: 0x2F
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1665 high: 1897 min/max: 500/1900 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1897 2: 1896 3: 1896
    4: 974 bogomips: 15966
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 5500 vendor: Hewlett-Packard driver: i915
    v: kernel arch: Gen8 process: Intel 14nm built: 2014-15 ports: active: eDP-1
    empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1616 class-ID: 0300
  Device-2: Suyin HP Truevision HD type: USB driver: uvcvideo bus-ID: 2-5:6
    chip-ID: 064e:930b class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: Samsung 0x4e51 built: 2014 res: 1366x768 hz: 60
    dpi: 101 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel HD Graphics 5500 (BDW GT2) v: 4.6 Mesa 22.1.2
    direct render: Yes
  Device-1: Intel Broadwell-U Audio vendor: Hewlett-Packard
    driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:160c
    class-ID: 0403
  Device-2: Intel Wildcat Point-LP High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:9ca0 class-ID: 0403
  Sound Server-1: ALSA v: k5.18.6-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: no
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard
    driver: r8169 v: kernel pcie: speed: Unknown lanes: 63 link-max: gen: 6
    speed: 64 GT/s port: 4000 bus-ID: 07:00.0 chip-ID: 10ec:8136
    class-ID: 0200
  IF: enp7s0 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtl8723be v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 0d:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlp13s0 state: down mac: <filter>
  IF-ID-1: CloudflareWARP state: unknown speed: 10 Mbps duplex: full
    mac: N/A
  IF-ID-2: enp0s20u2 state: unknown speed: -1 duplex: half mac: <filter>
  Device-1: Huawei LLD-AL20 type: USB driver: rndis_host v: kernel
    bus-ID: 2-2:7 chip-ID: 12d1:108a class-ID: 0a00 serial: <filter>
  Report: This feature requires one of these tools: hciconfig/bt-adapter
  Device-2: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 2-4:5 chip-ID: 0bda:b006 class-ID: e001 serial: <filter>
  Report: ID: hci0 rfk-id: 1 state: up address: N/A
  Local Storage: total: 931.51 GiB used: 397.66 GiB (42.7%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS541010A9E680
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: A7L0 scheme: GPT
  ID-1: / raw-size: 199.66 GiB size: 195.47 GiB (97.90%)
    used: 98.95 GiB (50.6%) fs: ext4 dev: /dev/sda7 maj-min: 8:7
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 37.4 MiB (38.9%) fs: vfat dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 16 GiB used: 16.1 MiB (0.1%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 57.0 C pch: 50.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 236 Uptime: 2h 7m wakeups: 1 Memory: 7.68 GiB
  used: 5.16 GiB (67.2%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1 Packages: pacman: 1458
  lib: 351 Shell: Zsh v: 5.9 running-in: yakuake inxi: 3.3.19

about the logs, i collected them using journalctl -b-$(last | sed -e '/crash/,$d' | grep 'system boot' | wc -l) and they exceed the allowed limit here

dont post here that much logs… you said that your laptop is old, yet you are using the 5.18 kernel… install the 5.4 and the 5.10 kernels, and try with them and see if you have still the same issues

ok let me check

Don’t rule out hardware problems. I have a laptop that won’t run on battery power, even with a new battery. I forget the name of the card that has failed. I now use this laptop (plugged in of course) for W10 which I rarely use.

I see. Well in my case my laptop does run normally when im using windows ( can play games as well) and have even worked without any problem on Parrot OS, the previous distro I had. I’m now trying to find any driver issues if i can.

also about downgrading kernel. Well, package manager returning 404.

why do you want to downgrade the kernel?
install these:
sudo mhwd-kernel -i linux510
sudo mhwd-kernel -i linux54
reboot and select the 5.4 in the grub menu, test with it, if it happens again, do the same with the 5.10

My bad I rather used wrong word for it.

What I tried:

  • Manjaro gui tool to download kernel
    Result: 404
  • yay
    Result: 404

The way the messages shows up, it sys the file is not in server it is possibly removed from there

As for mhwd-kernel utility, i believe it’s the same as the gui tool i mentioned above.

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
then try again:
sudo mhwd-kernel -i linux510
sudo mhwd-kernel -i linux54

1 Like

I’ve switched to kernel 5.10 and haven’t faced any shutdown so far. I think this fixes it. But I’ll keep an eye out just in case. And thanks a lot.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.