Laptop-Screen resolution - possible values to low


I do have an Laptop (ASUS N76vz) and an external Screen (BENQ 24).

I’ve worked a bit at my nvidia config. After rebooting the PC, the Laptop-Screen-Resolutions are way to low. The highest resolution I could choose is 950x540:

AND, the screens are always arranged above each other after reboot… even if I put the Laptop-Screen at the right side of the BENQ 24, and save that changes. On next boot, position of Laptop-Screen is again as shown in the image.

How can I fix that?

BTW: If I try to run nvidia-settings, I always got this message:

Even if I follow the instructions, it appears every time again


Operating System: Manjaro Linux
KDE Plasma Version: 5.24.6
KDE Frameworks Version: 5.96.0
Qt Version: 5.15.5
Kernel Version: 5.19.1-3-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-3610QM CPU @ 2.30GHz
Memory: 15.1 GiB of RAM
Graphics Processor: Mesa Intel® HD Graphics 4000

Ok, figured out, how to add an needed resolution to xorg:

If you can only choose lower resolutions in your KDE settings, you can add them like this:

// Might output something like that: 
Screen 0: minimum 8 x 8, current 2880 x 1080, maximum 32767 x 32767
LVDS1 connected 960x540+1920+0 (normal left inverted right x axis y axis) 380mm x 210mm
   960x540       59.82* 
   864x486       60.00    59.92    59.57  
   640x480       59.94  
VGA1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 530mm x 300mm
   1920x1080     60.00*+
   1680x1050     59.95  
   1600x900      60.00  
   1280x1024     60.02  
   1280x800      59.81  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Our LVDS1 (Laptop-Screen) is missing higher resolutions. So we add the now:

cvt 1920 1080
// result in:
# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

Copy the value and do following CLI-Commands with it:

xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync
xrandr --addmode LVDS1 1920x1080_60.00
xrandr --output LVDS1 --mode 1920x1080_60.00

That’s it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.