Laptop monitor not working but external one does

Yap. Problem solved. Thank you @brahma @Olli for your time.

Solution: Extract the right EDID from Windows and booted with that. Monitor working as it should.

Booting with this parameters in /etc/default/grub.

GRUB_CMDLINE_LINUX_DEFAULT="video=eDP-1:e drm.edid_firmware=eDP-1:edid/3000x2002.bin udev.log_priority=3"

Thank you guys.

@brahma @Olli It was so helpful, thanks, but you didn’t say how you got edid binary file from windows (Monitor Asset Manager 2.9)? And to which directory i should put it in a linux (/lib/firmware/edid)? Have same configuration’s notebook (Irbis NB656) I still having issue, maybe wrong EDID file?

1.did you tried newer kernel like the 5.19?
2.did you enabled early loading:

3.did you tried booting with this parameter:
video=eDP-1:e drm.edid_firmware=eDP-1:edid/3000x2002.bin

@brahma Yup, still same (black screen after X is inited), i using archbang with kernel 5.19.9 it almost arch but very lightweight. Have recompiled mkinitcpio after i915 and added step 3 to /etc/default/grub then grub-mkconfig -o /boot/grub/grub.cfg
added /lib/firmware/edid folder and put 3000x2002.bin to it. I have got .bin from windows 10 using app Monitor Asset Manager

1 Like

so try this line instead:

drm.edid_firmware=eDP-1:edid/1920x1080.bin
1 Like

@brahma Not standard resolution for this display i think so it same, here is my Xorg.0.log on gdrive /file/d/1BukSw1gteG4QJhyg_D78VVVcE10eO4xt i think something strange in it.

1 Like

so if you checked this:
https://forums.linuxmint.com/viewtopic.php?f=59&t=343706&p=1978463&hilit=GWTN141+4#p1978463
and:
https://forums.linuxmint.com/viewtopic.php?t=376894
and:
https://wiki.archlinux.org/title/Kernel_mode_setting#Forcing_modes_and_EDID
then i dont know … maybe your issue is not related to this? or you are doing something wrong…
does it works in different linux live usb?
and dont know how to open the xorg file, you can post links using formatting…

1 Like

i not able to post links, just add drive•google•com before /file/ many thanks for links, inspecting

1 Like

it looks like the xorg is not complete, also the last logs are from adding the edid, so it seem that that worked …
post log from this:
cat /home/freedom/.local/share/xorg/Xorg.0.log

and this? :arrow_up:

1 Like

It work only with KaliLinux installer usb, but after installing is not:)

I tried these:
alpine-extended-3.15.4-x86_64, archlinux-2022.08.05-x86_64, elementaryos-6.1-stable.20211218-rc, LXLE-Focal-Release, TinyCorePure64-13.1, void-live-x86_64-20210930-xfce

and lightweight:
archbang-summer-1709-x86_64, bodhi-6.0.0-64, cbpp-11.1-amd64-20210923, elive_3.0.6_stable_usb, Porteus-LXDE-v5.0-x86_64, puppy-lfa20.08-21.05-x86_64, q4os-4.10-x64-tde.r2, slax-64bit-15.0.0, slitaz-rolling-core-5in1, Zorin-OS-16.1-Lite-64-bit

1 Like

are you sure that its not some physical damage?

so the monitor is detected in the live usb of kalinux? so you should check the kernel parameters that are applied in the live usb, maybe it will help: inxi -Faz and check parameters

1 Like

Monitor anywhere is as unknown monitor

Mean damage of integrated videocard? Not sure. Windows 11 works well

you said here that it works only in kali … now you saying that monitor is not detected anywhere, so what is it?

I can’t find live kali, only installer, it works with monitor by default but it’s not os i can check hardware only after install

i dont understand, so does the monitor work with kali live usb or not?

With live = no, only with installer; but items looks so small

so if you install kali the moitor is working? but the items are too small? am i understanding it correctly? …