Laptop monitor flickers during cpu load and eventually turn off

I’m new to manjaro and recently installed it on my laptop. Lenovo legion y740.

I’m using a dual monitor setup, the laptop monitor and one external monitor connected via HDMI.
After I installed the nvidia driver my laptop monitor flickers during load, when playing or watching youtube video or just opening a program that makes the computer work harder. If I continue to have a high load the monitor will eventually turn off. But only the laptop monitor, my external one will keep working and I can continue playing(or doing whatever). You can turn the laptop monitor on/off in display settings and it will start again like normal.

I have disabled turbo boost and when restricting the cpu frequency the problem disappears or becomes less noticeable depending on how low you cap the frequency. At idle there is no flickering.

When I’m using the open source drivers the problem don’t exist. But the performance is so bad so I need to use the nvidia ones.
No problem in windows.
I have reinstalled Manjaro several times with no luck.

Don’t know how to continue from here. Provided inxi output but unsure what’s needed. If you need further information I will be happy to provide it.
All help is appreciated greatly.

This is my inxi output:

  Kernel: 5.13.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=e8503241-22a2-4795-97b3-8ce5965013a8 rw quiet apparmor=1 
  security=apparmor resume=UUID=f2601d61-71b2-4079-b66c-26f83a314279 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 81UH v: Lenovo Legion Y740-15IRHg 
  serial: <filter> Chassis: type: 10 v: Lenovo Legion Y740-15IRHg 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <filter> 
  UEFI: LENOVO v: BVCN16WW(V1.12) date: 06/21/2021 
  ID-1: BAT1 charge: 50.0 Wh (100.0%) condition: 50.0/57.0 Wh (87.8%) 
  volts: 13.0 min: 11.5 model: SMP L17M3PG2 type: Li-ion serial: <filter> 
  status: Full cycles: 143 
  RAM: total: 31.27 GiB used: 3.44 GiB (11.0%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: EA cache: L2: 12 MiB bogomips: 62431 
  Speed: 2699 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 2699 2: 1707 
  3: 1048 4: 901 5: 2765 6: 900 7: 2260 8: 1177 9: 900 10: 900 11: 900 12: 900 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU106BM [GeForce RTX 2070 Mobile / Max-Q] vendor: Lenovo 
  driver: nvidia v: 470.57.02 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1f50 class-ID: 0300 
  Device-2: Chicony Integrated Camera (1280x720@30) type: USB driver: uvcvideo 
  bus-ID: 1-7:12 chip-ID: 04f2:b604 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: nvidia display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0") 
  s-diag: 1245mm (49") 
  Monitor-1: HDMI-0 res: 2560x1440 hz: 144 dpi: 109 
  size: 597x336mm (23.5x13.2") diag: 685mm (27") 
  Monitor-2: DP-4 res: 1920x1080 hz: 144 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: NVIDIA GeForce RTX 2070 with Max-Q Design/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.57.02 direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 
  chip-ID: 8086:a348 class-ID: 0403 
  Device-2: NVIDIA TU106 High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:10f9 
  class-ID: 0403 
  Device-3: SteelSeries ApS Arctis Pro Wireless type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.3:15 chip-ID: 1038:1294 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.13.8-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
  Device-1: Intel Cannon Lake PCH CNVi WiFi 
  vendor: Rivet Networks Killer Wireless-AC 1550i Wireless driver: iwlwifi 
  v: kernel bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 3f:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp63s0 state: down mac: <filter> 
  WAN IP: <filter> 
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB 
  driver: btusb v: 0.8 bus-ID: 1-14:14 chip-ID: 8087:0aaa class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 953.87 GiB used: 42.66 GiB (4.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB1T0HALR-000L2 
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: 5L1QEXA7 temp: 33.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 919.16 GiB size: 903.66 GiB (98.31%) 
  used: 42.66 GiB (4.7%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: e8503241-22a2-4795-97b3-8ce5965013a8 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: NO_LABEL uuid: 9F26-DCF6 
  Kernel: swappiness: 10 (default 60) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 34.4 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: f2601d61-71b2-4079-b66c-26f83a314279 
  Message: No unmounted partitions found. 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 1-1:2 info: Texas Instruments TUSB2036 Hub ports: 3 rev: 1.1 
  speed: 12 Mb/s chip-ID: 0451:2036 class-ID: 0900 
  Device-1: 1-1.3:15 info: SteelSeries ApS Arctis Pro Wireless type: Audio,HID 
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 6 rev: 1.1 
  speed: 12 Mb/s power: 100mA chip-ID: 1038:1294 class-ID: 0300 
  Device-2: 1-2:3 info: SteelSeries ApS SteelSeries Apex 7 type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 5 rev: 2.0 speed: 12 Mb/s 
  power: 500mA chip-ID: 1038:1612 class-ID: 0300 
  Device-3: 1-3:5 info: SteelSeries ApS SteelSeries Rival 650 Wireless 
  type: HID,Mouse driver: hid-generic,usbhid interfaces: 4 rev: 2.0 
  speed: 12 Mb/s power: 200mA chip-ID: 1038:172b class-ID: 0300 
  serial: <filter> 
  Device-4: 1-4:7 info: Integrated Express ITE Device(8910) type: Keyboard 
  driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 048d:c936 class-ID: 0301 
  Hub-3: 1-5:8 info: VIA Labs VL813 Hub ports: 4 rev: 2.1 speed: 480 Mb/s 
  chip-ID: 2109:2813 class-ID: 0900 
  Device-1: 1-6:10 
  info: Integrated Express Corsair Gaming K95 RGB PLATINUM Keyboard 
  type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 100mA chip-ID: 048d:c935 class-ID: 0300 
  Device-2: 1-7:12 info: Chicony Integrated Camera (1280x720@30) type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 04f2:b604 class-ID: 0e02 serial: <filter> 
  Device-3: 1-14:14 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) 
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 100mA chip-ID: 8087:0aaa class-ID: e001 
  Hub-4: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-5: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-7: 5-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-8: 6-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-9: 6-1:2 info: VIA Labs VL813 Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 2109:0813 class-ID: 0900 
  Device-1: 6-1.4:3 info: Norelsys NS1081 type: Mass Storage 
  driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 8mA 
  chip-ID: 2537:1081 class-ID: 0806 serial: <filter> 
  System Temperatures: cpu: 56.0 C mobo: N/A gpu: nvidia temp: 51 C 
  Fan Speeds (RPM): N/A 
  Processes: 325 Uptime: 55m wakeups: 2 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1100 pacman: 1088 lib: 292 
  flatpak: 5 snap: 7 Shell: Bash v: 5.1.8 running-in: xfce4-terminal 
  inxi: 3.3.06 
1 Like

Direct HDMI-HDMI or is there a converter in play?

Have you vacuumed your laptop already? (Or used air spray to clean it out?) Do you monitor T° and P-state?

Doesn’t mean anything

Have you tried an LTS kernel already?

This is unrelated to your issue, but why didn’t you split out / with /home?

No converter.

I have monitored the temps and they are ok for both cpu and gpu. No difference in temp when I use the open source driver and that works fine(except I only have half screen but different problem)

I did this to check if there was a faulty component

Yes, tried 5.10.51-1, 5.12.19-1, 5.13.8-1 and 5.14 experimental.
Same problem.

Are you supposed to run it in two partitions? Did’t know that.

Thx for taking the time :slight_smile:

  • How about cleaning?
  • How about P-State?


My current workaround is to use cpupower to monitor frequency and governor. Have tried different settings with the same problem as result. It works normal when I limit the CPU frequency to 2.6GHz. Also used i7z to monitor voltage and can see no strange behaviour.

I have cleaned the laptop so it’s nice :slight_smile:

1 Like

Or do you need more precise info about P-state? Can I provide some sort of log for that? Don’t know how to do that.

OK then! As you’ve got a GeForce RTX 2070 Mobile (quite new) with an nVidia 470.57.02 driver (beta) let’s assume this is a bug in the driver (there are a few) so you have a workaround for the moment; keep monitoring your frequency and let’s wait for the next nVidia update, because as you don’t have an iGPU we can’t switch to that to ensure this is not a hardware problem…


Nope! That’s all the info I needed!

I would say: accept this one as the current Solution although it’s a workaround so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

In the meantime, I would try and file a bug with nVidia so they’re aware of this.

What’s your opinion? :thinking:

1 Like

Yeah, waiting for a new driver was my solution also :slight_smile:
But it’s a strange problem, feels like unstable cpu but only shows up when installing the nvidia driver.

Thanks for the help!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.