Laptop Mic stopped working sometime in last 3-4 months

Somewhere in last 3-4 months(not sure of the exact time) my laptop mic suddenly stopped working, it works on windows but not on manjaro and even debian, i tried the arch wiki solution(pulse audio to edit /etc/pulse/ but no results, below are some outputs from the commands i stumbled across on internet:-
arecord -l  :heavy_check_mark:  10m 6s 
**** List of CAPTURE Hardware Devices ****
card 1: PCH [HDA Intel PCH], device 0: ALC233 Analog [ALC233 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

amixer  INT ✘
Simple mixer control ‘Master’,0
Capabilities: pvolume pswitch pswitch-joined
Playback channels: Front Left - Front Right
Limits: Playback 0 - 65536
Front Left: Playback 86989 [133%] [on]
Front Right: Playback 86989 [133%] [on]
Simple mixer control ‘Capture’,0
Capabilities: cvolume cswitch cswitch-joined
Capture channels: Front Left - Front Right
Limits: Capture 0 - 65536
Front Left: Capture 55743 [85%] [on]
Front Right: Capture 55743 [85%] [on]

dmesg|grep snd  1|INT ✘  14s 
[sudo] password for sunny:
[ 4.005383] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC233: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[ 4.005387] snd_hda_codec_realtek hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 4.005389] snd_hda_codec_realtek hdaudioC1D0: hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[ 4.005390] snd_hda_codec_realtek hdaudioC1D0: mono: mono_out=0x0
[ 4.005391] snd_hda_codec_realtek hdaudioC1D0: inputs:
[ 4.005393] snd_hda_codec_realtek hdaudioC1D0: Mic=0x19
[ 4.005395] snd_hda_codec_realtek hdaudioC1D0: Internal Mic=0x12
[ 4.271240] snd_hda_intel 0000:00:03.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

PLease help, i use this laptop to connect to my work remote desktop and now i am not able to attend zoom calls on laptop, i remember it working sometime back not sure when or why it stopped working, i thought may be i messed up something so i installed it clean but still no good, and same thing on debian(testing gnome), it doenst work, but on windows it works beautifully.

O/p of audio part of inxi -Fzxxxa :-
Device-1: Intel Broadwell-U Audio vendor: Toshiba driver: snd_hda_intel
v: kernel bus ID: 00:03.0 chip ID: 8086:160c
Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Toshiba
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:9ca0
Sound Server: ALSA v: k5.9.16-1-MANJARO

no one replied, but for someone who stumble across it, updating the kernel to 5.10.7-3-MANJARO fixed the issue. and i am guessing it wouldnt have been 304 months , i think i never checked the mic frequently to know if its broken or not.