Laptop lot hotter to the touch than it should be

My laptop (Lenovo ideapad pro 14ACN6) is a lot hotter to the touch, than in windows during the same medium load (browsing, media consumption in a dual-monitor setup), even though the sensor temps are basically the same, when I run manjaro it hurts to touch the chassis and in windows it’s just mildly warm. I already tried thermald for example, but it didn’t make a difference.
Any help is appreciated.

sudo inxi -Fza
  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=7098fdc5-760c-4862-91b7-5abd93de2d49 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 82L7 v: IdeaPad 5 Pro 14ACN6
    serial: <filter> Chassis: type: 10 v: IdeaPad 5 Pro 14ACN6 serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <filter> UEFI: LENOVO
    v: GECN31WW(V1.15) date: 06/24/2022
  ID-1: BAT1 charge: 31.5 Wh (55.1%) condition: 57.2/56.5 Wh (101.2%)
    volts: 11.7 min: 11.5 model: 0x53 0x75 0x6E 0x77 0x6F 0x64 0x 0x4C 0x32
    0x30 0x44 0x33 0x50 0x5650 type: Li-ion serial: <filter> status: N/A
    cycles: 7
  Info: model: AMD Ryzen 5 5600U with Radeon Graphics socket: FP6 bits: 64
    type: MT MCP arch: Zen 3 gen: 4 built: 2021-22 process: TSMC n7 (7nm)
    family: 0x19 (25) model-id: 0x50 (80) stepping: 0 microcode: 0xA50000D
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 16 MiB desc: 1x16 MiB
  Speed (MHz): avg: 1891 high: 2300 min/max: 1600/4288 boost: enabled
    base/boost: 2300/4250 scaling: driver: acpi-cpufreq governor: schedutil
    volts: 1.2 V ext-clock: 100 MHz cores: 1: 1600 2: 1600 3: 1600 4: 1600
    5: 1600 6: 2300 7: 2300 8: 1600 9: 2300 10: 2300 11: 1600 12: 2300
    bogomips: 55125
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Cezanne vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5.1
    code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 3
    speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: HDMI-A-1,eDP-1 empty: DP-1,DP-2 bus-ID: 04:00.0
    chip-ID: 1002:1638 class-ID: 0300
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-3:2 chip-ID: 04f2:b6be class-ID: fe01 serial: <filter>
  Display: x11 server: X. Org v: 21.1.4 compositor: xfwm v: 4.16.1 driver:
    X: loaded: amdgpu gpu: amdgpu display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 6720x2160 s-dpi: 96 s-size: 1778x572mm (70.00x22.52")
    s-diag: 1868mm (73.53")
  Monitor-1: HDMI-A-1 mapped: HDMI-A-0 pos: top-right model: VG245
    serial: <filter> built: 2016 res: 3840x2160 hz: 60 dpi: 184 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 mapped: eDP pos: primary,bottom-l model-id: CSO 0x1402
    built: 2020 res: 2880x1800 hz: 90 dpi: 242 gamma: 1.2
    size: 302x188mm (11.89x7.4") diag: 356mm (14") ratio: 16:10 modes:
    max: 2880x1800 min: 640x480
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.1 chip-ID: 1002:1637
    class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x
    pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
    bus-ID: 04:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 04:00.6 chip-ID: 1022:15e3
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 bus-ID: 01:00.0 chip-ID: 168c:003e class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Device-1: Qualcomm Atheros QCA61x4 Bluetooth 4.0 type: USB driver: btusb
    v: 0.8 bus-ID: 3-4:3 chip-ID: 0cf3:e300 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 62.56 GiB (6.6%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: MZVLB1T0HBLR-000L2 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 3L1QEXF7 temp: 49.9 C scheme: GPT
  SMART: yes health: PASSED on: 4d 7h cycles: 738 read-units: 3,332,213
    [1.70 TB] written-units: 2,829,890 [1.44 TB]
  ID-1: / raw-size: 125 GiB size: 122.48 GiB (97.98%) used: 62.53 GiB (51.1%)
    fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 27.6 MiB
    (28.7%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 77.5 C mobo: N/A gpu: amdgpu temp: 74.0 C
  Fan Speeds (RPM): N/A
  Processes: 322 Uptime: 6h 31m wakeups: 11153 Memory: 13.51 GiB used: 4.77
  GiB (35.3%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.1 alt: 11 clang: 14.0.6 Packages: pacman: 1183
  lib: 332 flatpak: 0 Shell: Bash (sudo) v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.20

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Did you start the and enable the thermald.service? If so, what does your config look like?

I did start the service. Can not see a config file though in the thermald folder. Just this: This XML file does not appear to have any style information associated with it. -

Ran some extra commands. Thermald status says my platform is not supported. After that I ran sensors-detect, which came back with “no sensors detected”. Kind of clueless on what to do.

You will also have to enable the service for it to automatically start with the OS. Did you run the sensors-detect as root or with sudo?
Unsupported platforms still get some benefit from thermald. But if it doesnt lower the temps enough you will likely have to go old school with cpu frequency scaling. I would start with the conservative governor.