Laptop Lenovo Ideapad 5 15ARE05 81YQCT01WW motherboards beeps when hitting keyboard

Hi everyone,

I made a youtube video for my problem its way faster to explain but its impossible to link it so here is the title “motherboard beep when keyboard input on Manjaro on Lenovo Ideapad 15 ARE05 (ryzen 7 4800u)” by Lucroz94 (me, Hi)

I tried to install Manjaro in april 2020 and failed and this month but still failed.

When I tried with KDE, the brightness was chaos, my screen was totally off when I reached the lower brightness level and I have those weirds beeps coming from my motherboard when I pressed the “delete” key on my keyboard. I also have the system utility software that crashes randomly when trying to set differents colour (dark mode for example) and so on.

I tried XFCE (my second choice) and it’s working great BUT I still have those beeps wich ruins everything.

I absolutely don’t know how to fix it and I travel the entire internet and nobody seems to have the same issue.

This is my last try after giving up for good to install Linux on this laptop.
I even consider to sell it and buy another one with 100% compatibility (but with the specs I have it’ll be so much more expensive)

Yes I’m desperate and my english is not that good but if someone as a clue, please help me
Sorry also if its in the wrong section of the forum


Hi everyone,

It seems that my problem may be in the wrong section of the forum (or no one has ever suffered this issue).

I was finally able to solve my two problems on XFCE and latest Manjaro !

Here is what works for me.

sorry I didn’t have the link from the other forums that help me but there is the steps

First, to disable the loud beep when I press the backspace in the XFCE login session and in a browser like firefox I had to do this :

  1. open a terminal and write “xset -b” or “xset b off” to disable it in Xorg
    to make the change permanent, add a line in either “.xinitrc” or “xprofile” file
    It works when I put the line in “.xinitrc”. I put it early in the file, because I didn’t find (or understand) where it should be instead

I hope it helps some folks around !