Laptop is nothing but problems bootloop after install

Short version: finally got Manjaro XFCE installed and first boot it throws an error on the screen and boot loops. HP 15-bw011dx photo of error attached.

AMD Dual-Core A6-9220 APU and it has an SSD and 8gb of ram

Longer version:
I have installed Manjaro several times on several computers. This is an old laptop that I’m trying to make a very limited kid friendly computer for my kid. I tried and it sucked, I tried the Endless os and it was humongous and didn’t have enough parental restrictions and its a very heavy install made for offline use.
So I decided to build my own starting with Manjaro XFCE old faithful. I used Rufus to burn the iso to a thumb drive and it would boot loop right before the splash screen. Researching I learned that other people have had problems with Manjaro and Rufus so I used Ventoy on the drive. That booted me into live Manjaro and I was able to install and then on the first reboot I got the error above. After googling and getting various weird answers I tried installing again with the same result.
To recap two distros have installed correctly. Manjaro installs in VirtualBox so the image probably isn’t bad.
It was running windows 10 last week (slowly).

Hello @mattbatt :wink:

As you can see it is a Hardware Error. To be more specific: BANK 4 → fourth RAM Modul return an error on allocation, which was not repairable.

Thanks for the quick reply. I was ruling out actual hardware problems since it was running windows 10 and 2 versions of Linux plus the Manjaro live boot within the last few days. Plus there are only 2 ram slots on this laptop so which one is bank 4?
I’ll unscrew the bottom and try booting with only one of the sticks.

I geuss it is the last one. Sometimes numbering is a bit screwed up. Linux just reads what the BIOS says.

Maybe DIMM4 is meant?

sudo dmidecode --type=memory

Then it is possible that the error was recently correctable by the CPU, but now not anymore. These errors can come and go. :man_shrugging:

Alright I am running memtest, it passed the first round and it’s on to the second. As you can see I was incorrect there is 12gb of ram not 8.
So I’m guessing ram isn’t actually the problem.

I don’t know how much it was born with - but guessing from the different sizes - one of them is aftermarket.

Since you mention 8G and now 12G - I am thinking the 4G module is faulty or one of them not seated properly.

I would experiment by running with only one bank at a time to locate which one makes the kernel stall.

It also looks like the the 4G module is CRC and the other is not - that combo rarely work well - same type - same size is usually prescription.

You may succeed with different sizes but M/B is usually designed for equal sizes and spec.

1 Like

Excuse my butting in and pedantry, but DDR4 has 4 banks groups per DIMM/module.

Bank 4 would mean it’s the first bank of the 2nd DIMM.

From my research your A6-9220 only has a single memory channel, and it’s highly not recommended to use mixed memory on the same channel. If your CPU had two memory channels, mixing would have been fine. Otherwise, you should really be only running matched pairs of DIMMS on a single channel.

As @linux-aarhus said, you should try and run (maybe re-install too) with a single stick. I’m surprised that it worked with other OS’s, but since you mentioned that it only had 8GB before, perhaps memory wasn’t seated all the way on the 4GB stick and it prevented you from having issues before, but now suddenly started “working” (for the worst) :slight_smile:

Okay well Memtest ran for 8 hours and completed almost 3 passes and it determined there was nothing wrong with my memory.

So I took out the 8 screws and pried off the bottom of this laptop to pull out the memory modules.
I got the same boot error with either ram stick in the first slot and the laptop would not boot with either ram stick in DIMM2.
I have now reinstalled Manjaro for a third time and it still fails. The last thing the boot screen shows berfore it boot loops is.
Finished: Terminate Plymouth boot screen

Also before I put mismatched ram in my computers I did do some research
Just How Bad is Mixing Memory? - YouTube

Welp, sorry for wasting your time with the RAM. Looks like you have gotten farther into the boot process before a boot loop though and the machine check exception no longer shows up?

In which case, best bet to proceed is to chroot into the machine and see if logs have any hints at the issue:

and look at something along the lines of:
journalctl -b -1 -p 0-3

Thanks for all of your help everyone. I really actually do appreciate it.
I’ve decided to move on to Mint XFCE it’s working just fine. I wanted to keep all my Linux computers as Arch derivatives because I’m not smart enough to remember “apt-get beer form fridge” but apparently this hardware is haunted.
Thank you again.