Laptop internal speakers not detected on launch, but work after plugging and unplugging an hdmi cord

Hi! I’m having a little issue. After a recent update, after each full reboot, Manjaro isn’t registering that I have internal speakers in my laptop. After a little exploration, I found in the audio settings tab that the HDMI port audio was being seen, just inactive, while the internal speakers were nowhere to be seen. So, I had the crazy idea to plug in my monitor and then unplug it to see if it would switch over, and this actually worked.

My trouble now is that the internal speakers still aren’t being detected after reboot. This solution works for now, but I won’t always be in a position to plug in my home monitor and then unplug it just so the speakers work after a reboot. Is there a configuration file that got messed up somewhere that would explain why the internal speakers aren’t being connected on launch?

Welcome to Manjaro forum

You should try this first

if speakers are still not working as expected after system is restarted, please post some system information

inxi -Fazy

This worked. Thank you!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.