Laptop does not resume from hibernation on Kernels newer than 5.10

Hello, I’m using Acer Aspire 3 with Manjaro KDE Plasma. While on any kernel newer than 5.10.79-1 (which is LTS), I’m having a problem with my laptop monitor after it goes to sleep.
This problem occurs after any action that turns off monitor (sleep, hibernate…) and the only solution is to hold power off button to force a shutdown.
As I have said, everything seems to be working fine if I switch to 5.10.79-1
I am not a Manjaro expert, I’ve only started using it like two months ago and I’ve had this problem on a fresh install which came with Kernel 5.14.18-1. The only solution I’ve found was to downgrade.

Is there a possible solution or should I just wait for the next Kernel version and hope that it gets fixed?

This is my neofetch result:
OS: Manjaro Linux x86_64
Host: Aspire A314-21 V1.25
Kernel: 5.10.79-1-MANJARO
Uptime: 15 mins
Packages: 1351 (pacman)
Shell: bash 5.1.8
Resolution: 1366x768
DE: Plasma 5.23.3
WM: KWin
Theme: Breath2 2021 Light [Plasma], Breeze [GTK2/3]
Icons: breath2 [Plasma], breath2 [GTK2/3]
Terminal: yakuake
CPU: AMD A4-9120e RADEON R3 2C+2G (2) @ 1.500GHz
GPU: AMD ATI Radeon R2/R3/R4/R5 Graphics
Memory: 1530MiB / 3806MiB

Please post a proper inxi output. The information provided does not give enough information. Do you have a swap file or swap partition??? Please read:

1 Like

Thanks for the reply! Here is the inxi output as per the instructions provided:

  Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=fba38b1e-ee03-4005-8351-0d9e35f364ce rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Aspire A314-21 v: V1.25
  serial: <superuser required>
  Mobo: SR model: Bulbasaur_SR v: V1.25 serial: <superuser required>
  UEFI: Insyde v: 1.25 date: 04/15/2020
  ID-1: BAT1 charge: 14.2 Wh (38.0%) condition: 37.4/37.0 Wh (101.0%)
  volts: 7.4 min: 7.7 model: PANASONIC AP16M5J type: Li-ion serial: <filter>
  status: Discharging
  RAM: total: 3.72 GiB used: 1.81 GiB (48.6%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Dual Core model: AMD A4-9120e RADEON R3 4 COMPUTE CORES 2C+2G bits: 64
  type: MCP arch: Excavator family: 15 (21) model-id: 70 (112) stepping: 0
  microcode: 6006705 cache: L1: 256 KiB L2: 2 MiB bogomips: 5990
  Speed: 1646 MHz min/max: 1100/1500 MHz boost: enabled Core speeds (MHz):
  1: 1737 2: 1240
  Flags: 3dnowprefetch abm acc_power aes aperfmperf apic arat avic avx avx2
  bmi1 bmi2 bpext clflush cmov cmp_legacy constant_tsc cpb cpuid cr8_legacy
  cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid fma fma4 fpu
  fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibs lahf_lm lbrv lm lwp mca mce
  misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nodeid_msr nonstop_tsc
  nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq
  pdpe1gb perfctr_core perfctr_nb pfthreshold pge pni popcnt pse pse36 ptsc
  rdtscp rep_good sep skinit smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 svm
  svm_lock syscall tbm tce tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme
  vmmcall wdt xop xsave xsaveopt
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics]
  vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus-ID: 00:01.0
  chip-ID: 1002:98e4 class-ID: 0300
  Device-2: Quanta VGA WebCam type: USB driver: uvcvideo bus-ID: 1-1.4:4
  chip-ID: 0408:a031 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org compositor: kwin_x11 driver:
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
  display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
  s-diag: 414mm (16.3")
  Monitor-1: eDP res: 1366x768 hz: 60 dpi: 112 size: 309x173mm (12.2x6.8")
  diag: 354mm (13.9")
  OpenGL: renderer: AMD STONEY (DRM 3.40.0 5.10.79-1-MANJARO LLVM 13.0.0)
  v: 4.5 Mesa 21.2.5 direct render: Yes
  Device-1: AMD vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
  bus-ID: 00:01.1 chip-ID: 1002:15b3 class-ID: 0403
  Device-2: AMD Family 15h Audio vendor: Acer Incorporated ALI
  driver: snd_hda_intel v: kernel bus-ID: 00:09.2 chip-ID: 1022:157a
  class-ID: 0403
  Sound Server-1: ALSA v: k5.10.79-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 2000
  bus-ID: 02:00.1 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0f1 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
  vendor: Lite-On driver: ath10k_pci v: kernel bus-ID: 03:00.0
  chip-ID: 168c:0042 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb
  v: 0.8 bus-ID: 1-1.3:3 chip-ID: 04ca:3015 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 5 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 119.24 GiB used: 34.88 GiB (29.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: RBUSNS8180DS3128GJ
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 61E1 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 118.95 GiB size: 116.52 GiB (97.96%)
  used: 34.88 GiB (29.9%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: fba38b1e-ee03-4005-8351-0d9e35f364ce
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
  uuid: 2F68-C03A
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2
  file: /swapfile
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
  chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Advanced Micro Devices Root Hub ports: 4 rev: 2.0
  speed: 480 Mb/s power: 100mA chip-ID: 0438:7900 class-ID: 0900
  Device-1: 1-1.3:3 info: Lite-On Qualcomm Atheros QCA9377 Bluetooth
  type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
  power: 100mA chip-ID: 04ca:3015 class-ID: e001
  Device-2: 1-1.4:4 info: Quanta VGA WebCam type: Video driver: uvcvideo
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0408:a031
  class-ID: 0e02 serial: <filter>
  Hub-3: 2-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 3-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 34.0 C mobo: N/A gpu: amdgpu temp: 32.0 C
  Fan Speeds (RPM): N/A
  Processes: 204 Uptime: 4h 21m wakeups: 3 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1351
  lib: 386 flatpak: 0 Shell: Zsh v: 5.8 default: Bash v: 5.1.8
  running-in: konsole inxi: 3.3.09

To answer your question, I have a swap file.

If you need more information, please give me more instructions.

I don’t use sleep or hibernation and I am not a KDE user either. You have a swap file so that should not be the problem with sleep/hibernation. I would go over your Power settings carefully just to be sure it is not a configuration issue. Also, I would edit the the query to better describe the issue; something along the lines of " laptop does not resume from hibernation on Kernels newer than 5.10".

Take a look here with attention to the Troubleshooting and " Configure the initramfs" sections:

I did not want to presume that the issue is laptop related, but maybe I should change the title.

Interestingly, the resume option was missing from the /etc/mkinitcpio.conf however, after putting the option in, and this is how it looks now, by the way:

HOOKS="base udev autodetect modconf block keyboard keymap consolefont filesystems resume fsck"

and after running the

mkinitcpio -P

command, the laptop still doesn’t resume after the monitor turns off.

Did you update grub after

sudo mkinitcpio -P ?

sudo update-grub


I have not. However, after I did it, I still get the same behavior. Interestingly enough, I now get these errors while manjaro boots:

mount /sys/firmware/efi/efivars: unknown filesystem type 'efivarsfs'
ERROR: resume: no device specified for hibernation

Don’t know if these two lines are related, but the 2nd line looks like it has something to do with the resume option in the /etc/mkinitcpio.conf

I can still boot in the system fine, I just still get the same behavior on the newer kernels though.

Also, about the thread you’ve sent me, I’ve gathered that there was a change in kernel that removed amdgpu_amdkfd_resume_iommu() function, I just don’t know what to do about that.

Should I opet the issue in gitlab somewhere to point out the issue I have? It’s weird that this happendes only on later versions of kernel…

UPDATE: The first line

mount /sys/firmware/efi/efivars: unknown filesystem type 'efivarsfs'

appears only in the newer kernel. Also, while booted in the newer Kernel, rebooting also does not work anymore (the screen goes dark and nothing happens - I have to hold power to force a shutdown)

In 5.10 everything works fine. Only

ERROR: resume: no device specified for hibernation

shows up.