Laptop completely hangs on latest kernels

My laptop (ThinkPad X1 Carbon gen. 4) completely hangs at random times on the actual kernel (6.0.8 at the time) and on the latest LTS kernel 5.15. Also tried Linux Zen from Arch repos with the same result.

How it looks: at some point the system stops accepting commands. At first the mouse looks like functional, I can minimize-maximize and move the windows, but their content is not displayed anymore, only artefacts, Application menu doesn’t work and applications couldn’t being runned. Yakuake(F12) is not called, switching to another session via Ctrl+Alt+F* does not work, Ctrl+Esc does not response. Once I catch hanging with active Konsole and it didn’t respond to commands. Even that hangs deeper after a while. The system completely stops responding to any command, even the hardware CapsLock indicator stops switching. The only thing left is a hard shutdown by holding down the power button.

It’s definitely not overheating - before and during the hanging fans weren’t working even halfway.
It’s definitely not a problem with fs - tried both btfs and (now) ext4.
It must not be a RAM problem, cuz I didn’t done any RAM (or CPU) consuming operations during the hanging, and the problem isn’t connected with load out. I can play games without any problems, but sometimes it may hang in browser with 3-5 tabs.
The fwupdate is done, the firmware for the bios is latest and dated 11.2022.
The same problem was on EndeavourOS, so this problem is not specific to the Manjaro.

Now I’m using the oldest available kernel (4.19.267-1) and it doesn’t have the problem. Only once I faced plasma crashed, but I don’t think that’s related to the described problem, although on fresh kernels the plasma didn’t crash.

Here is my current state of inxi -Fxz

  Kernel: 4.19.265-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: KDE Plasma v: 5.26.3 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20FB004JUS v: ThinkPad X1 Carbon 4th
  Mobo: LENOVO model: 20FB004JUS UEFI: LENOVO v: N1FET81W (1.55 ) date: 10/11/2022
  ID-1: BAT0 charge: 46.9 Wh (100.0%) condition: 46.9/52.1 Wh (90.0%)
    volts: 17.0 min: 15.2 model: SMP 00HW029 status: full
  Info: dual core model: Intel Core i5-6300U bits: 64 type: MT MCP
    arch: Skylake rev: 3 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
  Speed (MHz): avg: 733 high: 800 min/max: 400/3000 cores: 1: 620 2: 712
    3: 800 4: 800 bogomips: 19968
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915
    v: kernel arch: Gen-9 bus-ID: 00:02.0
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-8:4
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.2.3 renderer: Mesa Intel HD Graphics 520 (SKL
    GT2) direct render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
  Sound API: ALSA v: k4.19.265-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes
  Device-1: Intel Ethernet I219-LM vendor: Lenovo driver: e1000e v: 3.2.6-k
    port: N/A bus-ID: 00:1f.6
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel Wireless 8260 driver: iwlwifi v: kernel bus-ID: 04:00.0
  IF: wlp4s0 state: up
  Local Storage: total: 119.24 GiB used: 74.68 GiB (62.6%)
  ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD
    size: 119.24 GiB
  ID-1: / size: 107.86 GiB used: 74.56 GiB (69.1%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 9.4 MiB (3.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 105 MiB (1.2%)
    dev: /dev/nvme0n1p3
  System Temperatures: cpu: 54.0 C pch: 48.5 C mobo: N/A
  Fan Speeds (RPM): cpu: 3522
  Processes: 202 Uptime: 21h 5m Memory: 7.53 GiB used: 4.4 GiB (58.5%)
  Init: systemd Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1452 Shell: Zsh
  v: 5.9 inxi: 3.3.23

we need logs, so switch to the 5.15 kernel and when you are forced to shutdown provide logs with:
journalctl -b-1 -p4 --no-pager