Laptop charging disruptions after installing the Feb 21st and Mar 06th updates

Problem: Change in charging behaviour

Updates were installed on March 10th, then I noticed a change in charging behaviour. The change was that it no longer keeps the battery in a constant changing mode, instead it started to drain the battery to low levels, before resuming the battery charge again.

This change being unusual, I attempted to unplug the charger and plug it back in just to make sure it’s working fine. Doing so would trigger the battery to charge again.

Issue escalation

I didn’t think much of this change as it wasn’t causing any issues over these past 5 days.
However, just 30 minutes ago, the laptop ran out of power to critical levels and went into hibernation.(Which it has done successfully for the 1st time ever in these 2 years since I switched to Manjaro - so good job, devs! It’s not all bad news as previously it would just freeze & I’d have to cut the power).

After resuming the system from hibernation, I attempted the unplug/plug-back-in trick again with the charger. This has worked for 2 seconds, until it switched back to the “Discharging” mode again.

I rebooted the laptop hoping it would reset whatever processes was supposed to monitor the “start charging again” threshold, however it had no effect. The charging indicator seems to be stuck on 5% “Discharging” state:


Could there be also an indicator issue?

Curiously enough, the battery has been holding on these levels for the entire time of me writing this post, so I’m guessing that charging is happening in some way. It’s either flipping on & off very quickly around this 5% threshold, or it’s charging, but the charging status or the battery level are both failing to give accurate readings. This is after a fresh reboot, so there’s not long-running state influencing it.

I don’t think it’s the settings:

I’ve checked the power settings, it appears that it’s set to be “Charging all the time when plugged-in”, which it is and was plugged in. So it shouldn’t be sitting on 5% period given the settings.

The only way I see the settings being an issue is if this “Advance Power Settings” page is lying:

and, perhaps, there’s supposed to be some new config elsewhere. I just don’t know.


  • The historical and expected system’s behaviour when laptop is plugged is for the battery to be in a non-stop charging mode.
  • With the install of updates this has changed to where it feels like it’s alternating between charging and discharging.
  • Based on the current settings, the system should follow the old behaviour.
  • The change in charging behaviour has caused the system to go to hibernation once while it’s actively used over the course of 5 days since the update install.

I’d love to provide some sort of logs, though, I’m not sure what to search for in this case.
Does anyone have any ideas for what the cause of the issue is?

The issue may gone now after unplugging the battery and plugging it back in again whilst the system is running.

The 5% battery Issue was persevering across multiple reboots, but got solved by doing the above. I don’t know why. :man_shrugging:

I’ll try watching for the issue appearing again for another couple days. If it’s gone, I’ll delete the post.