Laptop boots into bios

I was missing around with ubuntu then decided to install manjaro so I did and updated the system, everything was going fine. After a little bit of looking around in the system without touching anything I rebooted it and suddenly it won’t boot to manjaro. Only to bios.

I tried to reinstall it again and when I pressed F12 to get the boot menu I noticed there are ubuntu and manjaro there. But before when I installed it I chose the option to erase the hard disk. So is that the reason for my problem? And how to get rid of ubuntu there ?

Totally new to linux here.

Hello and welcome on the forum,

For beginning we are return the result of tne next command line: inxi --full -verbosity=7 --filter, please.

I think to install a new. Erase and created the part on the hard disc yourself.

did you perform a proper installation, creating a fast 32 partition with mount point boot/efi with boot flag checked?
It seems ubuntu is till in the efiboot manager. That can be cleaned out once you have the laptop booting into manjaro. You might want to perform a clean install, remove and create new partitions.

If you don’t care to reinstall, and only want Manjaro installed on the disk, select the Erase Disk option it should properly format and create the partition automatically.

@omano This is exactly what I did from the beginning and now it’s booting to bios

@Rezenebe Do you mind to give instructions or a link on how to clean it from ubuntu? I’m reinstalling it now using the erase option.

Then I don’t understand why you would have another boot entry if you selected to erase the disk during install. Something is odd.

Probably an UEFI entry which you did not remove. It won’t go away by “erasing the disk”.
Please boot your Manjaro installation and post output of

$ efibootmgr -v

Not sure if this is important to mention. But when I erased the disk and installed manjaro all over again. I got an update for about 500 packages. Installing the I got a message saying "transaction aborted " and when I rebooted the laptop it went again to bios now .

I’m 100% sure when I stick my usb to install it again I’ll find ubuntu there in the boot menu

What do ypu exactly suggest me to do now. I’m totally noob. If you give me steps to do it would be much easier and appreciated

You’re talking about the entries you can manage from the Bios?

Not sure but it could have erased your disc, then could not complete the Manjaro install. Then you get no OS to boot from BIOS.
I’d try to reinstall it again. Let’s just wait what the others advise.

@Falav already did, twice. Keeps booting into bios.

Then in your bios change the boot entry priority if you have multiple. You may even be able to delete the unwanted one.

but you should also focus when people ask you things in order to help you;

Sorry my bad, totally didn’t understand that. I will post the output now.

Should I boot into manjaro from a usb right? Without installing ot all over again?

Yes boot from your Manjaro live USB and run the requested command

This is the output

BootCurrent: 0019
Timeout: 0 seconds
BootOrder: 0001,0000,0015,0016,0017,0018,0019,001A,001B,001C,001D
Boot0000* ubuntu        HD(1,GPT,3a5d6679-3270-459a-afe6-eb28f5b8443f,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0001* Manjaro       HD(1,GPT,e8f711fd-f9c7-5a4f-9a5c-ba4ad31edae5,0x1000,0x96000)/File(\EFI\Manjaro\grubx64.efi)
Boot0010  Setup FvFile(721c8b66-426c-4e86-8e99-3457c46ab0b9)
Boot0011  Boot Menu     FvFile(86488440-41bb-42c7-93ac-450fbf7766bf)
Boot0012  Regulatory Information        FvFile(e4a83242-deee-f12e-15ff-0102036cc3ce)
Boot0013  Diagnostic Splash     FvFile(a7d8d9a6-6ab0-4aeb-ad9d-163e59a7a380)
Boot0014  OilDiagApp    FvFile(f8397897-e203-4a62-b977-9e7e5d94d91b)
Boot0015* NVMe: VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,001c199932d94c4eae9aa0b6e98eb8a4)
Boot0016* MSATA Hard Drive:     VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,91af625956449f41a7b91f4f892ab0f602)
Boot0017* ATA HDD: TOSHIBA MQ04ABF100                           PciRoot(0x0)/Pci(0x17,0x0)/Sata(1,0,0)..bYVD.A...O.*..
Boot0018* ATAPI CD:     VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,aea2090adfde214e8b3a5e471856a354)
Boot0019* USB Device: SanDisk Cruzer Blade      PciRoot(0x0)/Pci(0x14,0x0)/USB(3,0)3.!..3.G..A.....
Boot001A* PXE Network Boot: EFI Network (IPv4)  PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/MAC(b4a9fc6e5926,0)/IPv4(,0,0)x.J.+*.N.....=8.
Boot001B* USB CD:       VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,86701296aa5a7848b66cd49dd3ba6a55)
Boot001C* USB LAN:      VenMsg(bc7838d2-0f82-4d60-8316-c068ee79d25b,e854bca4cae7704ca322b00da0376322)
Boot001D* PCI LAN: EFI Network (IPv6)   PciRoot(0x0)/Pci(0x1d,0x0)/Pci(0x0,0x0)/MAC(b4a9fc6e5926,0)/IPv6([::]:<->[::]:,0,0)x.J.+*.N.....=8.

There is an (old?) ubuntu entry:

To delete it:

$ sudo efibootmgr -b 0000 -B

If that listed Manjaro entry isn’t working properly, try restoring grub.

Not all BIOSes look the same and some aren’t able to be configured properly. I’ve one such machine here.

efibootmgr is “comon ground” and universal these cases.


I just solved the BIOS problem, it seems out that the update I did from the “software update” maneger was the problem. because after the last install I run this command line in the terminal

$ sudo pacman -Syyu

It installed all the updates and upgraded the Kernel and every thing is smooth now.
I even rebooted the Laptop twice to make sure. I just checked again Ubuntu entry is still there so I will use

remove it as @freggel.doe suggested.

Thank you all for your efforts and time.

One more question. If I delete the Ubuntu entry will that effect anything ? or the system will keep working normally? should I expect anything here?