Laggy and buggy window resizing in Cinnamon and other bugs

Hi there everyone, recently ever since I started using the Cinnamon spin of Manjaro on my main desktop, immediately one problem I’ve instantly noticed is resizing windows can be extremely laggy especially on applications such as Firefox while tabbed onto a Youtube video page. Other sites such as Twitter can make the system freeze up for a split second as I scroll through my feed as well. Everything else however like games seem to have no issues, it’s specifically window resizing that causes this lag

I’ve tried other various Cinnamon spins like Garuda’s take on the DE that doesn’t have this laggy window resizing problem, albeit it has a couple of its own little quirks. I’ve tried various kernels, refresh rates, etc and I seemingly haven’t found what’s causing this problem. There is also a couple of smaller faults like highlighting a category in my menu can cause the highlight graphic to jitter and stutter, specifically when watching a Twitch stream, as well as my bluetooth and pamac notifications have their dialogue boxes go beneath the screen when hovering over them.

Definitely a little stumped here and not quite sure what else I can do on my own.

  Kernel: 5.19.16-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    Desktop: Cinnamon v: 5.4.12 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Tactus product: Custom v: N/A
    serial: <superuser required>
  Mobo: ASUSTeK model: ROG STRIX X570-E GAMING WIFI II v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4101
    date: 09/10/2021
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming
    Mouse charge: 100% (should be ignored) status: discharging
  Info: 12-core model: AMD Ryzen 9 5900X bits: 64 type: MT MCP arch: Zen 3
    rev: 2 cache: L1: 768 KiB L2: 6 MiB L3: 64 MiB
  Speed (MHz): avg: 2624 high: 3900 min/max: 2200/5218 boost: disabled
    cores: 1: 3900 2: 3900 3: 2200 4: 2200 5: 2200 6: 2200 7: 3900 8: 3900
    9: 2200 10: 3898 11: 2200 12: 2200 13: 2200 14: 2200 15: 2200 16: 2200
    17: 2200 18: 3900 19: 2200 20: 2200 21: 2200 22: 2200 23: 2200 24: 2200
    bogomips: 187263
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] vendor: Gigabyte
    driver: amdgpu v: kernel arch: RDNA-2 bus-ID: 0c:00.0
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu
    resolution: 2560x1440
  OpenGL: renderer: AMD Radeon RX 6800 XT (sienna_cichlid LLVM 14.0.6 DRM
    3.47 5.19.16-2-MANJARO) v: 4.6 Mesa 22.1.7 direct render: Yes
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel v: kernel
    bus-ID: 1-4:2
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0e:00.4
  Device-3: RODE Microphones NT-USB type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-4: Creative Pebble V3 type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 5-1:2
  Sound API: ALSA v: k5.19.16-2-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.58 running: yes
  Device-1: MEDIATEK MT7921K Wi-Fi 6E 80MHz driver: mt7921e v: kernel
    bus-ID: 04:00.0
  IF: wlp4s0 state: up mac: <filter>
  Device-2: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    port: e000 bus-ID: 05:00.0
  IF: enp5s0 state: down mac: <filter>
  Device-3: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb
    v: kernel port: d000 bus-ID: 06:00.0
  IF: enp6s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  Device-1: MediaTek Wireless_Device type: USB driver: btusb v: 0.8
    bus-ID: 1-6:4
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 8.2 TiB used: 3.43 TiB (41.9%)
  ID-1: /dev/nvme0n1 vendor: Seagate model: FireCuda 530 ZP1000GM30013
    size: 931.51 GiB temp: 42.9 C
  ID-2: /dev/sda vendor: Samsung model: SSD 870 QVO 2TB size: 1.82 TiB
  ID-3: /dev/sdb vendor: Seagate model: ST2000DM008-2FR102 size: 1.82 TiB
  ID-4: /dev/sdc vendor: Seagate model: ST4000NE001-2MA101 size: 3.64 TiB
  ID-5: /dev/sdd type: USB vendor: SanDisk model: USB 3.2Gen1
    size: 14.34 GiB
  ID-1: / size: 915.53 GiB used: 57.29 GiB (6.3%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  Alert: No swap data was found.
  System Temperatures: cpu: 39.0 C mobo: 33.0 C gpu: amdgpu temp: 68.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0
  Processes: 447 Uptime: 11m Memory: 62.71 GiB used: 4.9 GiB (7.8%)
  Init: systemd Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: 1351
  Shell: Bash v: 5.1.16 inxi: 3.3.22

Just a bump to say I recorded a quick video to demonstrate my problem with laggy window resizing if it helps anyone figure out what the problem might be.

I’ve made some progress, turns out the on-screen keyboard was causing the lag when resizing windows so I ended up disabling that completely. However the slow “re-drawing” of the windows upon resizing is an issue that annoyingly still persists.