La opción ELF no es correcta

I tried to update the system today and the following error message was:

Iniciando actualización completa del sistema...
advertencia: python-pyqt5: desactualizando de la versión 5.15.6-7.1 a la versión 5.15.6-7
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquetes (4) inxi-  manjaro-hello-0.6.7-6  manjaro-release-21.3.0-1

Tamaño total de la instalación:  27,74 MiB
Tamaño neto tras actualizar:     -0,01 MiB

:: ¿Continuar con la instalación? [S/n] s
(4/4) comprobando las claves del depósito          [######################] 100%
(4/4) verificando la integridad de los paquetes    [######################] 100%
(4/4) cargando los archivos de los paquetes        [######################] 100%
(4/4) comprobando conflictos entre archivos        [######################] 100%
(4/4) comprobando el espacio disponible en el ...  [######################] 100%
error: «hook» /usr/share/libalpm/hooks/30-systemd-update.hook línea 1: la opción ELF no es correcta
error: no se pudo realizar la operación (no se pudieron ejecutar los «hooks»)
Ocurrieron errores, por lo que no se actualizarán los paquetes 

I run the following terminal command in order to find any answer:

sudo pacman -Qo /usr/share/libalpm/hooks/* | grep 30-
/usr/share/libalpm/hooks/30-systemd-binfmt.hook está contenido en systemd 251.2-3
/usr/share/libalpm/hooks/30-systemd-catalog.hook está contenido en systemd 251.2-3
/usr/share/libalpm/hooks/30-systemd-daemon-reload.hook está contenido en systemd 251.2-3
/usr/share/libalpm/hooks/30-systemd-hwdb.hook está contenido en systemd 251.2-3
/usr/share/libalpm/hooks/30-systemd-sysctl.hook está contenido en systemd 251.2-3
/usr/share/libalpm/hooks/30-systemd-tmpfiles.hook está contenido en systemd 251.2-3
/usr/share/libalpm/hooks/30-systemd-udev-reload.hook está contenido en systemd 251.2-3
/usr/share/libalpm/hooks/30-systemd-update.hook está contenido en systemd 251.2-3
/usr/share/libalpm/hooks/30-update-mime-database.hook está contenido en shared-mime-info 2.0+144+g13695c7-1

The system information is the following:

inxi --admin --verbosity=7 --filter --width
  Kernel: 5.10.121-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=59cdc8ed-6422-4198-a0e5-ba3c5cff247a rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: Kanji product: Tamura MAX DUO v: N/A
    serial: <superuser required>
  Mobo: N/A model: N/A serial: <superuser required>
    UEFI: American Megatrends v: LC-BI-15.6-S133AR200-413-A date: 10/19/2017
  ID-1: BAT0 charge: 40.3 Wh (84.0%) condition: 48.0/N/A Wh volts: 7.6
    min: N/A model: Intel SR 1 SR Real Battery type: Unknown serial: <filter>
    status: discharging
  RAM: total: 3.67 GiB used: 1.99 GiB (54.1%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Celeron N3350 bits: 64 type: MCP arch: Goldmont
    built: 2016 process: Intel 14nm family: 6 model-id: 0x5C (92) stepping: 9
    microcode: 0x48
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
    desc: d-2x24 KiB; i-2x32 KiB L2: 2 MiB desc: 2x1024 KiB
  Speed (MHz): avg: 902 high: 1009 min/max: 800/2400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 796 2: 1009
    bogomips: 4378
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
    arch_perfmon art bts cat_l2 clflush clflushopt cmov constant_tsc cpuid
    cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est
    flexpriority fpu fsgsbase fxsr ht ibpb ibrs ida intel_pt lahf_lm lm mca
    mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat
    pbe pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdrand
    rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap smep ss sse sse2 sse4_1
    sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq tsc_reliable vme vmx vnmi vpid x2apic
    xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass status: Not affected
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 500 driver: i915 v: kernel arch: Gen9
    process: Intel 14n built: 2015-16 ports: active: eDP-1 empty: DP-1,HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:5a85 class-ID: 0300
  Device-2: Alcor Micro USB2.0 Camera type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 1-8:5 chip-ID: 058f:3841
    class-ID: 0102
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 model: BOE Display 0x062b built: 2014 res: 1920x1080
    hz: 60 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
    driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci
    bus-ID: 1-8:5 chip-ID: 058f:3841 bus-ID: 00:0e.0 class-ID: 0102
    chip-ID: 8086:5a98 class-ID: 0403
  Device-2: Alcor Micro USB2.0 Camera type: USB
    driver: snd-usb-audio,uvcvideo
  Sound Server-1: ALSA v: k5.10.121-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.0 running: yes
  Sound Server-4: PipeWire v: 0.3.52 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8168 v: 8.049.02-NAPI modules: r8169 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 01:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: wlp0s21f0u7i2 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek RTL8723BU 802.11b/g/n WLAN Adapter type: USB
    driver: btusb,rtl8xxxu bus-ID: 1-7:4 chip-ID: 0bda:b720 class-ID: e001
    serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 252.69 GiB used: 30.28 GiB (12.0%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: HP model: DF4032 size: 29.12 GiB
    block-size: physical: 512 B logical: 512 B type: SSD serial: <filter>
    rev: 0x8 scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 1.5 Gb/s
    type: SSD serial: <filter> rev: 0010 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 97.66 GiB size: 95.56 GiB (97.86%) used: 18.19 GiB (19.0%)
    fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: Manjaro_root
    uuid: 59cdc8ed-6422-4198-a0e5-ba3c5cff247a
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
    used: 292 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: EFI
    uuid: 82D1-0F63
  ID-3: /home raw-size: 121.52 GiB size: 119.05 GiB (97.97%)
    used: 12.08 GiB (10.1%) fs: ext4 dev: /dev/sda4 maj-min: 8:4
    label: Manjaro_home uuid: 5e31ce64-3f4a-4d63-99f8-806d9d69d9a7
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 3.91 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2 label: swap
    uuid: d7080cd4-6338-477d-a36e-2509cd444e9c
  ID-1: /dev/mmcblk0p1 maj-min: 179:1 size: 300 MiB fs: vfat label: NO_LABEL
    uuid: 09D1-6397
  ID-2: /dev/mmcblk0p2 maj-min: 179:2 size: 28.82 GiB fs: ext4 label: N/A
    uuid: 3af55b27-23cd-43f0-aff6-57a7fcfb32a9
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 8 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: MosArt 2.4G Keyboard Mouse type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 062a:5918 class-ID: 0301
  Device-2: 1-6:3 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:0129
    class-ID: ff00 serial: <filter>
  Device-3: 1-7:4 info: Realtek RTL8723BU 802.11b/g/n WLAN Adapter
    type: Bluetooth driver: btusb,rtl8xxxu interfaces: 3 rev: 2.1
    speed: 480 Mb/s power: 500mA chip-ID: 0bda:b720 class-ID: e001
    serial: <filter>
  Device-4: 1-8:5 info: Alcor Micro USB2.0 Camera type: Video,Audio
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 058f:3841 class-ID: 0102
  Hub-2: 2-0:1 info: Super-speed hub ports: 7 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 45.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 178 Uptime: 12m wakeups: 2 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 13.0.1
  Packages: pacman: 1298 lib: 385 flatpak: 0 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.17

I really appreciate any help, regards.

Hi, I will close this post.
I installed the root partition again.
I have uninstall Windows from


two months ago and installed another Arch Linux distro on this drive. Maybe, something went wrong.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.