Kwin_x11 unable to start

Upon logging in today, no windows were loading with decorations, making my system incredibly difficult to use since windows aren’t taking focus, nor can I use the normal alt-tab to switch focus. Upon further googling, I found that kwin is not starting. When running kwin_x11 it gives the following error:
kwin_x11: error while loading shared libraries: cannot open shared object file: No such file or directory

Is part of the kconfig package … did you updated and put the system to sleep or hibernate after an update, or you did a full reboot of the system ?

I’ve done a full update, rebooted, still no luck. Also tried specifically installing kconfig (pacman -S kconfig) but that didn’t do anything either.

Just an FYI, I am on the kde-unstable branch, though I doubt that’s the cause since I haven’t found any other mentions of this error online.

Please provide
pacman -Qi kconfig
pacman -Qi kwin
I think you have mixed packages after all …

Name            : kconfig
Version         : 5.91.0.r937.g1067eed5-1
Description     : Configuration system
Architecture    : x86_64
URL             :
Licenses        : LGPL
Groups          : kf5
Provides        : None
Depends On      : qt5-base
Optional Deps   : python-pyqt5: for the Python bindings [installed]
Required By     : kactivities  kcompletion  kconfigwidgets  kcontacts  kfilemetadata  kglobalaccel  knotifications  kservice
Optional For    : None
Conflicts With  : None
Replaces        : kconfig-git
Installed Size  : 3.21 MiB
Packager        : Manjaro Build Server <>
Build Date      : Wed 23 Feb 2022 11:05:52 GMT
Install Date    : Tue 08 Mar 2022 09:10:18 GMT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature
Name            : kwin
Version         : 5.23.5.r20800.g7faa2587d-1
Description     : An easy to use, but flexible, composited Window Manager
Architecture    : x86_64
URL             :
Licenses        : LGPL
Groups          : plasma
Provides        : None
Depends On      : kscreenlocker  xcb-util-cursor  plasma-framework  kcmutils  kwayland-server  breeze  qt5-script  pipewire  libqaccessibilityclient  lcms2
Optional Deps   : qt5-virtualkeyboard: virtual keyboard support for kwin-wayland [installed]
Required By     : plasma-workspace
Optional For    : None
Conflicts With  : None
Replaces        : kwin-git
Installed Size  : 17.20 MiB
Packager        : Manjaro Build Server <>
Build Date      : Fri 18 Feb 2022 02:37:57 GMT
Install Date    : Tue 08 Mar 2022 08:12:12 GMT
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature

Those look fine based on the branch compare for stable and testing branches of kde-unstable but i can’t say what might have gone wrong … Maybe i can ping @oberon to check :slight_smile:

@oberon Any ideas what’s gone wrong here?

Could the missing library be replaced with just one file? If so could you link me to your copy of it?

Doesn’t work like that. Also, manual symlinks to system files should also be avoided … Personally i would suggest, for a usable system, to avoid the kde-unstable, unless you know what you are doing and you actively report bugs to KDE development team while also using the debug symbols packages. Otherwise you can still be on unstable, but not the kde dev …

Alright. Is there any way I can get this temporarily fixed so I have a usable DE?

If is an upstream issue, then you will have to wait till someone does a fix and the package is rebuild, otherwise switch from kde-unstable to the normal unstable, refresh mirrors and run the update with
sudo pacman -Syyuu
and let the update replace the kde-unstable git packages …

How would I go about switching to unstable from kde-unstable?

You edit the /etc/pacman-mirrors.conf
Replace the

Branch = kde-unstable


Branch = unstable

Open terminal and run
sudo pacman-mirrors -f5 && sudo pacman -Syyuu

Still seems to be fetching packages from kde-unstable when running the update. are you sure its not just pacman.conf that needs changing?

Well, the issue might be that the name of the packages is the same. A while back the difference was that those packages in kde-unstable had the git to them.
Try to install kwin that should be Version: 5.24.2-2 and also kconfig that should be 5.91.0-1

Later today there will be Plasma 5.24.3 available on unstable, might want to wait for that.

Disable the [kde-unstable]-Repository in /etc/pacman.conf and do a full update allowing downgrades afterwards:

$ sudo pacman -Syyuu
1 Like

Totally forgot about that … Thanks for clarifying that for the OP!!!

1 Like

Thanks for all the help. I’m back up and running with window decorations. I’m missing all the customizing I did, but that’s recoverable.