KWin Shortcuts broken after update to Plasma 6

I’ve used many shortcuts before and everything worked fine. After I updated to KDE Plasma 6, some of my shortcuts don’t work anymore. Currently, the most important for me are my KWin shortcuts I use, like grid view and switching between desktops.

I’ve already rebooted many times and tried to reassign them, but it is still not working.

Anyone have an idea what’s the problem? I’ve found some similar threads on other platforms, but none of them yet has a solution.

1 Like

wayland is not ready yet, switch to x11. I’m on x11 and everything is fine

I’m currently running x11

Look in your shortcuts, some have moved.

Besides which, many of them always sucked!!!

Start with this:


Create a new file named ‘Keyboard shortcuts module’:

[Desktop Entry]
Comment=Launch kcmshell6 Keyboard Shortcuts module
Exec=kcmshell6 kcm_keys

Note that now we’re using kcmshell6.

Now you can launch that to get a tidier shortcuts window.

Toggle Grid View ==> Meta + G is set on mine for

However, a more convenient one for me (easier to reach at least ):
Cycle through Overview and Grid view ==> Meta+Z.

Then, for selecting windows (on all desktops - with a filter you can type any string) I use:
Toggle Present Windows (All Desktops) ==> Ctrl+Space

Try those for size - it’s not so bad after a few days to adjust.

I had to adjust a lot more, because with Plasma 5 running X11 I was using a lot of mouse gestures, so I had to find new ways of doing stuff as I also moved to Wayland.

Plasma 6 is a major upgrade that changed many features, so to avoid any problems coming from old config files, simply create a new user and start using it with Plasma 6.

(read: if you previously used khotkeys to set a shortcut, it will not work. Is not going to work. This is not a bug. This is deprecation. Set the shortcut using kglobalaccel, the unified shortcuts kcm)

1 Like

Thanks for your replies. I’ve got it working after some more searching. A few settings were under Settings > Keyboard > Shortcuts > plasmashell instead of KWin. Also, there were some KWin shortcuts twice, like Toggle Grid View. When I changed from one to another, it worked fine.

With it working, I didn’t need this one, but thank you.

Thanks for this suggestion. I’ll do it as soon as I have some more time to transfer all the important data.

Thanks everyone and have a nice day!


Wayland is functioning remarkably well for something you claim isn’t ready yet - I have used it exclusively for around six months, without any insurmountable issues, and I’m aware of many others who share this experience. Perhaps there is something specific to your configuration that is creating any apparent problem for you. Cheers.