KWin isn't painting/drawing window updates to an external monitor

Hi all,

I’ve recently been assigned a new laptop for work. While it has hybrid graphics, I’m sticking with the vanilla open source drivers because I don’t want to deal with the headache. Using the built-in display works just fine. However, when I connect my external display, some funkiness starts to occur.

  • KDE recognizes the display and prompts me to extend it
  • I do, and the new display turns black
  • I can move my cursor to the display, and see it on the display
  • If I drag a window fully onto the display, it “disappears”
    • the window is not painted on the new display
    • the window is present in the task manager
    • my cursor reacts to where the window should be (i.e., it changes to resize, etc).
  • Using the meta + drag gesture lets me bring the window back to my primary, working display

I can “force” the external display to update by changing its position from the Display Configuration settings panel. When I do this, I can see my wallpaper, as well as the window. However, any attempts to interact with the window don’t paint any changes.

I tried a Wayland session and it worked, but for other reasons (e.g., screen sharing, general stability) I can’t use Wayland.

  Kernel: 5.18.10-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.18-x86_64
    root=UUID=88a34fd2-59b7-46f5-9296-0e6433eeb9dd rw quiet
    root=/dev/mapper/luks-31d11fca-9aa8-4b52-bc13-1c2abdf0cb35 apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20Y6S1U200
    v: ThinkPad X1 Extreme Gen 4i serial: <superuser required> Chassis: type: 10
    serial: <superuser required>
  Mobo: LENOVO model: 20Y6S1U200 v: SDK0T76461 WIN
    serial: <superuser required> UEFI: LENOVO v: N40ET34W (1.16 )
    date: 04/08/2022
  ID-1: BAT0 charge: 85.5 Wh (95.7%) condition: 89.3/90.1 Wh (99.2%)
    volts: 16.6 min: 15.5 model: SMP 5B11B79217 type: Li-poly serial: <filter>
    status: not charging cycles: 3
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master 3
    serial: <filter> charge: 50% (should be ignored) rechargeable: yes
    status: N/A
  RAM: total: 31.08 GiB used: 7.77 GiB (25.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 11th Gen Intel Core i7-11800H bits: 64 type: MT MCP
    arch: Tiger Lake gen: core 11 built: 2020 process: Intel 10nm family: 6
    model-id: 0x8D (141) stepping: 1 microcode: 0x3E
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 640 KiB desc: d-8x48 KiB; i-8x32 KiB L2: 10 MiB desc: 8x1.2 MiB
    L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1039 high: 1287 min/max: 800/4600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1128 2: 1194 3: 1010
    4: 998 5: 1287 6: 1112 7: 801 8: 1026 9: 1224 10: 1105 11: 801 12: 917
    13: 986 14: 1206 15: 800 16: 1031 bogomips: 73744
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-H GT1 [UHD Graphics] vendor: Lenovo driver: i915
    v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21 ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:9a60 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Lenovo
    driver: nouveau v: kernel non-free: 515.xx+ status: current (as of 2022-06)
    arch: Ampere process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: DP-5 empty: DP-6,HDMI-A-2,eDP-2
    bus-ID: 01:00.0 chip-ID: 10de:2520 class-ID: 0300
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo bus-ID: 3- chip-ID: 046d:082d
    class-ID: 0102 serial: <filter>
  Device-4: IMC Networks Integrated RGB Camera type: USB driver: uvcvideo
    bus-ID: 3-8:4 chip-ID: 13d3:5271 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.2
    compositor: kwin_x11 driver: X: loaded: modesetting alternate: fbdev,vesa
    gpu: i915,nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 7680x2400 s-dpi: 96 s-size: 2032x635mm (80.00x25.00")
    s-diag: 2129mm (83.82")
  Monitor-1: DP-5 mapped: DP-1-5 pos: right model: Dell U3818DW
    serial: <filter> built: 2021 res: 3840x1600 hz: 60 dpi: 111 gamma: 1.2
    size: 880x367mm (34.65x14.45") diag: 953mm (37.5") modes: max: 3840x1600
    min: 720x400
  Monitor-2: eDP-1 pos: primary,left model: LG Display 0x06aa built: 2020
    res: 3840x2400 hz: 60 dpi: 284 gamma: 1.2 size: 344x215mm (13.54x8.46")
    diag: 406mm (16") ratio: 16:10 modes: 3840x2400
  OpenGL: renderer: Mesa Intel UHD Graphics (TGL GT1) v: 4.6 Mesa 22.1.3
    direct render: Yes
  Device-1: Intel Tiger Lake-H HD Audio vendor: Lenovo
    driver: sof-audio-pci-intel-tgl bus-ID: 3-
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 046d:082d chip-ID: 8086:43c8 class-ID: 0102 serial: <filter>
    class-ID: 0401
  Device-2: NVIDIA GA106 High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:228e class-ID: 0403
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Device-4: C-Media Henge Audio type: USB
    driver: cm6533_jd,snd-usb-audio,usbhid bus-ID: 3-4.4:8 chip-ID: 0d8c:0022
    class-ID: 0300
  Sound Server-1: ALSA v: k5.18.10-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.54 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: 09:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp9s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152
    bus-ID: 2-2.1:3 chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  IF: enp0s13f0u2u1 state: down mac: <filter>
  IF-ID-1: br-43b20090e4d5 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IP v6: <filter> scope: global
  IP v6: <filter> scope: link
  Message: Output throttled. IPs: 4; Limit: 10; Override: --limit [1-x;-1 all]
  IF-ID-2: br-62a6b8721e31 state: down mac: <filter>
  Message: Output throttled. IPs: 1; Limit: 10; Override: --limit [1-x;-1 all]
  IF-ID-3: docker0 state: down mac: <filter>
  Message: Output throttled. IPs: 1; Limit: 10; Override: --limit [1-x;-1 all]
  IF-ID-4: veth6f7b629 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  WAN IP: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-14:11 chip-ID: 8087:0032 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-31d11fca-9aa8-4b52-bc13-1c2abdf0cb35 maj-min: 254:0
    type: LUKS dm: dm-0 size: 476.64 GiB
  p-1: nvme0n1p2 maj-min: 259:2 size: 476.64 GiB
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 61.68 GiB (12.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Micron model: MTFDHBA512TDV
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 3011P4LN temp: 45.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
    used: 61.68 GiB (13.2%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-31d11fca-9aa8-4b52-bc13-1c2abdf0cb35 label: N/A
    uuid: 88a34fd2-59b7-46f5-9296-0e6433eeb9dd
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 472 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 88E0-E3DA
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 2-2:2 info: VIA Labs USB 3.1 Hub ports: 4 rev: 3.1 speed: 5 Gb/s
    chip-ID: 2109:0817 class-ID: 0900
  Device-1: 2-2.1:3 info: Realtek RTL8153 Gigabit Ethernet Adapter
    type: Network driver: r8152 interfaces: 1 rev: 3.0 speed: 5 Gb/s
    power: 288mA chip-ID: 0bda:8153 class-ID: 0000 serial: <filter>
  Hub-4: 2-2.2:4 info: VIA Labs USB 3.1 Hub ports: 4 rev: 3.1 speed: 5 Gb/s
    chip-ID: 2109:0817 class-ID: 0900
  Hub-5: 2-2.2.2:5 info: VIA Labs USB 3.1 Hub ports: 4 rev: 3.1
    speed: 5 Gb/s chip-ID: 2109:0817 class-ID: 0900
  Hub-6: 3-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-7: 3-4:2 info: VIA Labs USB 2.0 Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    chip-ID: 2109:2817 class-ID: 0900
  Hub-8: 3-4.2:5 info: VIA Labs USB 2.0 Hub ports: 4 rev: 2.1
    speed: 480 Mb/s chip-ID: 2109:2817 class-ID: 0900
  Hub-9: 3-4.2.2:10 info: VIA Labs USB 2.0 Hub ports: 4 rev: 2.1
    speed: 480 Mb/s chip-ID: 2109:2817 class-ID: 0900
  Device-1: 3- info: Logitech HD Pro Webcam C920 type: Video,Audio
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 046d:082d class-ID: 0102 serial: <filter>
  Device-2: 3- info: Logitech Unifying Receiver
    type: Keyboard,Mouse,HID driver: logitech-djreceiver,usbhid interfaces: 3
    rev: 2.0 speed: 12 Mb/s power: 98mA chip-ID: 046d:c52b class-ID: 0300
  Device-3: 3- info: Holtek USB Keyboard type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 04d9:0230 class-ID: 0301
  Device-4: 3-4.2.4:12 info: Henge Docks LLC Docks Stone type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 1.0 speed: 12 Mb/s
    power: 100mA chip-ID: 2a4e:2001 class-ID: 0300 serial: <filter>
  Device-5: 3-4.4:8 info: C-Media Henge Audio type: Audio,HID
    driver: cm6533_jd,snd-usb-audio,usbhid interfaces: 4 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 0d8c:0022 class-ID: 0300
  Hub-10: 3-5:16 info: Texas Instruments ports: 6 rev: 2.1 speed: 480 Mb/s
    chip-ID: 0451:8442 class-ID: 0900
  Device-1: 3-5.5:17 info: Texas Instruments type: HID
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 480 Mb/s
    chip-ID: 0451:82ff class-ID: 0300 serial: <filter>
  Device-2: 3-8:4 info: IMC Networks Integrated RGB Camera type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 13d3:5271 class-ID: 0e02 serial: <filter>
  Device-3: 3-9:7 info: Synaptics type: <vendor specific> driver: N/A
    interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 06cb:00f9
    class-ID: ff00 serial: <filter>
  Device-4: 3-10:9 info: Wacom Pen and multitouch sensor type: HID
    driver: usbhid,wacom interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 400mA
    chip-ID: 056a:52a3 class-ID: 0300
  Device-5: 3-14:11 info: Intel AX210 Bluetooth type: Bluetooth
    driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 8087:0032 class-ID: e001
  Hub-11: 4-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 59.0 C mobo: N/A
  Fan Speeds (RPM): fan-1: 3036 fan-2: 2783
  Processes: 480 Uptime: 33m wakeups: 5977 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6
  Packages: 1359 pacman: 1354 lib: 344 flatpak: 5 Shell: Zsh v: 5.9
  running-in: konsole inxi: 3.3.19
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

KWin Support Information:
The following information should be used when requesting support on e.g.
It provides information about the currently running instance, which options are used,
what OpenGL driver and which effects are running.
Please post the information provided underneath this introductory text to a paste bin service
like instead of pasting into support threads.


KWin version: 5.24.6
Qt Version: 5.15.5
Qt compile version: 5.15.5
XCB compile version: 1.15

Operation Mode: X11 only

Build Options
HAVE_X11_XCB: yes

Vendor: The X.Org Foundation
Vendor Release: 12101003
Protocol Version/Revision: 11/0
SHAPE: yes; Version: 0x11
RANDR: yes; Version: 0x14
DAMAGE: yes; Version: 0x11
Composite: yes; Version: 0x4
RENDER: yes; Version: 0xb
XFIXES: yes; Version: 0x50
SYNC: yes; Version: 0x31
GLX: yes; Version: 0x0

Plugin: org.kde.breeze
Plugin recommends border size: None
Blur: 0
onAllDesktopsAvailable: true
alphaChannelSupported: true
closeOnDoubleClickOnMenu: false
decorationButtonsLeft: 0, 2
decorationButtonsRight: 6, 3, 4, 5
borderSize: 0
gridUnit: 18
font: Noto Sans,10,-1,0,50,0,0,0,0,0
smallSpacing: 4
largeSpacing: 18

Name: KWin::X11StandalonePlatform

themeName: breeze_cursors
themeSize: 24

focusPolicy: 0
xwaylandMaxCrashCount: 3
nextFocusPrefersMouse: false
clickRaise: true
autoRaise: false
autoRaiseInterval: 0
delayFocusInterval: 0
shadeHover: false
shadeHoverInterval: 250
separateScreenFocus: false
activeMouseScreen: true
placement: 6
focusPolicyIsReasonable: true
borderSnapZone: 10
windowSnapZone: 10
centerSnapZone: 0
snapOnlyWhenOverlapping: false
rollOverDesktops: true
focusStealingPreventionLevel: 1
operationTitlebarDblClick: 5000
operationMaxButtonLeftClick: 5000
operationMaxButtonMiddleClick: 5015
operationMaxButtonRightClick: 5014
commandActiveTitlebar1: 0
commandActiveTitlebar2: 1
commandActiveTitlebar3: 2
commandInactiveTitlebar1: 4
commandInactiveTitlebar2: 1
commandInactiveTitlebar3: 2
commandWindow1: 7
commandWindow2: 8
commandWindow3: 8
commandWindowWheel: 28
commandAll1: 10
commandAll2: 3
commandAll3: 14
keyCmdAllModKey: 16777251
condensedTitle: false
electricBorderMaximize: true
electricBorderTiling: true
electricBorderCornerRatio: 0.25
borderlessMaximizedWindows: false
killPingTimeout: 5000
hideUtilityWindowsForInactive: true
compositingMode: 1
useCompositing: true
hiddenPreviews: 1
glSmoothScale: 2
glStrictBinding: true
glStrictBindingFollowsDriver: true
glPreferBufferSwap: 101
glPlatformInterface: 1
windowsBlockCompositing: true

Screen Edges
desktopSwitching: false
desktopSwitchingMovingClients: false
cursorPushBackDistance: 1x1
timeThreshold: 150
reActivateThreshold: 350
actionTopLeft: 0
actionTop: 0
actionTopRight: 0
actionRight: 0
actionBottomRight: 0
actionBottom: 0
actionBottomLeft: 0
actionLeft: 0

Multi-Head: no
Active screen follows mouse:  yes
Number of Screens: 2

Screen 0:
Name: eDP-1
Geometry: 0,0,3840x2400
Scale: 1
Refresh Rate: 60000
Screen 1:
Name: DP-1-5
Geometry: 3840,0,3840x1600
Scale: 1
Refresh Rate: 59993

Compositing is active
Compositing Type: OpenGL
OpenGL vendor string: Intel
OpenGL renderer string: Mesa Intel(R) UHD Graphics (TGL GT1)
OpenGL version string: 4.6 (Compatibility Profile) Mesa 22.1.3
OpenGL platform interface: GLX
OpenGL shading language version string: 4.60
Driver: Intel
GPU class: Tiger Lake
OpenGL version: 4.6
GLSL version: 4.60
Mesa version: 22.1.3
X server version: 1.21.1
Linux kernel version: 5.18.10
Direct rendering: Requires strict binding: yes
GLSL shaders:  yes
Texture NPOT support:  yes
Virtual Machine:  no
OpenGL 2 Shaders are used

Loaded Effects:

Currently Active Effects:

Effect Settings:
zoomFactor: 1.2
mousePointer: 0
mouseTracking: 0
focusTrackingEnabled: false
textCaretTrackingEnabled: false
focusDelay: 350
moveFactor: 20
targetZoom: 1

pluginId: kwin4_effect_logout
isActiveFullScreenEffect: false

pluginId: kwin4_effect_sessionquit
isActiveFullScreenEffect: false

pluginId: kwin4_effect_login
isActiveFullScreenEffect: false

slideInDuration: 150
slideOutDuration: 250

pluginId: kwin4_effect_windowaperture
isActiveFullScreenEffect: false


zoomDuration: 300
border: 10
desktopNameAlignment: 0
layoutMode: 0
customLayoutRows: 2
usePresentWindows: true

duration: 500
horizontalGap: 45
verticalGap: 20
slideDocks: false
slideBackground: true

duration: 160
inRotationEdge: 0
inRotationAngle: 3
inDistance: 30
inOpacity: 0.4
outRotationEdge: 2
outRotationAngle: 3
outDistance: 30
outOpacity: 0


pluginId: kwin4_effect_maximize
isActiveFullScreenEffect: false

pluginId: kwin4_effect_morphingpopups
isActiveFullScreenEffect: false

pluginId: kwin4_effect_frozenapp
isActiveFullScreenEffect: false

pluginId: kwin4_effect_scale
isActiveFullScreenEffect: false

pluginId: kwin4_effect_fullscreen
isActiveFullScreenEffect: false

pluginId: kwin4_effect_squash
isActiveFullScreenEffect: false

pluginId: kwin4_effect_fadingpopups
isActiveFullScreenEffect: false

pluginId: kwin4_effect_dialogparent
isActiveFullScreenEffect: false


layoutMode: 0
showCaptions: true
showIcons: true
doNotCloseWindows: false
ignoreMinimized: false
accuracy: 20
fillGaps: true
fadeDuration: 150
showPanel: true
leftButtonWindow: 1
rightButtonWindow: 2
middleButtonWindow: 0
leftButtonDesktop: 2
middleButtonDesktop: 0
rightButtonDesktop: 0



type: 1


Loaded Plugins:

Available Plugins:

Thanks for taking the time to read this!