KVM with libvirt | Manjaro ISO boot stuck at TLP

Hello,

i recently switched from VMWARE Workstation to KVM and have a very well working virtualization and manage it with libvirt-manager.
I use PCI-Passthrough to forward my graphics card and SSDs etc. to my game OS.
So far so good.
Unfortunately I can't boot the Manajro installation CD because it always hangs at 'Reached target Graphical Interface' and 'Started TLP system startup/shutdown'.
There are many reports on the web, none of them seem to fit my case.
I have of course tried everything possible with the graphics settings ( Spice, vnc, virt+opengl) and I have tested different versions 18.1, 18.0, KDE, xfce etc.
Again and again the same error at exactly the same place, or there is no error, it just doesn't go on.

Console based ISOs like the pure Archiso work as usual.
Debian 10 Buster graphical also works. ZorinOS, partedmagic, elementary also etc...
it seems almost only not to work with Manjaro.
Do you have an idea?

/home/tom/ inxi -Fxzc0
System:    Host: zero Kernel: 5.4.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 Console: tty 2 Distro: Manjaro Linux 
Machine:   Type: Desktop System: Micro-Star product: MS-7B09 v: 2.0 serial: N/A 
Mobo: Micro-Star model: X399 SLI PLUS (MS-7B09) v: 2.0 serial: <filter> UEFI: American Megatrends v: A.70 
date: 11/14/2018 
Battery:   Device-1: hidpp_battery_0 model: Logitech M510 charge: 50% (should be ignored) status: N/A 
CPU:       Topology: 12-Core model: AMD Ryzen Threadripper 1920X bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 6144 KiB 
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 168039 
Speed: 3511 MHz min/max: 2200/3500 MHz Core speeds (MHz): 1: 3511 2: 2167 3: 2187 4: 2150 5: 3398 6: 2283 7: 2040 
8: 2188 9: 2054 10: 2171 11: 3683 12: 2175 13: 2065 14: 2082 15: 2170 16: 2171 17: 2157 18: 2193 19: 2166 
20: 2186 21: 2271 22: 2034 23: 2152 24: 2151 
Graphics:  Device-1: NVIDIA GM206 [GeForce GTX 960] driver: vfio-pci v: 0.2 bus ID: 0b:00.0 
Device-2: NVIDIA GK208B [GeForce GT 710] vendor: Micro-Star MSI driver: nvidia v: 440.44 bus ID: 43:00.0 
Display: server: X.Org 1.20.6 driver: nvidia resolution: 1920x1080~60Hz 
OpenGL: renderer: GeForce GT 710/PCIe/SSE2 v: 4.6.0 NVIDIA 440.44 direct render: Yes 
Audio:     Device-1: NVIDIA GM206 High Definition Audio driver: vfio-pci v: 0.2 bus ID: 0b:00.1 
Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel
bus ID: 0d:00.3
Device-3: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 43:00.1
Sound Server: ALSA v: k5.4.6-2-MANJARO
Network:   Device-1: Intel I211 Gigabit Network vendor: Micro-Star MSI driver: igb v: 5.6.0-k port: 3000 bus ID: 08:00.0
IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: virbr0 state: up speed: N/A duplex: N/A mac: <filter>
IF-ID-2: virbr0-nic state: down mac: <filter>
IF-ID-3: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-4: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
IF-ID-5: vnet0 state: unknown speed: 10 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 524.57 GiB (44.8%)
ID-1: /dev/nvme0n1 vendor: Samsung model: MZVPV256HDGL-000H1 size: 238.47 GiB
ID-2: /dev/nvme1n1 vendor: Western Digital model: WDS500G2X0C-00L350 size: 465.76 GiB
ID-3: /dev/nvme2n1 vendor: Western Digital model: WDS500G2X0C-00L350 size: 465.76 GiB
ID-4: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
ID-5: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
Partition: ID-1: / size: 274.18 GiB used: 27.61 GiB (10.1%) fs: ext4 dev: /dev/dm-0
ID-2: /boot size: 1.91 GiB used: 452.8 MiB (23.2%) fs: ext4 dev: /dev/sda2
ID-3: swap-1 size: 8.00 GiB used: 23.2 MiB (0.3%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 45.5 C mobo: N/A gpu: nvidia temp: 54 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 50%
Info:      Processes: 518 Uptime: 1d 17m Memory: 31.34 GiB used: 6.01 GiB (19.2%) Init: systemd Compilers: gcc: 9.2.0
Shell: zsh v: 5.7.1 inxi: 3.0.37

not really but maybe this video can solve your problem. it shows how to set up pci-passtrough

I'm sorry, but you didn't read it right.
I only mentioned the PCI passthrough for the sake of completeness.
It's going very well and has nothing to do with my problem.
I wrote above that many other operating systems work, ONLY not Manjaro.

Edit the GRUB boot option on live media install and add systemd.mask=tlp.service

Perfect answer,
worked,
thanks a lot.

1 Like

Unfortunately, I still had problems.
It's definitely due to the automatic hardware detection of Manjaro.
If you turn it off, all Manjaro Isos boot perfectly in KVM/Qemu UEFI.
Found here: QEMU/KVM install media fails to boot with UEFI firmware

1 Like

Please tell me, how is MHWD issue described there related to your initial issue with TLP?

Forum kindly sponsored by