Kvantum themes will set but change slightly after closing Kvantum manager

I’m having this really odd issue with Kvantum on Gnome. It worked before, so I am not sure if an update messed it up or if I did something. When I set a theme, the manager window changes to that theme and looks fine. I like dark themes so I have it set to a dark theme, and all the text is set to white in Kvantum manager when I set a dark theme. Then when I click “quit” on the window and open a program that uses this theme or the manager itself, the theme is changed somehow. It doesn’t select a new theme, I mean the theme I chose previous is altered in a way that some parts are dark themed and other parts are with a white background that wasn’t previously. If I set the theme in the manager to something else and back to the previous theme, it looks again… until I close the manager. This white background makes some areas nearly impossible to read because the text is set to white or very light shade of a color.

I am not sure if the theme is altered exactly when I close the manager or when I open a program that uses that theme, not really possible to tell since I cannot see the change until a program is opened. Anyone have any ideas?

  1. It may depend on theme. Which theme you want use?
  2. Kvantum themes work only with QT applications. Are you sure that those apps use QT?
  3. I don’t know how it was solved in Gnome (I use KDE), but try to set QT style to kvantum or kvantum-dark in your system settings (I don’t know difference, for me those two always are same). If this is not available use qt5ct.
  4. Maybe something in system settings blocking it – like global themes for QT and GTK. Check it.

Kvantum change themes after clicking on Use this theme (or similar, my translation from Polish) – Kvantum interface will change instantly, other apps after restart (you don’t need closing Kvantum or restart computer)

I have tried many of the themes that are available in the Kvantum Manager dropdown menu and the same thing is happening in all of them. This is also something that wasn’t happening before, the theme just stuck and worked in all the programs that use QT.

I’m not sure if I am explaining it correctly. The theme DOES get set and stays, but the colors of settings of the theme get all messed up after closing Kvantum Manager. I can recreate this error with just the Kvantum Manager window.
Here is after I selected the theme and everything looks fine:

And here is after I close the manager and immediately open it again without changing anything:

Same theme is set and it just looks completely odd and is almost unreadable in parts. It does exactly this with every dark theme that I pick. If you still think setting the QT style could fix this, then I can research how to do that in Gnome.

I have been having this issue for over a week now and I was fed up with the theming and decided to know if the problem was me or it was for everyone. I downloaded the latest 20.1.1 Gnome ISO a few hours ago and this same issue of theming being inconsistent is preset even in that!

Another bug in the latest ISO is about the gnome-terminal having an extremely buggy feel when having use system colours option turned on.

Are these current upstream Arch bugs too? Or is it there since we are two weeks behind updates? If fixes are out, I heavily request the devs to roll them out as soon as we can as this is driving me crazy :crazy_face:. JK, devs take your time.

Well at least I know I’m not the only one. Maybe it will work correctly again in the next update.

For me it looks that QT5 is trying to follow the theming, but it is a mess (see the picture at we.tl/t-2oRrMagcnV )…
It starts to be not a mess when I remove gnomepaltform or install qt5ct and update .profile with QT_QPA_PLATFORMTHEME=qt5ct. Then you can just separately choose themes for Gnome and QT.

3 Likes

Holy crap, that worked! thanks a lot!

1 Like

OMG! This actually works! :partying_face:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.

Hello, first of all, sorry if my comment enters a separate topic. So far no problems during this update. But. In an update from October last year, Kvantum crashed and does not apply dark themes correctly. In other posts a solution seems to have been found, but honestly I’m a newbie and I don’t know how to apply them or what happened next. Would it be a good idea to apply them in some next stable update? Thanks!

@Fixamer I’ve reopened this post because @cantalisa has trouble implementing your genius solution. Can you dumb down your genius press the three dots below your post and press the :pencil2: and

  • use
  • some
  • simple
  • steps

that anyone can follow?

:pray: :unicorn: :rainbow:

Hi there. Can someone tell me step by step how to solve the problem? I did not understand the indications much. Thanks

Cantalisa,

You already requested that 2021-09-04 23:51 CET, but it depends on the poster of the solution if they can break it down into simpler steps or maybe not, because:

So please be patient OR do some additional research as 2 people so far found the instructions clear enough to implement them.

:bowing_man:

I followed the next advice from a Reddit post:

  1. Install qt5ct and qt5-styleplugins
  2. If it’s not there already, add this line in /etc/environment “QT_QPA_PLATFORMTHEME=qt5ct”
  3. From your menu launch qt5 settings
  4. Under style select “gtk2” and the same for Standard dialogues.
  5. Click apply or ok
  6. Optional - setup your fonts and/or icons

So I installed qt5ct and qt5-styleplugins

I tried following:

cat ~/.profile

But such directory doesn’t exist…

Then I ran the command:

cat /etc/environment

then

sudo gedit /etc/environment

And replaced

QT_QPA_PLATFORMTHEME=gnome

with

QT_QPA_PLATFORMTHEME=qt5ct

But didn’t work so I also run a combination with:

QT_STYLE_OVERRIDE="kvantum"

with

QT_STYLE_OVERRIDE="kvantum-dark"

And still nothing…

-In the Reddit advice, when i open QT5 Settings and select “GTK2” the windows crashes.
-When trying to follow the solution presented here, the directory doesn’t exist.

Now I reverted everything and edit again the default values like it was in the beggining. I’m I doing something wrong? In other forums here in Manjaro, there are still doubts about it, from April, May, it seems that it is a bit latent …