Kscreen2 makes my desktop laggy when i close the laptop montor

I faced with two strange problems since i got updates at 06.12.2022.


  • Dell Laptop with nvidia+intel graphics cards
  • Plasma desktop
  • 2 monitors. External is my primary and left monitor, laptop’s monitor is my right monitor.
  • Using pulseaudio.


  1. After some time of idle, my sound cards stops serving. Playback device and confguration in KDE still exists however there is no sound untill i disable and enable device. I dug in and found that this problem is happening when my device gets in sleep mode. So i commented out # load-module module-suspend-on-idle in /etc/pulse/default.pa and problem solved. However i have no idea why i had to do that after this updates.

  2. When i close my laptop monitor, it also turns off monitor (set in Settings->power management → energy saving ). However after i do that everything moves very slow. i can’t drag a window left to right under 3-4 seconds, games in a window gets laggy etc. Mouse moves as usual.

I discovered that if i stop KScreen2 before doing that everything goes normal. I don’t prefer disable it permenantly. But it starts becoming a headache because whenever i play a game , i have to go first settings-> statup and shutdown -> background services and stop it.

Any idea?

Not sure what you mean by kwin2, but in the settings menu go to energy saving. Where you see “When power button is pressed” select Prompt log out dialog.

See if that helps.

Sorry it was kscreen2, my bad, edited.

@deroberts1 Unfortunately as an answer to you it is already prompt logout and it seems like it is irrelevant. My problem is not about behaviour of laptop lid or power button. I think i clould’nt explain clearly. Let me summarize it:

I set “turn off my laptop screen” when the laptop lid is closed. So i can continue with external monitor. It is ok, works as i expected. However when laptop monitor turned off the desktop becomes laggy. Everything slows down. And when i stop kscreen2 and repeat this steps from beginning everything goes normal.

However i need kscreen2. and i don’t prefer to disable it. At that point my problem starts.