Krunner5 suddenly showing from `pacman -Qm`

As in title.

Using unstable.
Today, out of nowhere I got “reminded” that krunner5 has an update.

I have a script that runs yay -Quaq to check for updates on aur and inform me if such exists.

I have NOT installed krunner5 so I took a look what pacman -Qm would return, and suddenly there is a whole bunch in there I did NOT install.
Seems like leftovers from plasma 5?

Below is a list, and I have marked what I HAVE NOT INSTALLED FROM AUR!

pacman -Qm

cura-bin 5.6.0-2
edid-decode-git r654.a31e680-1 # no idea what this is, have not installed it
electron25 25.9.8-5 # I did NOT install electron from AUR
hw-probe 1.6.5-2
khotkeys 5.27.10-1 # Have NOT installed this
khtml 5.115.0-1 # Have NOT installed this
kjs 5.115.0-1 # Have NOT installed this
kpeoplevcard 0.1-2 # Have NOT installed this
kquickcharts5 5.115.0-1 # Have NOT installed this
krunner5 5.115.0-1 # Have NOT installed this
manly-git 0.4.0.r13.722cfe0-1
plasma-simplemenu 1.0.12-1 # Have NOT installed this
proton-ge-custom-bin 1:GE_Proton9_2-1
rar 7.00-1
spotify 1:
systemd-fsck-silent 239-1 # Have NOT installed this
systemd-kcm 1.2.1-8 # Have NOT installed this
usbimager 1.0.10-1
vlc-pause-click-plugin 2.2.0-1
vmware-keymaps 1.0-3
vmware-workstation 17.5.1-1

So it seems Manjaro just put things in there by itself.
Why and what do I do now?!?

Perhaps some of the packages you have installed from AUR had some of those as dependencies; perhaps not. :man_shrugging:

A few of them are clearly KDE related; a wrong version of kpeoplevcard was accidentally pushed a few months ago; I don’t know the version, but maybe that’s it.

The rest, well, I’d probably need a :crystal_ball:.

Any news about RAR in Plasma6?
(I haven’t checked back since the addition I made to your bug report).

Quite a few seem related to kde, and every one I checked has been dropped from the repos.

Some may be from the AUR, but installed as deps. Check.

pacman -Qi package

Things don’t get installed without the user doing it.

You had them installed before, if not by you, then pulled by something else or with install .iso. And when something is dropped to AUR well… there you go, now it’s bunch of AUR stuff.

1 Like

Unlikely, unless all of those dependencies got pushed like a few hours ago, I checked very recently and there was only “my” stuff in there.

Yeah, they are working on it, should be fixed and pushed soon: 483748 – compressing using rar does not work


pacman -Qii krunner5                                                                                                                                                                                 ✔ 
Name            : krunner5
Version         : 5.115.0-1
Description     : Framework for providing different actions given a string query
Architecture    : x86_64
URL             :
Licenses        : LGPL
Groups          : kf5
Provides        : None
Depends On      : plasma-framework5  threadweaver5
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : krunner<5.111
Replaces        : krunner<5.111
Installed Size  : 854,70 KiB
Packager        : Antonio Rojas <>
Build Date      : 2024-02-03T18:53:07 CET
Install Date    : 2024-02-12T07:06:09 CET
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature
Backup Files    : None
Extended Data   : None

Should not plasma-framework5 have been removed in the upgrade to plasma 6?

I am 99% sure this was not there yesterday or I would have gotten the reminder then.

It is possible that they were pushed out to the AUR when they were dropped from the repo.

Given that they may still be needed by remnants of Plasma 5 — or just generic qt5-based stuff — they may still receive updates from their respective upstream. After all, Plasma 5.27 is an LTS, and Manjaro Stable has only recently updated Plasma 5.27.10 to 5.27.11, while Plasma 6 was already being introduced in Manjaro Testing.

1 Like

So what does that mean?

I just remove them?

I ask again, should those not have been removed in the update to plasma 6?

How should I have been aware that this would happen so I can take precautions against it in the future?
And how do I fix it now?

Not necessarily, no. If they are not listed as dependencies and they do not conflict with any of the new packages, then they will remain in place.


Indeed, seems it has been. One less annoyance solved. :wink:

I’m experiencing some mild deja vu;
recalling the Qt4 <=> Qt5 shamozzle (is that a word?).


Ok, I also have a laptop on testing, not really installed antyhing other than manly-git and vlc-pause-click-plugin from AUR and the same things are in pacman -Qm on that machine too, I just checked.

So I should just accept the manjaro installations are like that now, putting things from the AUR onto my installations hence making the installation “not supported”?

The laptop installation was less than 2 months ago, a completely fresh installation.

No. You should accept that your interpretation of the situation is wrong.

Those packages existed in the repos and on your system, they were probably installed with KDE. They have been removed from the repo.

You either keep the packages (which now come from the AUR), or you remove them and anything that depends upon them.

This is part of system maintenance, you should know this as you’re on unstable.

1 Like

Absolutely, Manjaro installed them when I ran calamares and installed the OS, I have not manually installed anything from them OR what they are dependencies of.

Manjaro is not responsible for your AUR helper script

I am 99% sure this was not there yesterday

I suggest check /var/log/pacman.log

Manjaro installed them when I ran calamares and installed the OS

I suggest check /var/log/Calamares.log

1 Like

LMAO, are you saying “yay -Quaq” changed anything on my system?

I have NOT installed f.ex plasma-framework5 and threadweaver5 that is now holding krunner5, pretty sure MANJARO did that.

Yes they were a part of your OS (which you installed), and those packages came from the repos, so you were ok with them.

Now they may still be part of your OS, but don’t exist in the repos, so yay is telling you they’re now from the AUR.

It’s simply a decision you need to make, keep them or not.

The change is not on your system, it’s in the repos.



To recap then.


If you have an installation less than 2 months old, COMPLETELY CLEAN, Manjaro thinks it is on YOU that you are now in a unsupported state.

It’s up to you to maintain your system, which includes accounting for changes.

Unless you actually went through with the yay update, then you’re still using the versions in stable, at least kpeoplevcard is the same.

i did EXACTLY that, followed all advice in release thread, asked for help here, and the response is a toxic “YoU aRe ReSpOnSiBlE”.

I will now let other know about this.

We’re simply explaining what has happened, and how to deal with it. Apparently that’s toxic, but having a tantrum and calling everyone toxic is not… :man_shrugging:


It is now. :face_with_hand_over_mouth:

1 Like