KRunner does not work as I expect

I was thinking about starting to use KRunner, but as it is working on my machine right now, it is unusable. Every time I activate KRunner, by hitting CTRL+Space (I changed the default key), the text field fills with whatever is in the copy buffer at the time. This, I don’t like, since what’s in my copy buffer is often a password from my password manager.

Worse than that is that the text is not selected, so I have to first use SHIFT+Home to select all text and then I can start typing whatever I want.

There does not seem to be a setting for using the copy buffer or not (I can’t really see why anyone would want that anyway), not even in the config file ~/.config/krunnerrc. Can this be fixed? Are there other “runner” applications that works more like I want them to work, always with an empty field, or maybe with the previous search text BUT SELECTED, so that you can just start to type?

What you are experiencing is most likely the result of the chosen hotkey for invoking krunner. On my system here, I have set the hotkeys for krunner to Alt+F2 and Meta+Space respectively, and I’m not seeing the same thing you are. :man_shrugging:

Nope, still the same with META + space, and I even removed my custom hotkey and used the default one, and it is still the same!?

Try… :arrow_down:

rm -rf ~/.cache/krunner/*

It might be some corruption in your cache.

Sorry, still the same problem…I wasn’t sure I wanted to use it anyway, so I guess I’ll just won’t use it. Is it safe to uninstall?

Have you tried logging out and back in again?

It’s part of the kf5, the KDE Frameworks. I wouldn’t try removing it.

1 Like

Nope, I can’t do that right now, I have a major file copying operation going for another hour or so. As soon as that is completed, I will reboot the machine completely, because I have some other issues as well…

Then I will not :slight_smile:

Also, if problem still persists, create new user, log in and check how KRunner behaive. If it works ok, then it’s an issue with your local settings.


Thank you @edkirin, I will try that too, if a reboot doesn’t solve the problem.

A reboot solved both my problems:

  • KRunner now works as expected, the previous search text is shown and is now selected. Great!
  • Last boot every application had “Keep above” set as default, that has now disappeared as well.

If it stays that way, KDE is looking a lot like my new home (coming from Cinnamon)…:slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.