Krita gives segmentation fault after update

After an update krita doesn’t start up at all when I run it from the terminal it give this output

Segmentation fault (core dumped)

I tried to install krita-git but it gave the same result, then I tried kirta-appimage which worked for me

Have no problem with Krita on any of the installs.
Make sure you run:
sudo pacman-mirrors -f5 && sudo pacman -Syyu krita
Reboot the system and try again.

This problem is caused by Deepin Terminal. Deepin Terminal will cause krita to fail to start. Because yesterday’s update will cause gnome-terminal to fail to start, you need to install other terminals to restore. If Deepin Terminal is installed, krita cannot be started.Run “sudo pacman -Rcs deepin-terminal” , if you have other deepin linux software, you can delete it in the same way.

This issue has been submitted to deepin by Chinese users long time ago, but it still has not been resolved. I also encountered the problem that krita could not start after installing Deepin Terminal and then it was resolved after uninstalling it.

I’m using manjaro KDE and I have the same issue, here is how I fix it:

1. run krita in terminal

# krita

2. check the journal

# journalctl -n 300|grep -A 4 dumped

Stack trace of thread 8994:
                                                   #0  0x00007fd96daa7ab8 _ZN22deepin_platform_plugin8DHighDpi10logicalDpiEP10QXcbScreen ( + 0x4eab8)
                                                   #1  0x00007fd973bb16c2 n/a ( + 0x1636c2)

we can see that the problem is caught by “deepin_platform_plugin”

3. now,we have two way to fix it:

a. uninstall “deepin_platform_plugin” (if you don’t have any other software depend on it)

# sudo pacman -Rs deepin-qt5platform-plugins

b. try firejail to run krita and blacklist belong to deepin-qt5platform-plugins)

# sudo pacman -Sy firejail

# QT_IM_MODULE=xim firejail --noprofile --blacklist=/usr/lib/qt/plugins/platforms/ krita

- set the env “QT_IM_MODULE=xim” incase the keyboad F××k up.
- if krita run well,you can changed the desktop file “sudo vim /usr/share/applications/org.kde.krita.desktop” , replace the exec line:“Exec=QT_IM_MODULE=xim firejail --noprofile --blacklist=/usr/lib/qt/plugins/platforms/ krita" (mine is on line 66,and you can run krita by double click)