Krfb loses password after clone

I cloned a Manjaro 8GB SD card to a 16GB SD card: when I booted for the first time I realized that password of Krfb are not stored and I have to re-insert password anytime I reboot my Rasperry Pi4. On the 8GB card installation password were stored as expected. I guess that is connected to password manager or something like this. At the moment I solved in dirty way by modifying the krbc config file:

[Security]
allowUnattendedAccess=true
desktopPassword=[NoptPostingPublicly]
noWallet=true
unattendedPassword=[AlsoNoptPostingPublicly]

in any case unattended access password are not retained and have to be inserted anytime.

How should I proceed?

:+1: Welcome to Manjaro! :+1:

How? Because ddrescue and CloneZilla Live should have copied everything “as is” and there should be no differences between the 2 sticks (you have to extend partitions using your favourite partition manager after using one of the above).

Also as this is ARM-based, I reclassified your question into the ARM category…

:innocent:

1 Like

Hi,

kwallet store the password, right ?
I’m satisfayed with krfb and krdc.

that surprises me too even I used Balena Etcher to clone it and Gparted to extend partitions

no, I solved by modifying the krfb config file as per my original post.Passwords are not stored in my wallet, but I am not an expert of wallets as I am using gnome on all other machines

I decided to investigate from scratch. I realizes that password are not stored in kwallet, I see a krfb(0) in my wallet, and I do not understand why. I suppose that is a problem with kwallet and not with krfb. But I am not in the position to decode the problem