Konsole ZSH configs lost after system updates

I’m using Manjaro KDE with no significant theme/config tweaks.
Each time one of these “big systems updates” happen, my Konsole ZSH configuration resets. After the update, when I reboot and open Konsole, I get a plain old zsh shell with no colors/tab completions/suggestions/path indicators/icons or anything. Even when I press “CTRL+Left” arrow, some Unicode chars appear instead of moving the cursor.

When this happens, I replace the ~/.zshrc with the following content,

# Enable Powerlevel10k instant prompt. Should stay close to the top of ~/.zshrc.
# Initialization code that may require console input (password prompts, [y/n]
# confirmations, etc.) must go above this block; everything else may go below.
if [[ -r "${XDG_CACHE_HOME:-$HOME/.cache}/p10k-instant-prompt-${(%):-%n}.zsh" ]]; then
  source "${XDG_CACHE_HOME:-$HOME/.cache}/p10k-instant-prompt-${(%):-%n}.zsh"

# Use powerline
# Source manjaro-zsh-configuration
if [[ -e /usr/share/zsh/manjaro-zsh-config ]]; then
  source /usr/share/zsh/manjaro-zsh-config
# Use manjaro zsh prompt
if [[ -e /usr/share/zsh/manjaro-zsh-prompt ]]; then
  source /usr/share/zsh/manjaro-zsh-prompt

# Use manjaro zsh 10k
if [[ -e /usr/share/zsh-theme-powerlevel10k/powerlevel10k.zsh-theme ]]; then
  source /usr/share/zsh-theme-powerlevel10k/powerlevel10k.zsh-theme

# To customize prompt, run `p10k configure` or edit ~/.p10k.zsh.
[[ ! -f ~/.p10k.zsh ]] || source ~/.p10k.zsh

source /usr/share/zsh/plugins/zsh-autosuggestions/zsh-autosuggestions.zsh

# zsh-syntax-highlighting plugin
source /usr/share/zsh/plugins/zsh-syntax-highlighting/zsh-syntax-highlighting.zsh

# CTRL+Left and CTRL+Right
bindkey "^[[1;5C" forward-word
bindkey "^[[1;5D" backward-word

# File/Dir colors
export LS_OPTIONS='--color=auto'
eval "$(dircolors -b)"
alias ls='ls $LS_OPTIONS'

After that, starting the Konsole triggers the powerlevel10k setup, and then everything works well. But this happens every time a 300 MB - 400 MB system update happens. One of my friends got the same issue and fixed it by reinstalling Manjaro, every time it comes.

Info :

Installation: Manjaro KDE - minimum ISO
System update method: Pamac GUI

/etc/skel/ do not have a .zshrc

Not using any external themes/configs for system/Konsole/zsh or anything.

The terminal inside vscode is also affected.

Current system info :

uname -a =>

Linux blaze 5.13.19-2-MANJARO #1 SMP PREEMPT Sun Sep 19 21:31:53 UTC 2021 x86_64 GNU/Linux

cat /etc/lsb-release =>


If you are in the habit of customizing files in /usr tree - don’t - as system files will be overwritten on updates - this is by design and therefore not a bug.

You local configuration in your home ~/ is never touched on updates.

My bad, I didn’t know it. Before this re-occurred from update “manjaro-release (21.1.4-1.0 → 21.1.5-1)” I used to store it on a file on /usr/share/ :cry:

However, the original ~/.zshrc file that comes with the Manjaro installation contains

# Source manjaro-zsh-configuration
if [[ -e /usr/share/zsh/manjaro-zsh-config ]]; then
  source /usr/share/zsh/manjaro-zsh-config
# Use manjaro zsh prompt
if [[ -e /usr/share/zsh/manjaro-zsh-prompt ]]; then
  source /usr/share/zsh/manjaro-zsh-prompt

Both “/usr/share/zsh/manjaro-zsh-config” and “/usr/share/zsh/manjaro-zsh-prompt” does not exist in my system now. But on the last update, they did (Because I didn’t have to create and source the file in the first post ).

Yes, this does not happen on every system update. But it did happen a few times.
I looked into the update log and found :

[2021-10-09T18:01:45+0530] [ALPM] downgraded zsh-theme-powerlevel10k (1.15.0+66+g3e515a7-1 -> 1.15.0

as the last update record.

I don’t use the powerlevel theme - so I don’t know the history.

The manjaro theming is a systemwide theming stored in the /usr tree somewhere and it may be that there has been a change in where the system config is stored.

I suggest you copy the system configuration to your home to have your personal settings survive what ever changes are made to the system config.

Neither are your Timeshift snapshots…

I solved this issue by installing github.com/Chrysostomus/manjaro-zsh-config

It basically provides these missing files (/usr/share/zsh/manjaro-zsh-config and /usr/share/zsh/manjaro-zsh-prompt )

Anyone having the issue can install it using

sudo pacman -S manjaro-zsh-config

Or you can search Add/Remove Software for manjaro-zsh-config