Konsole does not open recent tabs on restart as it did before

Konsole does not open recent tabs as it did before: not at application restart not at system restart.

KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.10-1-MANJARO (64-bit)
Graphics Platform: X11

$ inxi
CPU: 6-Core Intel Core i7-8750H (-MT MCP-) speed/min/max: 800/800/4100 MHz Kernel: 5.14.10-1-MANJARO x86_64
Up: 21m Mem: 5619.0/15863.5 MiB (35.4%) Storage: 2.05 TiB (15.3% used) Procs: 345 Shell: Bash inxi: 3.3.07

$ konsole -v
konsole 21.08.1

I’m not aware of such feature in Konsole.

You may be talking about the KDE desktop session restore feature?

“KDE desktop session restore feature” - Is it responsible for restoring Konsole tabs?
Because recently I had my regular 3-4 tabs in Konsole restored on every restart. Now it’s gone.
Moreover, now Konsole fails with background transparency appearance on system restart.

I guess it might be. How is it configured on your side? Did you recently change it?

That’s another issue try to not mix everything in one thread. Check your compositor settings, see if it is enabled, without it, no transparency I think.


I’ve just checked and it really has “wrong” options selected, though I had no reason to change them - I highly interested in recovering my previous work/applications/state.

I guess it relates to this Custom system settings lost after last upgrade

I felt that you might note that, sorry for my piled-up emotions.
(P.S. I wish the mentioned settings won’t be reset unexpectedly by one of those next upgrades)

Check the first option, Restore previous saved session and see if that fixes it for you.

They were not for me, and probably for everyone else, you might have been unlucky for whatever reason to be determined.

I already done that and had it worked before writing my previous comment. Thanks.

Alright, then mark the thread as solved by selecting the appropriate post (under […] click SOLUTION).

For the KDE settings resetting, I guess it could happen if the config file gets corrupted, or if something goes wrong when using some customization, or other reasons but it is hard to guess. For sure I didn’t have any reset I think since I use KDE.

Sometimes I had to play with config due to this issue Plasmashell (taskbar) does not work.
But I’m not sure if that could effect such global (mentioned) KDE settings.

Yeah it definitely can. This is the main KDE settings file I think.

//EDIT: something you could do is to track and remove all KDE config files from a TTY after logging out, and restart, then it will generate fresh proper KDE configs, then you would have to reconfigure your whole KDE but at least you would have clean config files and it should be OK after that.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.