Kodi won't open?

I just installed kodi because I need a good medial player. VLC keeps crashing, and I believe that it has crashed the whole computer a couple of times. So I’m trying to switch over to Kodi, but it just won’t open. You get a little flash of an icon down in the bottom left hand side of the task bar (KDE) and then it just… closes itself I guess. That’s all that ever happens.

Has anyone else experienced this? I noticed that there are two windows that open in pamac when you install kodi. They ask for two different dependencies, and this makes me wonder if I picked the wrong ones.

If you are not sure to have picked the right one, deinstall all kodi applications you find on your PC and reinstall the version from Manjaro repo using the pacman command as this cannot install anything from AUR.

Its also possible you have a driver problem.

inxi -Fazy

And try launching one of these applications from the terminal… copy any errors/output here.

Kernel: 5.4.58-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
root=UUID=11fc0169-3d12-4399-b7cd-1e12b59fd02e rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Type: Desktop Mobo: Intel model: DH67CF v: AAG10215-203 serial:
BIOS: Intel v: BLH6710H.86A.0078.2010.1118.1944 date: 11/18/2010
Device-1: hidpp_battery_12 model: Logitech M570 serial: charge: 70%
rechargeable: yes status: Discharging

Topology: Quad Core model: Intel Core i5-2500S bits: 64 type: MCP
arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F
L2 cache: 6144 KiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21557
Speed: 1596 MHz min/max: 1600/3700 MHz Core speeds (MHz): 1: 1596 2: 1596
3: 1596 4: 1596
Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
Type: mds mitigation: Clear CPU buffers; SMT disabled
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp

Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected

Device-1: Intel 6 Series/C200 Series Family High Definition Audio
driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / RX 560/560X]
vendor: XFX Pine driver: snd_hda_intel v: kernel bus ID: 01:00.1
chip ID: 1002:aae0
Device-3: Logitech G930 type: USB driver: hid-generic,snd-usb-audio,usbhid
bus ID: 3-1.8:4 chip ID: 046d:0a1f
Sound Server: ALSA v: k5.4.58-1-MANJARO
Device-1: Intel 82579V Gigabit Network driver: e1000e v: 3.2.6-k port: f040
bus ID: 00:19.0 chip ID: 8086:1503
IF: eno1 state: up speed: 1000 Mbps duplex: full mac:
IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Local Storage: total: 262.70 GiB used: 97.35 GiB (37.1%)
SMART Message: Required tool smartctl not installed. Check --recommends
ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial:
rev: 1B6Q scheme: MBR
ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Glide size: 29.82 GiB
block size: physical: 512 B logical: 512 B serial: rev: 2.01
scheme: GPT
ID-1: / raw size: 232.88 GiB size: 228.23 GiB (98.00%)
used: 97.22 GiB (42.6%) fs: ext4 dev: /dev/sda1
Alert: No Swap data was found.
System Temperatures: cpu: 41.0 C mobo: N/A gpu: amdgpu temp: 43 C
Fan Speeds (RPM): N/A gpu: amdgpu fan: 983
Processes: 224 Uptime: 1d 15h 17m Memory: 7.76 GiB used: 5.06 GiB (65.3%)
Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: 1354 pacman: 1347
lib: 385 flatpak: 3 snap: 4 Shell: Bash v: 5.0.18 running in: konsole
inxi: 3.1.05

I had to make all those separate replies, to figure out there is something under “Graphics” that this forum sees as a link. It won’t let me post it. I didn’t see anything in there, so I guess it’s just an error.

The graphic part might be of interest, try to post it somehow, can’t believe it’s not possible…

If you use the code formatting (like by clicking the </> button) it wont be read as a link … and it will be readable by everyone else.

Ok I will try to get that up here in a few minutes. For now, here’s part of the reason I’m trying to make Kodi work. VLC gets stuck open when it freezes. Not even the kill commands can turn it off:

[justin@Linux-Rig ~]$ ps aux | grep [process name]
grep: Unmatched [, [^, [:, [., or [=
[justin@Linux-Rig ~]$ ps aux | grep VLC
justin 259589 0.0 0.0 6288 2164 pts/1 S+ 09:37 0:00 grep --colour=auto VLC
[justin@Linux-Rig ~]$ kill 259589
bash: kill: (259589) - No such process
[justin@Linux-Rig ~]$ pgrep vlc
[justin@Linux-Rig ~]$ kill 201183
[justin@Linux-Rig ~]$ pkill 201183

It’s still open in the system tray. When you click it, you can see that it’s still just frozen on the last media item it was playing. It’s also visible as a running process in the system monitor.

Side question: I wonder why it says the KVM is a vulnerability…

I’m beginning to think that the problem isn’t with Kodi. There are other programs that behave the same way. Just to see what would happen, I installed Steam on my Manjaro system and downloaded a small, easy to run game called Harvest: Massive Encounter. I did this because I haven’t explored all that much of Linux and I wanted to see it run a game. If only for a minute or two.

The game won’t open. It behaves the same way as Kodi. It seems to make the attempt, and then closes the program immediately. You get a little icon flash in the bottom right hand side of the taskbar (KDE) as though the program is trying to start. But then that disappears and nothing ever happens. So I tried another game, one called “No more room in hell”. This game starts and runs just fine. This also happens frequently with VLC Media Player. But not always. Sometimes, I’ll go to play a video and all I’ll get is the icon flash in the taskbar.

My guess is that there are other programs that would behave this way as well, I just haven’t attempted to run them yet.

It sounds like something is wrong with your install.

You should probably start here (specifically in the inxi part):

Well just as an update, I recently installed Manjaro on a new machine and Kodi also behaves the same way. Haven’t made any changes to the new install except to add a few desktop icons and resize the display. I wanted to see if you were right and something was wrong with my OS. It now appears that it’s something wrong with kodi, or manjaro kde. Not just my particular install. No reason it would behave that way on two different computers, one with a fresh install.

I had the same issue! In my case, it was because I was blindly accepting the default installation for Kodi, at the prompt for:

:: There are 3 providers available for KODI-BIN:
:: Repository community
   1) kodi-gbm  2) kodi-wayland  3) kodi-x11

Enter a number (default=1):

I had gone with 1, but it appears I needed kodi-x11, possibly because I’m using xfce?

sudo pacman -R kodi kodi-gbm
sudo pacman -Syu kodi

worked for me!

1 Like