Kodi sets volume to maximum

Hello,

Brand new Manjaro convert. Just installed and tried to run Kodi but everytime I start a video the volume jumps to 100%! Literally unusable...

I found a post that recommeneds setting etc/pulse/daemon.conf and set "flat-volumes = no" but it is already like that by default.

I tried to set "flat-volumes = yes", saved the file, rebooted, then "flat-volumes = no" and rebooted again.

I've tried reinstalling kodi + pulseaudio.

I have a HDA Intel PCH card, Realtek ALC663 chip
Manjaro kernal 4.19.59-1

Thanks!

welcome to the forum, can you post some more info. be sure to use the </> button above the post entry box when posting terminal output so it's formatted properly.

post output of:

inxi -Fxxxz
hwinfo --sound

also when you say kodi changes the volume to 100, do you mean the volume level in kodi is set to 100, or that kodi is changing the system's volume to 100 ?

Just starting Kodi sets the system volume to 100%.
I also tried plugging in my headphones and the same thing happens.

Output for:

inxi -Fxxxz
System:
  Host: darren-manjaro Kernel: 4.19.59-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.3 tk: Qt 5.13.0 
  wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:
  Type: Laptop System: ASUSTeK product: G56JK v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: G56JK v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: G56JK.202 date: 09/26/2014 
Battery:
  ID-1: BAT0 charge: 28.9 Wh condition: 30.3/56.6 Wh (54%) 
  volts: 10.9/10.9 model: ASUSTeK N56--52 type: Li-ion serial: <filter> 
  status: Not charging 
  Device-1: hidpp_battery_0 model: Logitech K800 serial: <filter> 
  charge: 70% (should be ignored) rechargeable: yes status: Full 
CPU:
  Topology: Quad Core model: Intel Core i7-4710HQ bits: 64 type: MT MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 39924 
  Speed: 1098 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1098 
  2: 1098 3: 1098 4: 1098 5: 1098 6: 1100 7: 1098 8: 1098 
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics 
  vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:0416 
  Device-2: NVIDIA GM107M [GeForce GTX 850M] driver: N/A bus ID: 01:00.0 
  chip ID: 10de:1391 
  Display: x11 server: X.Org 1.20.5 driver: intel compositor: kwin_x11 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.1.2 
  compat-v: 3.0 direct render: Yes 
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:0c0c 
  Device-2: Intel 8 Series/C220 Series High Definition Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:8c20 
  Sound Server: ALSA v: k4.19.59-1-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: Lite-On driver: ath9k v: kernel port: f040 bus ID: 03:00.0 
  chip ID: 168c:0036 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.047.02-NAPI port: d000 
  bus ID: 04:00.0 chip ID: 10ec:8168 
  IF: enp4s0 state: down mac: <filter> 
  Device-3: Lite-On Atheros AR3012 Bluetooth type: USB driver: btusb 
  bus ID: 2-5:8 chip ID: 04ca:300f 
Drives:
  Local Storage: total: 4.32 TiB used: 2.07 TiB (47.8%) 
  ID-1: /dev/sda vendor: Seagate model: ST750LM000-1EJ16G 
  size: 698.64 GiB speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> 
  rev: AS11 scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Western Digital 
  model: WD My Passport 25E2 size: 3.64 TiB serial: <filter> rev: 4005 
  scheme: GPT 
Partition:
  ID-1: / size: 26.88 GiB used: 9.25 GiB (34.4%) fs: ext4 dev: /dev/sda6 
  ID-2: /home size: 70.43 GiB used: 37.08 GiB (52.7%) fs: ext4 
  dev: /dev/sda7 
Sensors:
  System Temperatures: cpu: 58.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2700 
Info:
  Processes: 220 Uptime: 1h 44m Memory: 7.67 GiB used: 1.94 GiB (25.3%) 
  Init: systemd v: 242 Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 
  running in: konsole inxi: 3.0.34

and for:

hwinfo --sound
13: PCI 1b.0: 0403 Audio device                                 
  [Created at pci.386]
  Unique ID: u1Nb.s9FVTfw97zC
  SysFS ID: /devices/pci0000:00/0000:00:1b.0
  SysFS BusID: 0000:00:1b.0
  Hardware Class: sound
  Model: "Intel 8 Series/C220 Series Chipset High Definition Audio Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x8c20 "8 Series/C220 Series Chipset High Definition Audio Controller"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x123f 
  Revision: 0x05
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xf7b10000-0xf7b13fff (rw,non-prefetchable)
  IRQ: 36 (1087 events)
  Module Alias: "pci:v00008086d00008C20sv00001043sd0000123Fbc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

17: PCI 03.0: 0403 Audio device
  [Created at pci.386]
  Unique ID: 3hqH.bQjzHrSTHK8
  SysFS ID: /devices/pci0000:00/0000:00:03.0
  SysFS BusID: 0000:00:03.0
  Hardware Class: sound
  Model: "Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0c0c "Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x2010 
  Revision: 0x06
  Driver: "snd_hda_intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xf7b14000-0xf7b17fff (rw,non-prefetchable)
  IRQ: 38 (350 events)
  Module Alias: "pci:v00008086d00000C0Csv00008086sd00002010bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Thanks in advance for your help.

when you want to edit pulse configurations you should use the ~/.config/pulse directory.

if this command returns nothing
ls -la ~/.config/pulse/

do this:

mkdir ~/.config/pulse/
cp /etc/pulse/* ~/.config/pulse/

now when you make any edits you leave /etc/pulse alone and edit the files in ~/.config/pulse .

after you do that, since your using KDE and it happens to be the one desktop environment i ever had pulseaudio issues with, mainly with pulse settings being reset every time a video or track is played/stopped.

close kodi or any other audio/video apps, then:

systemctl disable pulseaudio --now
systemctl --user enable pulseaudio --now

check that audio is working and try kodi again and see if the volume issue is gone

1 Like

That is golden advice that I never knew. Thanks!

I followed your suggestions and when trying this

systemctl disable pulseaudio --now

I kept getting this

Failed to enable unit: Unit file pulseaudio.service does not exist.

which lead me to here

Somehow running through those and your commands fixed my problem!

Strange thing is, if I try

systemctl disable pulseaudio --now

I still get

Failed to enable unit: Unit file pulseaudio.service does not exist.

But Kodi is functioning now and not setting the volume to 100% anymore so I'm happy.

Thank you very much!

1 Like

for some reason pulseaudio does some silly shyte on kde. i wrote a little mini tutorial to automate restarting pulseaudio in --user mode where it should be running anyhow. i'll see if i can find it.

many days of frustration in the process of figuring that one out. i would have to start playing music, then open pulseaudio-equalizer-ladspa and turn it off/on every single time i paused or the next track started to play. enough to drive me into the rabbit hole that is pulseaudio. anyway, glad it worked out.

Default configuration in etc/pulse/daemon.conf is ; flat-volumes = yes
semicolon character at beginning of the line acts like a comment tag and deactivates the configuration setting
need to delete the semicolon for new configuration to work
easy to miss this as all configuration settings etc/pulse/daemon.conf are commented out with a semicolon

What he means is the default looks like this:

flat-volumes = no
; flat-volumes = yes
1 Like

I think I might have edited those files without really paying attention. Now that I know that profile configs override the system ones I'll definitely use that approach in the future :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark