KODI broken after update

After about of month of putting it off I updated my system, and now KODI is no longer launching. If it try running it from the terminal I get the error:
error while loading shared libraries: libfmt.so.9: cannot open shared object file: No such file or directory
I tried installing fmt version 9 (version 10 was installed) from AUR, and now the error message is the same but for libspdlog.so.1.11
Should I keep hunting for missing packages, or this a bigger issue?

@spikerguy will have to recompile kodi against all of the latest libs.

Does removing and reinstalling Kodi (via pacman) not resolve this? Kodi appears to be available in standard Arch repo’s.

Before posting I had tried the Reinstall button for KODI in Pamac, but it didn’t help.
I just now tried sudo pacman -R kodi and then sudo pacman -S kodi but it also didn’t change anything.

The assumption being, that a reboot was performed between those commands.

Kodi seems to work as expected here (KDE). I really have nothing else to suggest, apart from referring you back to Darksky comment above.

New libraries hit the unstable branch. I am thinking they may have also been snapped to the testing branch also yesterday. I had to rebuild the kodi-rpi packages I maintain the other day.the libfmt error has been around for a while though; before the most recent lib upgrades in unstable.


I am actually on a pi4, and while the generic kodi install from the official repositories (extra) had been working fine, I changed to your kodi-rpi version and its working great! I’ve used the kodi-rpi version in the past, so I’m not sure why I was swapped to the non-rpi build. Is there still a difference between the two versions? I don’t know if the other one had hardware acceleration or not, but I never noticed any slowdowns. Can you give a quick overview of the differences?

the kodi-rpi packagesare has patched ffmpeg built in for HW decoding for the rpi vpu with h264/h265 video but only if you run it outside of a desktop environment. If run with in a DE there is no HW decoding with the rpi like the generic kodi package.