Kmail won't show eMail content

Hi there,
I’ve just reinstalled my whole system a couple of days ago after replacing an SSD disk with an NVMe one and after 8 years of running the same installation I thought it would be fine to do a clean install rather than migrating the system 1 on 1 to new disks every time one died.
Anyhow I have noticed some strange issue with Kontact/KMail which I was not able to fix for days now. After setting up all of my eMail accounts (GMail and some hosted ones, 5 total) KMail does not show me any of the content of any of my accounts. Whether in the preview windows or after double clicking the eMail. I can see the subject and all mails are received but no content is shown whatsoever.
Strange thing is, if I forward or reply any of the mails the content is shown. But simply reading them is currently impossible which is some big drawback to me as it takes much longer to check my eMails.

I’ve been searching for a solution online but couldn’t find anything which matches the problem I described. I checked for akonadi checks and everything but all seems fine from that end. But no matter what I tested and checked in the last days nothing did get KMail to directly show any of the eMails from any folder. It also does not make a difference between GMail or others, it’s the same in every account.

I’ve had this in the past with a work laptop but since I had to wipe it I never did get any solution to this. But now with my private system it is a different story and managing 5 eMail accounts through webmail also takes to much time.

Does anyone know what causes this issue and how I might be able to fix it?

Thanks a lot and I hope somebody had more luck than I did fixing this. :wink:

Could be video / driver related.

What happens if you suspend composting and then try to re-open Kmail to see if it resolves?

What GPU / driver are you using?

Have you tried with a different theme in Kmail / Plasma?

Disabling composting didn’t help. Driver is the same as I had before re-installing, also the graphics card did not change (Radeon HD 7870). Driver is the open source one “video-linux”.

Changing themes did not help either. :pensive:

Never used KMail … too much trouble out of nowhere.

But:
What about a new user and another setup for KMail?

Or:
Boot up a Live Manjaro and try there again?

Or:
Purge and reinstall KMail?

Or:
The Mail-Preview Window of Kmail is minimized. Search by moving your mouse cursor or look in the Kmail menue?

Or:
Change to thunderbird and become happy as me . Ok, i think thats no option for you?!!

Thanks, for all the suggestions. I tend to fix things rather than switching and ignoring them and in this case it used to work. Also the preview window is there but just empty. Also opening the eMail shows a blank window. So it’s definitely related to KMail.
Didn’t purge and start over though as like I mentioned I tend to rather fix and understand the problem so I can deal with it better if it ever happens again. :wink:
Also I feel that Thunderbird kinda lacks behind the KMail when it comes to integration and the overall feeling when using KDE. It feels more like being out of place but that’s just my subjective feeling when working with KMail and Thunderbird and compare them with each other (although I use and recommend Thunderbird on Windows if Outlook is not a must).

Yes, this way you will learn a lot … and on Linux to learn allways is essential

Good luck!!

Well, if only I would know where to exactly look at and what to check to hunt this issue down. So far researching on the internet only showed some old and already akonadi bugs from many years ago which indicated something similar. They referred to re-create the index which I did but nothing changed. Other than this I could not find anything like that or any possible solution. I was hoping some people with more insights can be found here which might have an idea where to look at or what might cause this behavior so I can fix it :wink: