Kmail Local Folders disconnected after update

After yesterday’s updates, Kmail ‘lost’ the Local folders. The ~/.local/share/local-mail was still there, seemingly intact, but a test folder created in Kmail appeared in a new “”. I tried connecting to this in the settings local folders configuration without success.
I then tried renaming my local-mail to, which didn’t work, then copying the local folders over, somehow ending up with “…”. Which does work, although a few sub-sub-folders have vanished from both old and new structures. Renaming just adds to the chaos. The filters are still there, but I have had to redefine their target folders. Kmail still thinks it is connected to “”.
What has happened? Can I safely leave things as they are, or will Kmail revert and lose my folders again? Is there a good solution? (Thunderbird is not, for me, a good solution.)

  1. Please read this:
    How to provide good information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.