Kingston DataTraveler Vault: "no DTVP device found"

Hello all,

I already did a search for Kingston, dtvp, encrypt, usb, vault, but didn’t get any interesting results. So I try it this way.

I own a Kingston DataTraveler Vault 4GB. This device has been set up on Kubuntu following the official manual and it works on Kubuntu pretty fine.

To use it on my main machine with Manjaro i3, I do
cd /run/media/daniel/DTVP30/linux/linux64/
sudo ./DTVP_login
After entering my sudo-password there is a message “Can not detect DTVP device !!”

In PCMANFM the stick is shown, the unprotected part of course. But when pressing “eject” in PCMANFM or when entering
umount /run/media/daniel/DTVP30
PCMANFM crashes.
That is not normal, because nothing else crashes on my Manjaro machine.

Yesterday, for testing, I did a new initialize on the stick on Kubuntu. And there it works normal.
But under Manjaro i3 I cannot execute any of the programs on the stick, no “init” and no “forgot”.

lsusb and lsblk show, filtered for the stick, the following:

  • lsusb:
    Bus 002 Device 005: ID 0951:1505 Kingston Technology DTVaultPrivacy30
  • lsblk:
    sr0 11:0 1 100M 0 rom /run/media/daniel/DTVP30

Thanks for your hints!

Can’t find it …

Looked in the AUR and found this:

AUR (en) - dtvp-utils

it may be what you need

Thanks for the answer!

Manual can be found here
[http s://]

I installed dtvp-utils from AUR (seems those are the same as already on the stick), cd’d into /usr/bin/ where it was installed to, and executed sudo ./dtvt_login.
same problem

For testing, I took the apps in the linux32 path, but still no dtvp device detected.

Why not reformat with LUKS encryption? Is there something special about this proprietary software? I always delete stuff like that first thing on a new USB stick. This sounds like more trouble than it is worth.

yes, this literally copies the directory with the commands in it
from the stick to system directories
so that you don’t need to change directories into the stick and execute them from there

it’s just more convenient that way

i3 is just a window manager and some programs
Kubuntu is a full KDE desktop
much more is automated and made easily accessible with a click

I’d think what happens when you “decrypt” that encrypted part of the device
via your command
another device is made accessible

perhaps check
lsblk -f
again after unlock whether that is so

I have never seen it in operation and don’t know what is supposed to happen.
You have - on KDE in Ubuntu.
i3 is a much more sparse environment - more manual work probably

I owned a Kingston Data Traveller vault: is a very unreliable device
it does not work on some usb ports or sometimes ==> better dispose of!

reformatting would make my investment in this stick overfluid, you understand :slight_smile:
I don’t want to. Also I could imagine there is some special hardware within this device.
Short: I want to use this device its supposed way.

I got your point on copying the tools into the system directories. :+1:
Well, I really like i3, it’s ultra fast and minimal. And I don’t have any problem working with it as long as anything is setup correctly. My scanner works, printer too, audio interface, external CD-ROM, normal USB sticks. I don’t want anything else.
There are always some issues, that makes it interesting :slight_smile:

Nachlese, you are absolutely right: logging in on the stick makes a hidden device accessible.
I logged in into the stick on my tablet, Kubuntu, but that is not my main machine. You can see on the screenshot (wanted to upload but cannot find a function to do so) the lsblk -f output and the Partition Manager output. Now I could use it pretty comfortable like any normal stick. Everything is fine here, but still not on i3.

Screenshot lsblk -f shows the following: (sorry for the formatting, but wasn’t possible otherwise)

'-sda1 vfat FAT32 SECURITY FFFF-77B4 3.9G 0% /media/SECURITY
sr0 iso9660 Joliet Extension DTVP30 2018-04-04-08-39-02-00 0 100% /media/DTVP30

sda is the hidden location.
sr0 is the part that is available when just plugging in the stick.

Please help me make it work, don’t want to reformat with LUKS.


'-sda1 vfat FAT32 SECURITY FFFF-77B4 3.9G 0% /media/SECURITY

It is a device ~ 4 GB in capacity, which is accessible under the directory /media/SECURITY
there should be all your secret data
on a vfat filesystem named SECURITY

lsblk -f output is structured like a table

this is the heading:
and under each tag are the corresponding columns of the output
so that you know what is what

this is my system, for example:

NAME     FSTYPE      FSVER LABEL  UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─sda1   vfat        FAT32 EFISYS ACDE-A3C7                             510,7M     0% /boot/efi
├─sda2   ext4        1.0   boot   ef07ba8b-8853-4d17-bce2-e86737b35aaa  289,6M    33% /boot
└─sda4   crypto_LUKS 2            7b4bb6e5-f2e3-435d-834e-8c3ee34f3865                
  └─encr ext4        1.0          305afbd2-b8a3-4e18-8828-34c6d1ead4d1  780,8G    16% /

go to /media/SECURITY and find your stuff there

as you can see - it is possible :nerd_face:
highlight the text and use this symbol: </>
(preformatted text)

mc as a filemanager fits really nicely into i3, IMO
keyboard driven, but mouse works too
have a look if you don’t know it yet

Hello Nachlese,

I just found the reason: neet to run “sudo modprobe sg”, which loads an SCSI kernel module.
Now I need to make this command run at system boot.

Some other person had the same issue on Endeavour OS and could solve it that way. Will try it and post the result.

:ok_hand: probably something like:

sudo nano /etc/modules-load.d/sg_mod.conf

then just put
in it, save and close

Kernel module - ArchWiki

Hello again,

that’s it, thanks!

So just for conclusion what I have done in case anyone has that same problem:

add “sg” to kernel modules that are loaded at system start

  • type “sudo nano /etc/modules-load.d/dtvp.conf”
  • just add “sg” without quotation marks and save that file
  • restart system
  • this automatically loads the required SCSI generic driver at system start and DTVP devices should get detected now

The name you chose for your file is different from my example - but the name doesn’t matter
as long as it ends with .conf

The name should probably be descriptive - it makes things easier for you. The machine doesn’t care.
You can even put a comment inside the file to remind you what it is there for.

start with a hash mark # and then put anything you like on that line - like:

# this is to load the sg kernel module so my kingston data traveler vault will work as intended

… you may have the “solution” mark - I could not care less about anything else than this. :sunglasses:

Just wanted to make you aware of what is actually important here and what is not.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.