Keyboard, Touchpad, Mouse input lag

I’m experiencing this issue for a while already.

Whenever I don’t use them for a bit (~5-10s) they are “stuck” and a lag occurs. Sometimes sending the input multiple times.

e.g. with Strg+w accidentally closing 2 tabs in firefox,
or the courser moves a bit gets stuck and then moves again

With a keyboard the lag only happens after an idle time, while moving the mouse it sometimes happens in between as well.

some observations

  • It only occurs when no external monitor is connected.
  • How the monitor is connected does not seem to matter (hdmi, Usb-c+db)
  • Tried with different monitors
  • it happens on external and internal keyboards/mices
  • power plugged in or not does not seem to matter

Right now it was hard to reproduce the issue, the next time this gets annoying what log messages could I check?

Some system infos.

$ inxi -Fazy

/System:
  Kernel: 5.10.19-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=d533e8d0-5320-414e-b164-3f637e551613 rw quiet
  cryptdevice=UUID=29ad5aaf-a3f2-4b54-bcc8-3ae4e551cf75:luks-29ad5aaf-a3f2-4b54-bcc8-3ae4e551cf75
  root=/dev/mapper/luks-29ad5aaf-a3f2-4b54-bcc8-3ae4e551cf75
  resume=/dev/mapper/luks-29ad5aaf-a3f2-4b54-bcc8-3ae4e551cf75 apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: awesome 4.3 dm: LightDM 1.30.0 Distro: Manjaro Linux
Machine:
  Type: Laptop System: LENOVO product: 20QNCTO1WW v: ThinkPad P53
  serial: <filter> Chassis: type: 10 serial: <filter>
  Mobo: LENOVO model: 20QNCTO1WW v: SDK0R32862 WIN serial: <filter>
  UEFI: LENOVO v: N2NET31W (1.16 ) date: 10/09/2019
Battery:
  ID-1: BAT0 charge: 49.7 Wh condition: 84.2/90.0 Wh (94%) volts: 11.6/11.2
  model: SMP 02DL028 type: Li-poly serial: <filter> status: Unknown cycles: 75
  Device-1: hidpp_battery_1 model: Logitech Wireless Mouse MX Master 3
  serial: <filter> charge: 100% (should be ignored) rechargeable: yes
  status: Discharging
CPU:
  Info: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10)
  microcode: DE L2 cache: 12 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 62431
  Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
  4: 800 5: 800 6: 800 7: 800 8: 800 9: 800 10: 800 11: 800 12: 800
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel UHD Graphics 630 vendor: Lenovo driver: i915 v: kernel
  bus ID: 00:02.0 chip ID: 8086:3e9b class ID: 0300
  Device-2: NVIDIA TU117GLM [Quadro T2000 Mobile / Max-Q] vendor: Lenovo
  driver: nvidia v: 460.56 alternate: nouveau,nvidia_drm bus ID: 01:00.0
  chip ID: 10de:1fb8 class ID: 0300
  Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
  bus ID: 1-8:4 chip ID: 13d3:56bc class ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting,nvidia
  display ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 111 s-size: 878x494mm (34.6x19.4")
  s-diag: 1007mm (39.7")
  Monitor-1: HDMI-0 res: 3840x2160 hz: 30 dpi: 111
  size: 878x485mm (34.6x19.1") diag: 1003mm (39.5")
  OpenGL: renderer: Quadro T2000/PCIe/SSE2 v: 4.6.0 NVIDIA 460.56
  direct render: Yes
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Lenovo driver: snd_hda_intel
  v: kernel alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3
  chip ID: 8086:a348 class ID: 0403
  Device-2: JMTek LLC. USB PnP Audio Device type: USB
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-5.2.3:16
  chip ID: 0c76:153f class ID: 0300
  Sound Server: ALSA v: k5.10.19-1-MANJARO
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
  bus ID: 1-14:9 chip ID: 8087:0029 class ID: e001
  Message: Required tool hciconfig not installed. Check --recommends
Drives:
  Local Storage: total: 1.86 TiB used: 413.74 GiB (21.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:3 vendor: Samsung model: MZVLB1T0HBLR-000L7
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 rotation: SSD serial: <filter> rev: 4M2QEXF7 temp: 38.9 C
  scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: MZVLB1T0HBLR-000L7
  size: 953.87 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 rotation: SSD serial: <filter> rev: 4M2QEXF7 temp: 43.9 C
  scheme: GPT
Partition:
  ID-1: / raw size: 953.57 GiB size: 937.61 GiB (98.33%)
  used: 206.87 GiB (22.1%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-29ad5aaf-a3f2-4b54-bcc8-3ae4e551cf75
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%)
  used: 424 KiB (0.1%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:1
Swap:
  Alert: No Swap data was found.
Sensors:
  System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 48 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 373 Uptime: 1h 33m wakeups: 4744 Memory: 31.01 GiB
  used: 6.04 GiB (19.5%) Init: systemd v: 247 Compilers: gcc: 10.2.0
  clang: 11.1.0 Packages: pacman: 1744 lib: 446 flatpak: 0 Shell: fish
  v: 3.1.2 default: Zsh v: 5.8 running in: alacritty inxi: 3.3.01
2 Likes

Any updates? I too have been experiencing some lags. I can type pn keyboard and still see the key presses being resolved on scree. Im still on the native monitor.

I"m having the same issue, after searching I seem to have fixed it by just downgrading my kernel from 5.15 to 5.10