Keyboard shortcuts not working properly

Hello, Manjaro KDE does not detect correctly some keys like F3, F4, F5, F9 and F12 instead this keys work like multimedia controls play, next, stop, mute vol+, etc, please help me. How can I fix this.

System: Kernel: 5.10.15-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 Desktop: KDE Plasma 5.20.5 Distro: Manjaro Linux
Machine: Type: Desktop System: Hewlett-Packard product: HP Z800 Workstation v: N/A serial:
Mobo: Hewlett-Packard model: 0AECh v: D serial: BIOS: Hewlett-Packard v: 786G5 v03.12 date: 09/13/2010
CPU: Info: 2x Quad Core model: Intel Xeon E5620 bits: 64 type: MT MCP SMP arch: Nehalem rev: 2 L2 cache: 24 MiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 76626
Speed: 1596 MHz min/max: 1596/2395 MHz boost: enabled Core speeds (MHz): 1: 1596 2: 1596 3: 1596 4: 1596 5: 1596
6: 1596 7: 1596 8: 1596 9: 1596 10: 1595 11: 1596 12: 1596 13: 1596 14: 1596 15: 1596 16: 1596
Graphics: Device-1: NVIDIA GM204 [GeForce GTX 970] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 0f:00.0
Display: x11 server: X.Org 1.20.10 driver: loaded: modesetting resolution: 1: 1680x1050~60Hz
OpenGL: renderer: NV124 v: 4.3 Mesa 20.3.4 direct render: Yes
Audio: Device-1: Intel 82801JI HD Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0
Device-2: NVIDIA GM204 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 0f:00.1
Sound Server: ALSA v: k5.10.15-1-MANJARO

Not much information there…
Try this (type ``` with your `~ key to make a code block) and/or tell us what keyboard you have plugged in…

❯ lsusb
Bus 002 Device 004: ID 062a:5918 MosArt Semiconductor Corp. 2.4G Keyboard Mouse
Bus 002 Device 003: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 25a7:2433 Areson Technology Corp 2.4G Wireless Device

If you’ve a Logitech, or otherwise a keyboard with function and F keys combined… with some recent keyboards they put a ‘function’ key and made the F1-F12 keys perform a swapped function.
Usually color coded (i.e. on mine now, the F9 is the function, and ‘Fn’ key makes it do ‘mute’ which is coloured blue. On my K400, the key does mute unless I press Fn to do F9).

I have 2 solutions (meaning if you have a HP keyboard with Fn button and can’t swap, just go out and buy the Logitech K270, to replace the aging HP keyboard - K270 has separate, though limited, media keys).

The first is Solaar which deals with logitech keyboards and has a swapfx function. It’s clumbsy (takes 3-4 seconds) to switch, but good to render your keyboard for multimedia when you’re playing music and not using the F keys too much (but still, the Fn key can do a temporary swap if you really need F2).

I bound this script to ScrollLock - it takes 4 seconds to give a notification so it isn’t quick…

checkstatus=$(solaar config 1 | tail -1 | awk '{ print $3 }')
echo "$checkstatus"
if [[ "$checkstatus" == "True" ]] ; then
        solaar config 1 fn-swap off && notify-send 'Functions OFF'
        solaar config 1 fn-swap on && notify-send 'Functions ON'

The second is to use MOUSE GESTURES like these: (I use easystroke but KWin also does shortcuts).

So I can mouse my function keys…
F3 is a 3 which will open ‘split view’ in dolphin etc. F4 pulls up Dolphin terminal etc.

You can map mouse functions to operate BOTH - for example draw 2 for F2 and draw ‘m’ for mail.

The final solution is to use the ‘fn’ keyboard key when pressing the ‘F1/Home’ button to activate the F1 or the Function. I think the k400 keyboard has them reversed (functions as default) but you don’t say what you use.

Anyway, even if it doesn’t solve your issue, I love my solutions :stuck_out_tongue:

Hello, thank you for the answer; I have and usb keyboard Kinesis Advantange connected to a desktop pc.
ekoms@desktop$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 003: ID 4e53:5406 USB OPTICAL MOUSE
Bus 007 Device 002: ID 1241:1503 Belkin Keyboard
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 003: ID 05f3:0007 PI Engineering, Inc. Kinesis Advantage PRO MPC/USB Keyboard
Bus 006 Device 002: ID 05f3:0081 PI Engineering, Inc. Kinesis Integrated Hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Thanks in advance.

Maybe the smartset app could help, but it only runs on Windows by the looks of it… otherwise I’m a bit lost about how to ‘swapfx’ on this keyboard… I assume there must be a way to switch with a special keypress.

Hello, Ben thanks for the answer, I found the answer on old post for the Kinesis FAQ. My F3 and F4 keys were behaving like multimedia keys. This feature can be disabled by holding = and pressing P for PC (you can also use W for Windows and M for Mac).

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.