Keyboard shortcut to snap window to NW, NE, SW, SE corners?

Hi, is anyone using a solution to mimic XFCE’s builtin window resizing keyboard shortcuts, in Gnome? I think I had Put Windows working but then did an update and now the only thing that works is Super+left Super+right for moving to left and right half of the screen, and Put Windows seems incompatible with the current version of gnome-shell. Does anyone know of alternative tools to accomplish this? Thanks!

Do you have gnome-shell-extension-gtile installed? If not… :arrow_down:

sudo pacman -S gnome-shell-extension-gtile

… or… :arrow_down:

pamac install gnome-shell-extension-gtile

I have installed gnome-shell-extension-gtile but I’m not sure how it works… In the “Accelerators” panel there are keyboard shortcuts but they don’t seem to be working. What I want are keyboard shortcuts to move a given window into the “corners” of a screen: top-right, bottom-right, etc. I’m sorry if I’m missing something obvious!

Well, I don’t use GNOME, so all I could do is point you toward the GNOME extension that allows for tiling. If the keyboard shortcuts don’t work, then that is unfortunately not anything I can fix.

However, have you tried logging out and back in? Sometimes that may fix things. :thinking:


Do I not have it installed correctly? The github page says it’s best to use the gnome extensions page, but the “off/on” switch on this page doesn’t seem to have any effect, and does not stay on if I refresh the page. I also don’t have a gTile icon in my toolbar.

I use Tiling Assistant - GNOME Shell Extensions. (Its GitHub: GitHub - Leleat/Tiling-Assistant: A GNOME extension which adds a Windows-like snap assist to the GNOME desktop environment. It also expands the 2x2 grid design.)

For me it worked out of the box. You can use Super + Num 1/3/7/9 to tile immediately to the right corners.

You can check the Extensions app (that I think is installed in Manjaro by default) whether it is installed and/or running. If you use Chrome, you might still need to install the chrome-gnome-shell.

You can also get a list of running extensions using gnome-extensions list --enabled

Finally, do you get a prompt like this when you click the on/off button?

If not, it might not be installed correctly or be missing certain permissions to run correctly.

Thanks for the tip on Tiling assistant.

I checked gnome-extensions list --enabled and got empty output, although in the browser it shows Tiling assistant and gTile as installed, so it seems extensions aren’t being turned on for some reason…

Maybe you can enable them with gnome-extensions list and then gnome-extensions enable <extension name>

If not, use the GUI, it might have set the switch for all extensions to off, try enabling it from there.

You could also install the extension manually, where this blog might be able to help you:

Thanks Masqueey. I ended up reinstalling Manjaro because a bunch of things broke after I did a system update from the testing branch, and now gnome extensions are working.

Happy to help! Sorry you had to reinstall Manjaro