Keyboard settings getting reset to default


I am setting keyboard delay and rate as defaults are to slow for my needs (system settings > keyboard settings). But after I re-login to my computer, these settings are getting reset to defaults, not the ones, that I have applied, which are really slow. I have also tried writing script with “xset r rate 200 50” which would trigger on startup. It works only untill I open any text editor: kate, Webstorm or vscode. Then it resets keyboard settings to a defaults. It seems like a bug to me, but maybe someone had solved this issue?

I have managed to set keyboard delay and repeat options using keyboard layout widget which is located in the panel and used to change the language keyboard layout. I went to widget settings and there is previously mentioned settings. After changing them, removing startup script of xset and rebooting, everything is now working as I like to.

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into a reply to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as your question will now be in the “solved” status.