Keyboard mapping is not perfect

Hello everyone,

I am running Manjaro Gnome on Ideapad IdeaPad 5 15ITL05, US keyboard.
As my hotkeys for settings, Brightness control and a few more are not functioning.

I tried xmodmap -pk where there are assigned keys for brightness controls but those keycodes can not be found when I tried xve.
The key event for Hotkeys does not show up for xve?

How can I fix this? Please guide me through this.

Output for my xmodmap -pk is :

 232    	0x1008ff03 (XF86MonBrightnessDown)	0x0000 (NoSymbol)	0x1008ff03 (XF86MonBrightnessDown)
 233    	0x1008ff02 (XF86MonBrightnessUp)	0x0000 (NoSymbol)	0x1008ff02 (XF86MonBrightnessUp)

My System Info is :

  Kernel: 5.10.61-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=67c8fb25-f5c7-4db5-9154-2e1f04a7ab8c rw quiet splash apparmor=1 
  security=apparmor resume=UUID=7bc34073-1434-480d-b900-89ea33f1d837 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 82FG v: IdeaPad 5 15ITL05 
  serial: <filter> Chassis: type: 10 v: IdeaPad 5 15ITL05 serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO 
  v: FHCN41WW date: 05/17/2021 
  ID-1: BAT0 charge: 46.6 Wh (82.3%) condition: 56.6/57.0 Wh (99.4%) 
  volts: 13.0 min: 11.5 model: Celxpert L19C3PF5 type: Li-poly 
  serial: <filter> status: Charging cycles: 23 
  RAM: total: 15.42 GiB used: 6.63 GiB (43.0%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP 
  arch: Tiger Lake family: 6 model-id: 8C (140) stepping: 1 microcode: 88 
  cache: L2: 8 MiB bogomips: 38720 
  Speed: 606 MHz min/max: 400/2400 MHz Core speeds (MHz): 1: 606 2: 1014 
  3: 555 4: 858 5: 653 6: 988 7: 669 8: 940 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_capabilities 
  arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2 avx512_vnni 
  avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f 
  avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2 cdp_l2 clflush 
  clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl 
  dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma 
  fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp hwp_notify 
  hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid invpcid_single 
  lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b movdiri msr mtrr 
  nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge 
  pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed rdt_a rdtscp rep_good 
  sdbg sep sha_ni smap smep split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 
  ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer 
  tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300 
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus-ID: 3-5:3 
  chip-ID: 174f:2459 class-ID: fe01 serial: <filter> 
  Display: wayland server: 1.20.13 compositor: gnome-shell driver: 
  loaded: intel display-ID: 0 resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: Lenovo 
  driver: sof-audio-pci alternate: snd_hda_intel,snd_sof_pci bus-ID: 00:1f.3 
  chip-ID: 8086:a0c8 class-ID: 0401 
  Sound Server-1: ALSA v: k5.10.61-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: yes 
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel port: 3000 
  bus-ID: 00:14.3 chip-ID: 8086:a0f0 class-ID: 0280 
  IF: wlp0s20f3 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Logitech Dell Wireless Mouse WM123 type: USB 
  driver: hid-generic,usbhid bus-ID: 3-1:2 chip-ID: 046d:c535 class-ID: 0300 
  WAN IP: <filter> 
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 3-10:5 chip-ID: 8087:0026 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 953.87 GiB used: 304.69 GiB (31.9%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: HFS001TD9TNI-L2A0B 
  size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: 11010C10 temp: 34.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 589.36 GiB size: 579.04 GiB (98.25%) 
  used: 195.58 GiB (33.8%) fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6 
  label: N/A uuid: 67c8fb25-f5c7-4db5-9154-2e1f04a7ab8c 
  ID-2: /boot/efi raw-size: 500.9 MiB size: 499.9 MiB (99.80%) 
  used: 292 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p5 maj-min: 259:5 
  label: NO_LABEL uuid: 1424-B942 
  ID-3: /run/media/loserlord/New Volume raw-size: 244.14 GiB 
  size: 244.14 GiB (100.00%) used: 109.11 GiB (44.7%) fs: ntfs 
  dev: /dev/nvme0n1p4 maj-min: 259:4 label: New Volume uuid: 66DAA1ACDAA178C7 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 15.62 GiB used: 512 KiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7 label: N/A 
  uuid: 7bc34073-1434-480d-b900-89ea33f1d837 
  ID-1: /dev/nvme0n1p1 maj-min: 259:1 size: 100 MiB fs: vfat label: N/A 
  uuid: 2A72-BF77 
  ID-2: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-3: /dev/nvme0n1p3 maj-min: 259:3 size: 103.65 GiB fs: ntfs label: N/A 
  uuid: 14E87364E87342D2 
  ID-4: /dev/nvme0n1p8 maj-min: 259:8 size: 508 MiB fs: ntfs label: N/A 
  uuid: 6E3292173291E3FD 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-1:2 info: Logitech Dell Wireless Mouse WM123 type: Mouse,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 98mA 
  chip-ID: 046d:c535 class-ID: 0300 
  Device-2: 3-5:3 info: Syntek Integrated Camera type: Video driver: uvcvideo 
  interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 174f:2459 
  class-ID: fe01 serial: <filter> 
  Device-3: 3-7:4 info: Shenzhen Goodix Goodix FingerPrint Device 
  type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s 
  power: 100mA chip-ID: 27c6:55a2 class-ID: ef00 
  Device-4: 3-10:5 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb 
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026 
  class-ID: e001 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 37.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 310 Uptime: 2d 6h 30m wakeups: 19498 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: 1405 pacman: 1388 lib: 348 
  flatpak: 10 snap: 7 Shell: Zsh v: 5.8 running-in: gnome-terminal 
  inxi: 3.3.06 

I have this same problem on a almost identical model. Didn’t find any solution, apparently the fn keys would need appropriate drivers to work, so it depends on Lenovo. For me even the power button doesn’t work properly. You have the latest bios anyway?

Oh, I understand. Thank you for the response.

About the BIOS version, so I have just checked and the latest release was on the 3rd Sept 21. I don’t have that version. have you got that @pinonat?
And if yes does the problem still persist?

Also, I read around and found out it is risky to upgrade BIOS and might lead to data erasure or some system reinstallation which would definitely be a problem.

Do you have any advice on that?

I’ve upgraded bios twice already. Though my model is 81YK precisely and the latest bios is from August. From the changelog there is no reason for me to think it will solve the problem. But I’ll update it in the next few days and I’ll post the update on this thread.
I’m afraid the problem will persist eventually since lenovo don’t care of model not officially supported.

update: I did update the bios. Nothing changed, fn keys still not working, laptop lid not working and power button not working properly. All regular :v:

Oh, that’s disappointing.
Why does this happen ? Is it because the models are newer and drivers are yet to release for open source?

Is there any way we can mail Lenovo for their support?

Hi, I have the exact same model and also have the same problem. I’ve tried lots of things but none of them worked for me. Last night I updated BIOS [through Windows 10] to its latest version but the issue still persists. ATM I change the brightness level through some custom key binding. It’s still annoying not to be able to change brightness through brightness keys. I also posted about this issue on reddit.

P.S: I’m not using Manjaro. I’m on Arch and I use i3wm.

This is my first post on Manjaro forum and apparently I can’t post URLs.

yes you can contact customer service, and there is also the forum with a section dedicated to linux. But their reply will be that this model is not supported, dumb me who bought lenovo because they are famous to “work well with Linux”

I won’t hope for a definitive solution from Lenovo. The easiest way for us is to use KDE since all the shortcuts are easily customizable, idk about you but I even had to make a shortcut for “suspend” since neither the power button nor the laptop lid would do it.

Thanks, @arman and @pinonat for being so responsive.

I also find it annoying. In GNOME I don’t think we are able to customize shortcuts for Brightness control. I just tried live booting some of the other Linux distros but the issue persists (as anticipated).

Also, I reckon you might also be having problems with the fingerprint scanners not being detected?
I tried using fprintd but my Goodix reader version is not among the list of supported models.

I also tried live booting with Xubuntu but the issue didn’t resolve.
I haven’t tested the fingerprint sensor. The Arch Wiki page for Lenovo laptops says the fingerprint sensor does not work for our laptop model. However, it also says xbacklight also doesn’t work on this model but after upgrading my BIOS, the command just works.


I was thinking of contacting Lenovo regarding our problems.

Is there any way which you might know of? It might be worth trying!

I contacted them via customer service and on the forum, but you won’t have support for it, they just tell you to use windows