Keyboard layout shortcut doesn't change keyboard layout

I right click on the keyboard layout in taskbar (en, gb, no etc based on what keyboard layout is active), choose “Configure Keyboard Layout…” → “Keyboard Shortcuts”. Where it says “This shortcut will activate the applet as though it has been clicked.” Clicking the applet changes keyboard layout.

I choose Alt+Shift, to mimic the Windows shortcut for same thing. It shows being the active one after applied. And if I re-do it it says “Conflict with registred global shortcut, the ‘Alt+Shift’ key is registred by application plasmashell for action Activate Keyboard Layout Widget.” so it really seems to be the active shortcut for chaning keyboard layout.

But when I press Alt+Shift, nothing happens.

Why? Need to make a change somewhere else as well?

You need to set it in the keyboard settings.

System Settings → Keyboard → Keyboard → Advanced → Switching to another layout


Thank you! That did the trick.

Would never have found that.

1 Like

You’re welcome. :slight_smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.