Keyboard layout is not applied

Hi, I want to try Manjaro Sway on an Odroid N2. I downloaded the image and installed it on a SD card with Etcher.

The installer asked me for the language and keyboard layout, but it was not applied.

How can I change that?


Application Launcher > Settings > System Settings > Input Devices > Keyboard > Layouts
I’m using for instance Map: us, Layout: English (US), Variant: English (Intl., with AltGr dead keys)

Sorry for the late answer.

It still doesn’t work. Doesn’t matter which layout I select, I still get qwerty.

Which layout did you try? That way I can try to verify on my Pinebook Pro.

I’m currently using the manjaro sway edition for raspberry pi 4 and has the same issue. By default there’s the american layout and cannot change it to spanish.

I’ve already tried this solution and everything seems the same.

If anyone is able to solve it I’d appreciate it.

After looking online I found this thread where it solves our issue. Basically you have to follow these steps:

  1. open your terminal and write the following command:

cd ~/.config/sway/

  1. modify the config file with nano (or the text editor of your choice)

nano config

  1. paste the following lines at the end of the file

input * xkb_layout “[layout]”
input * xkb_options “caps:escape”

where you replace [layout] with one of the values from the keyboard layout table.

  1. reboot your system

I hope this will solve the issue to you too.

1 Like

I add these lines to the config file. Now sway reports an error

Failed to compile keymap: Couldnt find file "symbols/de" in include paths

I also run locale-gen and it compiles the german locales. Still get the error message

Two questions:

  1. did you use the official sway edition, or do you installed sway from scratch on your own?
  2. can you post the lines you have added? I just checked my configuration, which looks like the following screenshot and this works without any issues…


It seems to work now. I first tried the syntax from BeneToff, but doesn’t work.

I have the official Sway edition installed. Thanks for your help

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.