Keyboard layout for login screen

I created a second user account and set a password.
I have two keyboard layouts installed in my primary account: US English and Hebrew. My location is Israel. The login screen for the second account defaults to Hebrew, and there is no apparent way to switch to English, so I can’t log in to the second account, as the password has English (latin) characters in it.

I tried setting the second account to automatic login, but for some reason, I am still asked for a password.

On top of all this, I can’t find an option for “switch user”.

  1. Execute:

    sudo nano --backup /usr/share/sddm/scripts/Xsetup
  2. You will see:

    # Xsetup - run as root before the login dialog appears
  3. Add this to the end:

    setxkbmap "il,uk"
  4. Restart X (or reboot if you don’t know how to do that) and you will have an :israel: and :uk: keyboard switcher in the lower left corner of your login screen

That’s because you can:

  • just hit Ctrl+Alt+F2 to go to a second TTY,

  • log in there

  • type:

  • Presto: Second user session and you can switch between the 2 sessions by pressing Ctrl+Alt+F1 and Ctrl+Alt+F2

  • So there is absolutely no need to “switch users” like on Windows. :grin:

That’s the worst thing you can ask on a forum, so edit your original question, remove that from your question and open a new topic ¹ and be specific as to what exactly doesn’t work.
Also for the future: it’s best you describe one topic per… well… topic! because the more topics you create per topic, the less likely you’ll find someone to answer all of your topics because they need to be an expert on all of them whereas a simple precise topic will have a much higher chance of being answered.

As you seem to be coming over from Windows, please read this:

Note 1: No, we don’t charge more if you create more topics: there is no need to cram all of your questions into one topic! :wink: :grin:


That’s an awesome hack. Thanks.

I am not coming from Windows, but from an earlier version of KDE, in which “switch user” was a GUI option. And it is indeed a GUI option in Xfce, to this very day.

Please note that the OP (which I edited as requested) is not quite as rambling and random as it seemed. The topic is difficulty with switching between user accounts.

Thanks again for resolving my issues!

1 Like

I’ve never noticed as I do things differently, but apparently there was a feature to switch users and it’s gone since the last update (bug) and will come back: :man_shrugging:

Once you get used to my system, you won’t need it any more though as the switching to another console thingy has been working since KDE 3… :grin:

1 Like

Would be nice to have a GUI login screen on selected VT’s :wink:
Do you know how to set a systemd unit to make that happen?

Please open a new topic for that as what you’re asking is not directly related to OP’s question and is considered “Thread Hijacking”. :grin:

*No harm done, you’re new here, just don’t persevere posting in this thread… :slight_smile:

I tried Manjaro “testing” channel, and “switch user” has already reappeared in the GUI. Although I must admit that the @Fabby method is faster and more reliable.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.