Keyboard input reverts to secondary language after reboot

i have Manjaro installed in English(US) and added my native language as a secondary language.
since a few days after reboot,my SDDM is in English(typing password with no issues)but on the desktop the default keyboard input is in my native language.
i already checked all the KDE setting to see the language priority and also the Manjaro settings.
i have KDE set to start with an empty session.
I’ve found quit a few possible solutions online,but thought I’d ask here first before applying them.

locale -a

seems off,they all point to my native language.
layout_memory.xml also shows the current layout as my secondary language.
kxkbrc shows english first.

any idea what might have caused this and how to revert it?

Edit: in Wayland it works fine,i get US on startup.