Keyboard hangs sometimes for minutes: OS not responding to keyboard input


the keyboard input sometimes does not get registered by the OS. The keyboard input randomly stops working, even though the mouse and touchpad are still working. After a while (couple of minutes) it usually resolves. If not, I need to restart the computer. I tried plugging in an external keyboard when this occurs, but that does not work either.

This issue started when I reinstalled my system with hard drive encryption (LUKS). Before the reinstall I never noticed this problem.

The interesting thing is, that when I press the caps lock key, the indicator light of the caps lock key starts lighting, which tells me that this is not a hardware issue. I can toggle the caps lock without a problem, but none of the other keys seem to get registered by the OS.

Also, if I open up a terminal with my mouse, then the cursor block is not solid, but just has an outline, the same way when the terminal window is not focued. What I mean by this is that when everything is OK and the keyboard works and I open up a new terminal the terminal has this type of cursor: █ (block that is filled)

But when I open up a terminal in this “halted” state, when the keyboard is not responding it is like this (just like as it would be when a terminal is open but it is not the focused window): ▯ (block that is not filled)

Also, this issue occured more often after starting the system, but after I removed psensor from application autostart, it almost never occured anymore on startup.

I don’t know what could be the cause of this, but I suspect that some process could “halt” all keyboard input for some time. Any help is appreciated.

Here is the output of inxi -Fazy:

  Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=61a927f8-0135-4924-91d0-bb2ed9d0b728 rw quiet
  root=/dev/mapper/luks-683ef627-fbd6-42b9-83f8-483f6126a588 apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: Inspiron 15 5501 v: N/A serial: <filter>
  Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 0C3R3K v: A00 serial: <filter> UEFI: Dell v: 1.3.0
  date: 05/20/2020
  ID-1: BAT0 charge: 53.0 Wh (100.0%) condition: 53.0/53.0 Wh (100.0%)
  volts: 16.8 min: 15.0 model: SMP DELL 9077G06 type: Li-poly serial: <filter>
  status: Full
  Info: Quad Core model: Intel Core i5-1035G1 bits: 64 type: MT MCP
  arch: Ice Lake family: 6 model-id: 7E (126) stepping: 5 microcode: A6 cache:
  L2: 6 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  bogomips: 19048
  Speed: 1276 MHz min/max: 400/3600 MHz Core speeds (MHz): 1: 1276 2: 1302
  3: 1300 4: 1302 5: 1300 6: 1274 7: 1300 8: 1251
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Plus Graphics G1 vendor: Dell driver: i915 v: kernel
  bus-ID: 00:02.0 chip-ID: 8086:8a56 class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
  bus-ID: 3-6:3 chip-ID: 0bda:5538 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver:
  loaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x194mm (13.5x7.6")
  diag: 395mm (15.5")
  OpenGL: renderer: Mesa Intel UHD Graphics (ICL GT1) v: 4.6 Mesa 21.2.3
  direct render: Yes
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Dell
  driver: snd_hda_intel v: kernel alternate: snd_sof_pci bus-ID: 00:1f.3
  chip-ID: 8086:34c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: yes
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
  bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
  driver: btusb v: 0.8 bus-ID: 3-10:4 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 476.94 GiB used: 339.73 GiB (71.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 512GB
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 11001101 temp: 35.9 C scheme: GPT
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%)
  used: 339.7 GiB (72.6%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
  mapped: luks-683ef627-fbd6-42b9-83f8-483f6126a588
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 448 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2671
  Processes: 315 Uptime: 9h 8m wakeups: 10814 Memory: 15.41 GiB
  used: 7.09 GiB (46.0%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1701 lib: 431 flatpak: 0 Shell: Bash v: 5.1.8
  running-in: xfce4-terminal inxi: 3.3.08

I’m having a similar problem on a budget HP laptop with the built in keyboard. If I plug in an external keyboard that works just fine. I’m running a fresh install and have updated and only added a few packages. It worked fine for the first day, but today it stopped working sometimes. One time I got distracted with something else for about 20 minutes and when I came back it was working again until I put the laptop to sleep. Restarting did not fix my issue.

Few days ago i had a similar issue. Most noticeable in LibreOffice, but also in other programs.
After removing some extensions to LibreOffice this problem disappeared in LibreOffice, but also outside. I have no clue why this may have affected programs outside, but the problem disappeared completely. :rofl:

  • -R libreoffice-extension-languagetool
  • -R libreoffice-extension-pepitocleaner